Jump to content

[Guide] SurfacePro 1 & 2 Osx-Android-Windows multiboot


  • Please log in to reply
2621 replies to this topic

#2621
DO3SHA

DO3SHA

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Surface Pro 2

 

I have OS X Mavericks 10.9 installed on my Surface Pro 2 4300u. I am having issues with NullEthernet (Rehabmans) not working properly on my Surface. I have installed Avastar kext for Bluetooth. Also added the ralink2870 driver with Bear Extender to connect via WiFi. Since I have removed all devices from Network. Removed networksettings.plist as-well as any network related kexts. i use kext utility to add the nullethernet kexts(both) and load them just fine. Reboot without kexts and injections still get no option for Ethernet in Network Settings. Am I doing something wrong? I also do understand about the serial number and how to  generate them, but that is irrelevant if I cannot even get Ethernet to show in my Network Prefs to get a valid serial for the Appstore/Facetime etc. 

 

Edit

 

Got it was having an issue compiling my dsdt


Edited by DO3SHA, 21 December 2016 - 05:35 AM.


#2622
willycrook777

willycrook777

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Hi! This guide was amazing! I have an Microsoft Surface Pro 2 256gb SSD working like a charm on OSX Yosemite and trying the Touch Base drivers right now (they seem to work really well!).

 

Thanks for all the efforts!

 

Now, first some explanation and then the question:

 

This is the second Surface Pro 2 I have. The first one has a 128Gb SSD so I couldn't use OSX because of the well known freeze problem with that specific SSD. So I got another with 256gb, buoght via Amazon. It came and it is almost new! just one little scratch in one edge. 

 

So, this 256Gb machine is having just one problem: The (not well documented) blinking orange light on the right of the tablet, inside the vents. 

 

As I found in some posts, it appears that it's a big problem... Some said it was the video, etc. Most of the people recommended and/or sent the machine to Microsoft. In my case, it's late for that and also I live in Argentina, so it's almost impossible to send it to them.

 

What I have found is that when I use a Windows 8.1 USB (not an installer but an installation) the orange light doesn't blink, it is off. Whenever I load OSX from my SSD the light starts blinking. Nothing more happens, everything goes well!

 

Also, if I enter into the BIOS it also starts to blink.

 

I checked CPU Temp and it's on 60°C. Using a video benchmark test it goes up to 80°C. 

 

Also I did the Microsoft Diagnose Tool and it came with an error in the Microsoft Assesment Test - (DX DMA Error) most of the time but not always.

 

When I check the first Surface Pro 2 128Gb with the same test, I get the same error but less frequently.

 

Now for the question: Do you have the same blinking light in your Surface Pro 2? 

 

Thanks!

 

 







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy