Jump to content

HD4000 problems with Lenovo Z500

Hd 4000 Lenovo Z500

  • Please log in to reply
9 replies to this topic

#1
bullfroglou

bullfroglou

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

Hi all,

 

I got my new laptop a week ago and have been struggling with its HD 4000 Graphics Card after Mountain Lion was installed. I use clover as bootloader and have been able to fix most of the problems at this point. Yet I still cannot turn on the QE/CI with my graphics card. I tried the "magic code", EDID Injection, also followed some DSDT modification methods in the forum, but still with no luck. So frustrated at this point. Can anyone help me with this? The dsdt file is attached. I made some patches on it (like Audio fix, DTGP etc.), but left the graphics part untouched. Along with it, I also put my Clover config file and my Display rom file in there. 

 

Hardware information is as follows:
CPU:i7-3612QM
Graphics:HD 4000
Audio:ALC269
Wireless:Intel Centrino Wireless-N 2230 (substituted with a USB Wireless Adapter)
Lan:ATL810X
Touchpad:Elan (Multi-touch is malfunctional)
RAM:8GB
HD:1T

 

Thanks!

Attached Files



#2
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,753 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

about hd 4000

 

Intel HD 4000

 

u can use clover to do that...

 

or u can try new keys in chameleon

 

good hack



#3
bullfroglou

bullfroglou

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

hello

 

about hd 4000

 

Intel HD 4000

 

u can use clover to do that...

 

or u can try new keys in chameleon

 

good hack

Thank you sir. Followed your post, I realized I deleted those graphics-related files to get the installation done so there's no plist file in AppleIntelFramebufferCapri.kext. So I replaced all the kext files with the original ones and it worked!



#4
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,753 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

nice to know.. enjoy now ...

 

good hack



#5
pogano

pogano

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Hi.

I also have Lenovo Z500. I'm using Clover bootloader and EDID injection like bullfroglou.

I can't get QE/CI to work (no kext loaded)

 

OSX 10.8.5

 

PS. I think that SMBIOS for Z500 with HD4000 should be MacBookPro9,1 instead of 9,2?



#6
pogano

pogano

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Everything is working now, even second HDMI display with full qe/ci.

My EDID was 0x0166003

 

Just can't run ALC269 on Z500.



#7
bullfroglou

bullfroglou

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

Hi.

I also have Lenovo Z500. I'm using Clover bootloader and EDID injection like bullfroglou.

I can't get QE/CI to work (no kext loaded)

 

OSX 10.8.5

 

PS. I think that SMBIOS for Z500 with HD4000 should be MacBookPro9,1 instead of 9,2?

I'm using MacBookPro9,2 as my SMBIOS configuration now. Clover does not support MacBookPro9,1 anyway. 

If you are looking for a ALC269 kext, I suggest you to search "Lenovo Z580 ML Installation" in Google to find the solution.



#8
pogano

pogano

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Thank you bullfroglou.

Almost everything is working now (except internal microphone).



#9
bullfroglou

bullfroglou

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

Thank you bullfroglou.

Almost everything is working now (except internal microphone).

Yeah, I have no clue how to fix the mic either.



#10
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

bullfroglou , Please edit your post!!!

 

 

 

For all those who don't yet know our position about tonymac, and your ##### software, your Forun, Tolls, links, thank you for reading  http://www.insanelym...ort-tonymacx86/   

 p.s : pls read the forum rules  !!! 

InsanelyMac doesn't support tonymac's tools.







Also tagged with one or more of these keywords: Hd 4000, Lenovo, Z500


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy