Jump to content

10.8.5 vanilla kernel still doesn't work on Haswell Engineering Sample CPUs


  • Please log in to reply
5 replies to this topic

#1
rgb

rgb

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

Hi

 

I have the same problem like here: http://www.insanelym...ng-sample-cpus/


I can use modified kernel to boot only


With vanilla kernel, the screen stay black and nothing load after chameleon boot partition selection

 

I really want to use vanilla kernel, is there any solutions for this? 

Pls help, Thanks

 

Here are the source/changes of the working modified kernel for me, compared to the Apple stock

http://pastebin.com/JPmXagCc


Edited by fantomas1, 22 September 2013 - 10:48 AM.
topic edited to be not removed


#2
bikinifarm

bikinifarm

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 138 posts
  • Gender:Male
  • Location:Chicago, Illinois

Also does not work with my motherboard either and i5-467k (release). I am waiting for 10.8.5 source to see what they have changed from 10.8.4. Same is true for 10.9 (DPx).

 

http://www.insanelym...ith-108-server/



#3
rgb

rgb

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

Also does not work with my motherboard either and i5-467k (release). I am waiting for 10.8.5 source to see what they have changed from 10.8.4. Same is true for 10.9 (DPx).

 

http://www.insanelym...ith-108-server/

Very weird

Many user reported 10.8.5 works oob with their machine

One user here are using very close hardware as my mine, which is 4770k, Asus z87 pro, gtx 660ti (i use 660)

He works everything with vanilla 10.8.5

I have compared his BIOS setting with my mine and we are the same (actually he is using the default settings)

So the only problem I can think about is ES cpu...

 

However, after heard that your retail one also cannot be use, it's time to think about another potential issue of us



#4
bikinifarm

bikinifarm

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 138 posts
  • Gender:Male
  • Location:Chicago, Illinois

Very weird

Many user reported 10.8.5 works oob with their machine

One user here are using very close hardware as my mine, which is 4770k, Asus z87 pro, gtx 660ti (i use 660)

He works everything with vanilla 10.8.5

I have compared his BIOS setting with my mine and we are the same (actually he is using the default settings)

So the only problem I can think about is ES cpu...

 

However, after heard that your retail one also cannot be use, it's time to think about another potential issue of us

I believe there are many people reporting success with my CPU (but I am not even sure if anyone else uses the same Intel motherboard). So, I am puzzled as well. I used MinHack's method to install 10.8.5 and revert back, and I am running 10.8.5 now. But with a 10.8.4 modded kernel. 



#5
rgb

rgb

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

I believe there are many people reporting success with my CPU (but I am not even sure if anyone else uses the same Intel motherboard). So, I am puzzled as well. I used MinHack's method to install 10.8.5 and revert back, and I am running 10.8.5 now. But with a 10.8.4 modded kernel. 

may i know where is MinHack's method?

TY



#6
bikinifarm

bikinifarm

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 138 posts
  • Gender:Male
  • Location:Chicago, Illinois

http://www.tonymacx8...7.html#comments

 

(look for MiniHack)

 

or

 

http://www.tonymacx8...m-gt-240-a.html

 

download toTry zipped file.

 

here, you can find MiniHack:

 

http://www.insanelym...55812-minihack/







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy