Jump to content

Packard Bell TK85 - USB Issues

usb card reader fix

  • Please log in to reply
5 replies to this topic

#1
Kataryno

Kataryno

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Portugal

Hello, 

Recently I finally complete the installation of ML on my laptop PB TK85. After struggling a bit with the graphics card, i managed to make it fully functional. The wireless ,ethernet and sound cards are ok either. 

However there is one issue with the USB that i cannot solve. The 3 USB ports sometimes work, other don't . I have to reboot the PC a few times to make it work. My laptop have am integrated web cam and card reader and I saw that when this peripherals are loaded, the USB ports not and vice-versa. Because I need more the USB ports I don't mind uninstall the kexts responsible for the camera and card reader, the problem is i don't know specifically which they are. 

So if anyone every experienced the same situation can point me in the right direction to solve the issue?

Thanks in advance



#2
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,755 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

probably need to patch u dsdt..

 

good hack



#3
Kataryno

Kataryno

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Portugal

It's strange why sometimes it recognize the USB ports others only the card reader and webcam.

 

im not familiarly with patching DSDT, can you point me something to read about it?

 

Thanks 



#4
Kataryno

Kataryno

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Portugal

UPDATE:

 

I think i found the kext responsible to start up the USB ports. Below i have a picture of the kexts loaded when USB ports are fine:

 
67441d1379360826-packard-bell-tk85-usb-i
 
 
This is the picture when USB ports are down but the card reader and camera works:
 
 
67442d1379360847-packard-bell-tk85-usb-i
 
I spot the difference on IOUSBHIDDriver.kext, so I think that is the one i need to load, despite of IOUSBMassStorage. So i deleted this one, repaired permissions and rebuilded the cache and yesterday it worked ok. Made severals reboots to confirm and all with success, always loaded the USB ports. However today i turned on the PC again, and the IOUSBHIDDriver.kext didn't load. Curiously despite of IOUSBMassStorage has been removed, the card reader and web cam loaded normally. I had to repair permissions again and rebuild the cache to USB ports work again.

What are your thoughts about this, there is any more suggestion to deal with this problem?



#5
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,755 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

olá

 

o k é estranho é estarmos os 2 aki a falar em inglês.. ainda mais com 1 forum em português

 

teu note é praticamente igual ao meu.. n tenho nada desses problemas

 

bom hack



#6
Kataryno

Kataryno

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Portugal

LOL, nem reparei que também eras português...

 

Mas finalmente consegui por isto a funcionar. Fiz como disseste, patch do DSDT e no reboot seguinte reconhece já tudo, USB, cartões, camera, etc.

 

Já agora aproveitando que és moderador, se puderes encerrar o tópico agradecia, já que está tudo resolvido.

 

 

 

Everything is solved by now. Patched the DSDT and now recognizes every peripheral.







Also tagged with one or more of these keywords: usb, card, reader, fix


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy