Jump to content

ASUS Sabertooth X79 - Ivy Bridge-E - 4930k


  • Please log in to reply
227 replies to this topic

#61
jasjeet

jasjeet

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 257 posts

I have played with the Bios settings to no end, is there anything specific i need to change?

 

I have disabled Speedstep and C States and left Turbo enabled to use a Multiplier of x45 but it doesn't work.



#62
jvolkman

jvolkman

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

 

Actually not know if this problem has to do with the patch kernel but trying to see with this
 

 

Can you list what you patched in the kernel so it can be done to subsequent updates until Apple releases native support?



#63
stinga11

stinga11

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts

Can you list what you patched in the kernel so it can be done to subsequent updates until Apple releases native support?

I use the following patch in a hex editor

 

eb1183f83TO eb1183f83e



#64
Music Producer

Music Producer

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

Sabertooth x79 and 4930k here. i've gotten all osx versions for run with patched kernels. but i can only get QE/CI in snow leopard because i have a ati 5970. but in all the osx installs my external apogee one usb audio interface has skipping audio in everything. anyone have any ideas what would be causing this skiping audio? is it the pached kernel? is there something i can modify to get audio working without the skipping? would popping in a 3930k fix it? my previous hack was a 980x cpu on a rampage iii extreme. had no audio problems.



#65
mr. west

mr. west

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts

Thanks for the help everyone.  I've got Mavericks running on my Sabertooth X79 and 4930k now.  Great.  I used the patched kernel posted.  So far so good!

 

Hopefully the Mac Pro will come out soon enough and we can get native everything. 

 

Music Producer:  I roll back to some old drivers on the Sabertooth and have no issues with native audio.  Not sure about the external card though.



#66
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,975 posts
  • Gender:Male

Thanks for the help everyone.  I've got Mavericks running on my Sabertooth X79 and 4930k now.  Great.  I used the patched kernel posted.  So far so good!

 

Hopefully the Mac Pro will come out soon enough and we can get native everything. 

 

Music Producer:  I roll back to some old drivers on the Sabertooth and have no issues with native audio.  Not sure about the external card though.

 

Roll back is not longer needed ;)



#67
Music Producer

Music Producer

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

Roll back is not longer needed ;)

It's definitely something to do with the CPU. To test it I went out and bought a 3930k

I use USB audio from a apogee one (used for studio work)

With the 3930k it works with no problems, no stuttering in snow Leo, lion, mountain lion, and mavericks.

With the 4930k I get stuttering audio in all osx installs.

Power management aside for the overclocking and turboboost, p-states, I'll never get the kernel support for snow leopard.

I'm hoping to retest this issue with the usb audio stuttering once ib-e support is written into the mavericks kernel. As far as the other osx installs, I think I'll always get stuttering usb audio, ESP in snow leopard because of no ib-e support.

Edit: just to fully test this issue, I used a pci-e USB 2.0 add on card that was made for Mac to work natively with osx. I Reinstalled every osx version with a clean install, and hooked the apogee to the USB addon card. Still get audio stuttering in every install with the 4930k. Not sure why.

#68
stinga11

stinga11

    InsanelyMac Protégé

  • Members
  • PipPip
  • 69 posts

It's definitely something to do with the CPU. To test it I went out and bought a 3930k

I use USB audio from a apogee one (used for studio work)

With the 3930k it works with no problems, no stuttering in snow Leo, lion, mountain lion, and mavericks.

With the 4930k I get stuttering audio in all osx installs.

Power management aside for the overclocking and turboboost, p-states, I'll never get the kernel support for snow leopard.

I'm hoping to retest this issue with the usb audio stuttering once ib-e support is written into the mavericks kernel. As far as the other osx installs, I think I'll always get stuttering usb audio, ESP in snow leopard because of no ib-e support.

Edit: just to fully test this issue, I used a pci-e USB 2.0 add on card that was made for Mac to work natively with osx. I Reinstalled every osx version with a clean install, and hooked the apogee to the USB addon card. Still get audio stuttering in every install with the 4930k. Not sure why.

Hey, you can test your ivy-e in snow leopard if you use this kernel:

http://www.osx86.net...w-leopard-10-6/



#69
mr. west

mr. west

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts

Roll back is not longer needed ;)

 

I've tried the Toleda solutions in your unified DMG but haven't had luck.  Also get KP with the included DSDT, but that's, I think, because my BIOS is a newer version. So I use a DSDT free solution and roll back old drivers from Lion and sound works.  Does the job for now. 

 

In any event, I'm using the Sabertooth X79 with a 4930k.  I'm running fine on Mavericks now with the modified kernel.  I can boot without NULLCPU, VoodooTSC, or an ACPI file.  However, I cannot yet get pstates/cstates generating properly.  Nor can I get the system to recognize an overclock, it just runs at the stock 3.4 Ghz.  Also, when I upgrade to the latest FakeSMC I cannot boot and got all sorts of USB errors.

 

So I've got a workable install for sure, but I think I'll wait till the Mac Pro release to try to get everything working 100%.

 

19,600 on Geekbench running native aint bad!



#70
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,975 posts
  • Gender:Male

I've tried the Toleda solutions in your unified DMG but haven't had luck.  Also get KP with the included DSDT, but that's, I think, because my BIOS is a newer version. So I use a DSDT free solution and roll back old drivers from Lion and sound works.  Does the job for now. 

 

In any event, I'm using the Sabertooth X79 with a 4930k.  I'm running fine on Mavericks now with the modified kernel.  I can boot without NULLCPU, VoodooTSC, or an ACPI file.  However, I cannot yet get pstates/cstates generating properly.  Nor can I get the system to recognize an overclock, it just runs at the stock 3.4 Ghz.  Also, when I upgrade to the latest FakeSMC I cannot boot and got all sorts of USB errors.

 

So I've got a workable install for sure, but I think I'll wait till the Mac Pro release to try to get everything working 100%.

 

19,600 on Geekbench running native aint bad!

 

Thanks for the feed back. Wondering if a DSDT extract per CPU gen installed is the issue... can you post a DSDT and IOreg and I will take a look. Thanks. 



#71
mr. west

mr. west

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts

Thanks for the feed back. Wondering if a DSDT extract per CPU gen installed is the issue... can you post a DSDT and IOreg and I will take a look. Thanks. 

Here are DSDT extracts and IOReg:

 

https://www.dropbox....h-bios-4302.dsl

https://www.dropbox....abertooth.ioreg

 

Thanks!



#72
jasjeet

jasjeet

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 257 posts

Good that im not the only one who's OC is not working in Mavericks, its definaltey just with the ivy-E's though, it worked fine with my 3960X.

 

Also I the AICPM kexts refuse to load at all as they detect an unsupported CPU, thats why we have no C/P states i believe, could be related to the OC as well.



#73
maleorderbride

maleorderbride

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 275 posts
  • Gender:Male

Can someone upload the modified 10.8.5 kernel that they are using with IvyBridge-EP?  I have an E5-2697 V2 arriving tomorrow!

 

I tried to search in Hexedit to change  eb1183f83TO eb1183f83but the string does seem to be in the 10.8.5 kernel.  Am I missing something? 



#74
mr. west

mr. west

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts

Can someone upload the modified 10.8.5 kernel that they are using with IvyBridge-EP?  I have an E5-2697 V2 arriving tomorrow!

 

I tried to search in Hexedit to change  eb1183f83TO eb1183f83but the string does seem to be in the 10.8.5 kernel.  Am I missing something? 

 

I used this:

 

http://www.osx86.net...pic-fix-kernel/


Good that im not the only one who's OC is not working in Mavericks, its definaltey just with the ivy-E's though, it worked fine with my 3960X.

 

Also I the AICPM kexts refuse to load at all as they detect an unsupported CPU, thats why we have no C/P states i believe, could be related to the OC as well.

 

 

I'll add that the OC didn't work in Mountain Lion or Mavericks.   I think most of this will get resolved with the Mac Pro release and the kernel from that becomes available.

 

One weird clue, though.  My OC does get recognized when I boot from the USB installer but load into the regular OS.  Not sure why.  Once I use a native bootloader, however, the OC gets lost.



#75
maleorderbride

maleorderbride

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 275 posts
  • Gender:Male

I used this:

 

http://www.osx86.net...pic-fix-kernel/


 

 

I'll add that the OC didn't work in Mountain Lion or Mavericks.   I think most of this will get resolved with the Mac Pro release and the kernel from that becomes available.

 

One weird clue, though.  My OC does get recognized when I boot from the USB installer but load into the regular OS.  Not sure why.  Once I use a native bootloader, however, the OC gets lost.

Thanks for that link!  I did not realize that the 10.8.4 kernel would work in 10.8.5.

 

Interesting about the OC--so if you use use the same version of the bootloader on a USB and then boot the main drive then it works?  Or is the USB installer using a different version of the bootloader than what you normally have installed to the drive?  It never occurred to me this could be a bootloader issue.  I have been having problems with this myself.

 

Also, if you want the OC now, you can always OC via BCLK instead.  I ended up resorting to that myself =/



#76
jasjeet

jasjeet

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 257 posts

Heres 4.5Ghz with bclck OC and Ram at 2000Mhz CL11 in 10.9

f7JJfEus.png

 

About 600 points higher than 10.8.5



#77
mr. west

mr. west

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts

Heres 4.5Ghz with bclck OC and Ram at 2000Mhz CL11 in 10.9

f7JJfEus.png

 

About 600 points higher than 10.8.5

Nice one.  I pushed my 4930k to 4.5 and got this result:

 

http://browser.prima...ekbench3/125656

 

 

24,000+.  Not bad.  But with that aggressive overclock it was only recognizing 24gb of memory, not 32.  Probably could figure that out but I can't be bothered.

 

Toned it down a little for now... running at 4.25ghz. 23,000+ on Geekbench 3.

 

In Windows I topped 25,000, I think, using a normal multiplier overclock, which was sweet.  Mac Pro Kernel will solve a lot of issues.

 

Sweet rig though.

 

Honestly it's so fast running stock... will I notice a difference?  Not sure!



#78
jasjeet

jasjeet

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 257 posts

Probably not notice a difference at all lol Just do it for fun.

 

You probably needed more VCCSA (IMC) and VTT Voltage at 32GB ram, maybe around 1.1v for both.



#79
Music Producer

Music Producer

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

Hey, you can test your ivy-e in snow leopard if you use this kernel:

http://www.osx86.net...w-leopard-10-6/

gave it a try, same skipping audio problem.



#80
HERFNERDERZ

HERFNERDERZ

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
  • Gender:Male
  • Location:Seattle, Washington

RampageDev.

Can we expect a guide on this build?

 

Thanks







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy