Jump to content

ASUS Sabertooth X79 - Ivy Bridge-E - 4930k


  • Please log in to reply
227 replies to this topic

#41
mr. west

mr. west

    InsanelyMac Protégé

  • Members
  • Pip
  • 48 posts

Welp, GM still no IB-E support.  Oh well!



#42
jasjeet

jasjeet

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 249 posts

We need that guy to patch the 10.9 kernel as well, but i think we need to wait till Apple release the kernel source, maybe a couple of months.



#43
stinga11

stinga11

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts

We need that guy to patch the 10.9 kernel as well, but i think we need to wait till Apple release the kernel source, maybe a couple of months.

I patch 10.9 GM mach_kernel but not know if it works so try it and tell me if it works

 

credits to PikeRAlpha for the original patch for haswell on 10.8.4
 


#44
jasjeet

jasjeet

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 249 posts
Wow thanks I'll see if the DP boots to try install 10.9 as I don't have the GM yet.

Can you share more info on how you patch the kernel?

#45
stinga11

stinga11

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts

Wow thanks I'll see if the DP boots to try install 10.9 as I don't have the GM yet.

Can you share more info on how you patch the kernel?

I use the following patch in a hex editor

 

eb1183f83a TO eb1183f83e



#46
jasjeet

jasjeet

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 249 posts

Well it gets to start loading OSX, in verbose i can see the following:

 

Flags used: -v -f

Stuck at PCI Configuration

 

Flags used: -v -f npci=0x2000 PCIRootUID=0

Stuck at USBF and some other USBXHCI errors slightly before hang.

 

This is with the DP however, so i will use myhack to make the bootable installer with GM now.



#47
stinga11

stinga11

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts

Well it gets to start loading OSX, in verbose i can see the following:

 

Flags used: -v -f

Stuck at PCI Configuration

 

Flags used: -v -f npci=0x2000 PCIRootUID=0

Stuck at USBF and some other USBXHCI errors slightly before hang.

 

This is with the DP however, so i will use myhack to make the bootable installer with GM now.

Apparently the patched kernel works your problem is that you try to use the Gm kernel on DP build

 

Another thing, When you prepare your custom kext ,use only Fakesmc and NullCPUPowerManagement if you use the latest bios update for your motherboard I don't think you need the VoodooTSCSync. About the chameleon flags, For the first boot use -v -f and npci=0x2000



#48
jasjeet

jasjeet

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 249 posts

Im using the patched Kernel on the GM now, stuck at hfs: Mounted myHack OS X Install Disk, just hangs after that.

 

Running myFix on the installer to see if there was a permissions issue.

 

Out of ideas, tried latest Chameleon Bootloader too.

 

Hangs at hfs: Mounted myHack OS X Install Disk to root_device.



#49
stinga11

stinga11

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
Actually not know if this problem has to do with the patch kernel but trying to see with this
 


#50
jasjeet

jasjeet

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 249 posts
Excellent it's installing now =)

#51
stinga11

stinga11

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts

Excellent it's installing now =)

Works? which of the two kernel works for you?



#52
jasjeet

jasjeet

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 249 posts
2nd one you posted worked

#53
stinga11

stinga11

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts

2nd one you posted worked

Nice, Hey if you can post a geekbench score



#54
jasjeet

jasjeet

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 249 posts

Sure, this is at stock clocks. My over clock doesn't apply in OSX for some reason.

 

NmebdUo.png



#55
stinga11

stinga11

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts

MAN your processor is awsesome



#56
jasjeet

jasjeet

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 249 posts

haha yeah its pretty quick.

 

I just need to figure out how to get OSX to work with Multiplier overclock, it only responds to BCLK overclock atm. Ive tried disabling C States and Speedstep but it doesn't work.



#57
calciumantacid

calciumantacid

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
  • Gender:Male

Does this mean I can finally build my 4930k hackintosh I've been dreaming about? I was waiting for OS X compatibility, it looks like you guys figured it out. I still need to decide on a motherboard, currently torn between P9X79 Pro and X79-UP4.



#58
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,949 posts
  • Gender:Male

Just want to clarify about IVY-B E support under Mac OS X. 

 

Apple has only been using internal builds of Mac OS X to test the new Mac Pro which uses this chip gen. Once Apple releases the new Mac Pro native kernel support will exist and no more patching will be needed. Apple did this so that not to much info about the new Mac Pro could be discovered.  

 

Hope this clears a few things up.



#59
jasjeet

jasjeet

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 249 posts

Well things that have problems on P9X79 Pro currently:

 

Non native power management- Speedstep doesn't work fully (only switch between 1.2-3.6Ghz nothing in between). Most likely fixed when next Mac Pro releases.

To make USB 3.0 Ports work the GenericXHCIUSB kext needs to be installed - This causes instant wake from sleep.

Sleep - see above, works without that USB 3.0 kext fine.

Cannot detect CPU Core temperatures, FakeSMC needs updating. CPU Case temp is reported along with Power usage, VCore and Speed.

Cant get Multiplier Overclock to work.

 

I haven't tested Bluetooth and eSATA.



#60
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,949 posts
  • Gender:Male

Well things that have problems on P9X79 Pro currently:

 

Non native power management- Speedstep doesn't work fully (only switch between 1.2-3.6Ghz nothing in between). Most likely fixed when next Mac Pro releases.

To make USB 3.0 Ports work the GenericXHCIUSB kext needs to be installed - This causes instant wake from sleep.

Sleep - see above, works without that USB 3.0 kext fine.

Cannot detect CPU Core temperatures, FakeSMC needs updating. CPU Case temp is reported along with Power usage, VCore and Speed.

Cant get Multiplier Overclock to work.

 

I haven't tested Bluetooth and eSATA.

 

Temps have absolutely nothing to do with FakeSMC. The plugins are at fault.

 

OC is a BIOS setting issue and has nothing to do with Mac OS X.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy