Jump to content

Maximus VI Gene issues

  • Please log in to reply
21 replies to this topic



    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Thank you DK-RendeR, you've inspired my config files ;)

This is my modification that worked in its particular form on the following hardware:


Asus Z87 Maximus VI Gene (C2 stepping version)

i5 4670k

Vengeance Pro 16GB

Belkin Bluetooth USB stick (F8T016)


MyHack method works for me very well and I have reached 100% functionality with this Mavericks build.

1. Maximus VI Gene was patched for native AppleIntelCPUPowerManagement.kext
PMPatch UEFI Boards

2. M6G with my BIOS version (0804) does not allow booting from a non-MBR partition i.e. GUID partitions are not recognized, therefore all formatting is done with MBR.

- format your USB stick, and target Disk using Options: MBR - Extended Journaled

3. Install MyHack onto the formatted USB Stick (you will need to extract the proper dmg from your App Store app), accept all changes.

4. Modify the installation USB stick before attempting to boot.
    a. Use Pacifist on Chameleon-2.2svn-r2265.pkg and extract Boot file, copy that file to root of the USB Stick
    b. Apply MBR patch so that OSX installer will allow for an MBR partition installation:
    MBR Patch

5. Install system as normal, accept myHack changes

6. Post-installation modifications

- After the installation my system would/could not boot. That was due to MyHack failing to install the proper bootloader.

- For me the simplest solution was to plug the SSD into my mac and install Chameleon 2.2 r2265 on it.

I've used following settings:
Install Bootloader
Graphics Mode=1920x1080x32
GraphicsEnabler=Yes ------------------disabled for the Asus (see my update below)
Instant Menu=Yes
IntelAzulFB=10 -------------------------disabled for the Asus (see my update below)

- Note that with the IntelAzulFB I'm activating my integrated HD4600 on the board - it is fully operational with all hardware acceleration and QE/CI although before getting to desktop I do get weird flickering artifacts (none of that afterwards, probably some weird initialization step).

- Next I've followed RendeR's steps
    11 (replace Extra folder with his, for me with the exception of his DSDT, which doesn't work on my machine),
    13 (that particular kext didn't work for me - see below),
    14 (IntelE1000, AppleRTC, TrimEnabler, excellent :)

- By the time I was fully booted I've managed to mess up my ethernet interface, which switched the LAN to en1 instead of en0 (icloud doesn't work with that) so I had to reset my interfaces... twice ;) solution here:
iCloud fix en1/en0

- Next I installed HWSensors.5.3.873 and removed the now-duplicate FakeSMC from extras giving me full sensor support on the board and monitoring through Hardware Monitor or iStat Menus. This allows me to check the CPU status, stepping indeed seems to work, although I'm not sure entirely because I see it only jumping between 800 and 3,4GHz... still have to look into this later.

- Audio was a {censored}, for this ALC1150 codec (Asus SupremeFX) the only AppleHDA that worked was released by Mirone, version 2.5.2fc2 and I had to use the HDAEnabler included with it. Everything works including digital out.

My system is now fully operational, and next I'll be putting in my Atheros-driven LAN/Bluetooth combo card (into mPCIe slot on the Combo expansion card) and a TI-chip Firewire PCIe card, both should theoretically work OOB, after that I'll transfer my HD7970 and be done.

If you're hesitant about the Maximus VI Gene, don't be - it really does work.



Syba SD-PEX30009 works OOB as expected, TI XIO2213 chip (2x800, 1x400)



In case anyone is interested - Since our Maximus is rather limited in terms of internal USB connectivity I've expanded the on-board USB 2.0 with the internal hub:

NZXT IU01 Internal USB - works flawlessly, I've got 3 connectors running off of it including the IR-sensor mod:




1. AppleHDA from Marrone was only partially working - a reboot would disable/enable it randomly - he was however so nice to modify my DSDT - if someone wants it, let me know. Thanks Marrone!!  (DK-RendeR's DSDT didn't work for me)

2. Asus R9280X-DC2T-3GD5 works out of the box with all options including hdmi audio - no more fooling around to get the HD4600 to play nicely with the OSX

3. Logitech c920 works out of the box - UVC driver - Logitech released into the App Store an app called Logitech Camera Settings - fully supports c920, amazing quality.


This is probably my last update, I've got a 100% clean Hack running stable with all features of my real Macs + cheaper and faster.

I fully recommend the Asus motherboard even though getting the installation to start can be tricky.

Edited by Teq, 23 October 2013 - 06:47 PM.

The Real Deal

The Real Deal

    InsanelyMac Legend

  • Donators
  • 1,014 posts
  • Gender:Male
  • Location:France

Hey fellas,

Do you know if there is some AppleHDA (or a patch solution) floating around for ALC 1150 and 10.6.8 ?


My DSDT is edited for 1150 audio device



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy