Jump to content

Black screen on ML 10.8.4 installation


  • Please log in to reply
10 replies to this topic

#1
Newnick

Newnick

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Hello, insanelymac users! I'm addressing you with a sort of urgent problem with my Mac OS X installation. The problem is that I'm loading Chameleon on my PC just okay, after picking my mac volume I see that HFS+ files are loading. After they finished loading, there must be another bunch of texts but it isn't appearing. I see a black screen instead. Here is the video of what exactly happens:

http://www.youtube.c...h?v=6_1Gx6qSbQ8

The configuration of my computer:

I need an advice on how to run Mac OS X (no matter 10.8 or 10.9) on the PC with the configuration like that. Thanks in advance.



#2
heyadrien

heyadrien

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Male
  • Location:France
  • Interests:User-interface & Web designer

Try

 

-v GraphicsEnabler=no 



#3
Newnick

Newnick

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Same black screen.



#4
adamsweeting

adamsweeting

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 255 posts

I've had issues when asking OS X to boot verbosely (i.e. my machine will boot OK if I do a non-verbose boot, but will not boot with -v!)

 

Try:

 

-f cpus=1 npci=0x02000 GraphicsEnabler=no



#5
MOCKBA80

MOCKBA80

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

I cannot get my GT220 work with Haswell board either. On my board (asrock h87m-pro4) only 10.8.4 patched is booting and only with integrated GPU. When I put my GT220 in, it boots but I am getting black screen (and I believe GraphicsEnabler=no/yes has no effect). There is no option in BIOS to disable integrated GPU (just a way to enable PCIe video card) and I am afraid this may have something to do with that. Any idea what I might be missing?

 

GT220 was working fine for me for years with non-Haswell boards with retail installs, so my assumption that it is natively supported...



#6
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

NVEnabler.kext :)



#7
MOCKBA80

MOCKBA80

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

NVEnabler.kext :)

 

But I have Chameleon 2.x and GraphicsEnabler=Yes

Isn't it the same thing as old NVEnabler?

 

I don't remember last time I had to use NVEnabler, definitely prior to getting that GF 220GT



#8
MOCKBA80

MOCKBA80

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

Hmm, adding NVEnabler.kext powers up monitor but I am getting colorful blinking vertical and horizontal lines... 

 

I believe I've seen somebody reporting this problem... Any hints on how to fix that?



#9
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

make a EfiString for your card 



#10
jamiethemorris

jamiethemorris

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 781 posts
  • Gender:Male
  • Location:San Rafael, CA

On my nforce hack, I had the same issue (different nvidia card though), and a dsdt injection was required to get it to boot without a blank screen. I'm not 100% sure which patch it was since verdant did it for me, but I believe this is the one you need: http://rampagedev.wo...rd-into-a-dsdt/ . EFI string should work too, but in my case it did not. You should be able to either boot with -x, or if that doesn't work, temporarily move all the nvidia kexts out of the extensions folder, that's what I had to do.



#11
MOCKBA80

MOCKBA80

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

NVEnabler it was. Thanks guys. I had to use NVEnabler 64.kext http://www.osx86.net...1989-nvenabler/ with my GT 220.

 

Still don't understand why GraphicsEnabler=Yes didn't work out as with other boards, but oh well Haswell is too new I guess.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy