Jump to content

TP-Link WN727N (RT2870USBWirelessDriver.kext) Restart / Shutdown Problem


  • Please log in to reply
13 replies to this topic

#1
MNSiw

MNSiw

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts

I've installed Mavericks DP 1, everything worked out of the box except sound, used kext from Mountain Lion to enable it, at this point Shutdown and Restart working fine, but as install RT2870USBWirelessDriver.kext to enable my USB Wi-Fi, shutdown and restart stop working properly, system shutdown but cpu fan keep spinning and Wi-Fi light keep blinking, for restart I have to press restart button, if I uninstall RT2870USBWirelessDriver.kext shutdown and restart restore to normal. Other USB devices like keyboard, mouse and mass storage are working fine without any shutdown / restart issue.

 

Any sugesstion / solution for this problem?

 

Here are my hardware:

Intel DW61WW

i3-2100

GS8400

TP-Link WN727N

USB Keyboard & Mouse



#2
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

If everything except sound works otb, why install RT2870USBWirelessDriver.kext?  :D Anyway, after usual stuff like restart fix in boot loader or DSDT has been tried, check kext's dependancies, maybe need to roll back another kext like IOUSBFamily, etc.. If this is UHCI (USB 1.1) and all other devices are EHCI (USB 2.0) or 3.0, see if another USB 1.0 device that works otb can cause same problem. Process of elimination will eventually lead you to the cure.



#3
Mac Hosehead

Mac Hosehead

    InsanelyMac Protégé

  • Members
  • Pip
  • 35 posts

Interestingly, I had similar behavior using a real Airport card from an old Macbook Pro. It would not completely shutdown or sleep. I have used the card with success in other hacks. I also have a TL-WDN4800 and with it I have no sleep or shutdown problems.

 

Since this is a design preview I suppose you could try one of the kexts that are purposed to aid in the shutdown of problematic systems. It is just a bandage to an underlying problem but it might suffice for the present. I suspect you will need an updated wifi driver.

 

-MH



#4
MNSiw

MNSiw

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts

If everything except sound works otb, why install RT2870USBWirelessDriver.kext?  :D Anyway, after usual stuff like restart fix in boot loader or DSDT has been tried, check kext's dependancies, maybe need to roll back another kext like IOUSBFamily, etc.. If this is UHCI (USB 1.1) and all other devices are EHCI (USB 2.0) or 3.0, see if another USB 1.0 device that works otb can cause same problem. Process of elimination will eventually lead you to the cure.

Actually during installation USB Wi-Fi was not plugged in, that why everything else except sound worked OOB :-D may be it's USB 1.1 issue, but for now don't have any alternate. While trying different kexts, installed D-Link DAW-140 driver for OS X 10.6, feel like it improve Wi-Fi proformace little bit, but shutdown / restart problem is still there.



#5
ham4ever

ham4ever

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 296 posts
  • Gender:Male

i have exactly same problem , and if unplug my wireless USB then i get KP ,, and also restart/shutdown don't work 

 

have u solved it ??  any suggests 



#6
MNSiw

MNSiw

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts

i have exactly same problem , and if unplug my wireless USB then i get KP ,, and also restart/shutdown don't work 

 

have u solved it ??  any suggests 

No, it's same, after shutting down I wait for display and hard disk activity then just switch off from power button, no other solution for now, but its working fine this way :)



#7
ham4ever

ham4ever

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 296 posts
  • Gender:Male

is bit annoying  :)  doesnt break PC to force shutdown all time ?



#8
MNSiw

MNSiw

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts

is bit annoying  :)  doesnt break PC to force shutdown all time ?

Yeah it's annoying but all possible solutions need some money :) I using it this way for 7-8 months, no problem so far.

 

If somehow we can force kext to stop or unload before system restart or shutdown that may help, but I don't know about any such utility or tool that can do it. What's your opinion?



#9
cuneytkarayalcin

cuneytkarayalcin

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Check out the driver I uploaded at http://www.osx86.net...-mavericks-109/ - extracted from BearExtender Mavericks beta driver - WORKING NOW - restart is ok :) just drag drop to kext utility - the only problem i have had so far ... now solved :)



#10
MNSiw

MNSiw

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts

Check out the driver I uploaded at http://www.osx86.net...-mavericks-109/ - extracted from BearExtender Mavericks beta driver - WORKING NOW - restart is ok :) just drag drop to kext utility - the only problem i have had so far ... now solved :)

Great :) thanks for sharing, downloading.



#11
MNSiw

MNSiw

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts

Check out the driver I uploaded at http://www.osx86.net...-mavericks-109/ - extracted from BearExtender Mavericks beta driver - WORKING NOW - restart is ok :) just drag drop to kext utility - the only problem i have had so far ... now solved :)

 

Worked like a charm. Thanks. Now just front audio ports don't work.



#12
kbapk

kbapk

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Can someone help me launch usb wifi TP-LINK 727. My wifi card dosn supprot. Take this usb from work. And realy want launch it



#13
RAW2019

RAW2019

    InsanelyMac Protégé

  • Members
  • PipPip
  • 56 posts

Hi all,

 

Wanted to share how i fixed my Tp-link 727n in 10.8. It supposed to work also in 10.9.

 

I got version 4 which uses a mediatek chip (used to be realtek) 

 

I found it out using this site.

 

https://wikidevi.com...NK_TL-WN727N_v4

 

The other Version 4 is china only. 

 

Cause you need to get the chipset right. I got a MediaTek MT7601U

 

And there is a russian site that has all the 'old' drivers 

 

I used google translate to read it

 

https://applelife.ru...160-i-dr.41353/

 

I don't need to enter device ID or anything. It just worked straight after installing the drivers and a restart!

 

Also i can remove the stick without a KP. Haven't tried sleep but that doesn't work on my desktop anyway. But i think it works according to the text next to driver nr 2. ( my chipset)

 

Hope you all have luck with this ( i almost send the stick back today. It was only 10 euro) 

 

I very happy :))))) 



#14
MNSiw

MNSiw

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts

Can someone help me launch usb wifi TP-LINK 727. My wifi card dosn supprot. Take this usb from work. And realy want launch it

 

It's already solved, read the post above.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy