Jump to content

FX 6300 running 10.7.3 in 64 bit


  • Please log in to reply
6 replies to this topic

#1
FaefLemon

FaefLemon

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Hello, my name is Faef and I got OS X Lion 10.7.3 working on AMD Piledriver with Andy Vandjick FX Kernel (http://www.osx86.net...ion_10.8.2.html the one in the middle)

 

 My Hackintosh Pro:

FX 6300 @4.0 GHz

ASUS M5A97 EVO R2.0 (BIOS 1708)

AMD HD 6450 1 GB DDR3

4x 2GB DDR3 Kingston 1600 MHz

500GB HDD WD Caviar Blue SATA-II

Thermaltake 600W PSU

 

Used Niresh12495-Lion-10.7.3-V2 on a flash drive, and Chameleon 2.1svn 2069 in a CD-RW as booting device.

 

Kernel Flags:

-v "Kernel Cache"=\amd arch=i386

 

As default, Chameleon adds the "npci=0x3000" boot flag. Use it if needed.

 

Proceed to install as usual, but don't add any sound kext, or graphics kext. Just check "AMD" in kernels and finish the install.

 

Chimera won't work with this configuration.

 

If the install was successful, you should be able to boot from the HDD.

 

In System Report, it'll show that you are using a 32-bit kernel without 64-bit extensions, and the graphics card will show as "AMD HD6xxx 1024MB". That's normal, the new kernel fix this.

 

Make a folder in the root of your HDD and name it "kernel" (it can have any other name, this one comes in handy)

If you can boot to the 32 bit OS X, it means that you can boot  in single user mode, so we'll do it.

 

Boot with the "-s" flag, and then type this when prompted:

 

mount -uw /

cp /mach_kernel /mach_kernel_old

cp /**folder with the new kernel**/**new kernel name** /mach_kernel

 

And voila~, 64-bit OS X Lion 10.7.3 in AMD!

 

so far the only cons in this build is the sound. I can't get sound over HDMI, just video. And from the integrated Realtek ALC 892 I only got Line-out to work. Can't use a microphone or anything else. Mountain Lion should fix this.

Attached Files



#2
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,907 posts
  • Gender:Male

Congratulations, Faef!

 

As far as i understood, you're running Lion with AnV's Mountain Lion kernel: this is rather impressive.

 

Can any global moderator move this thread to the AMD section, since it's quite relevant for the kernel development?

 

All the best!



#3
FaefLemon

FaefLemon

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Software that I tested that works:

-GarageBand 

-Logic Pro X

-Skype

-Google Chrome

-Office suite 2011

-Photoshop CS5

-Ableton Live 9 Suite

 

and little games as Braid, Limbo & Angry Birds Space



#4
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,907 posts
  • Gender:Male

Are you graphics working flawlessly? No glitches, artifacts etc...?

 

Andy, Bronzovka, Sinetek and all the task force: is there an explanation for this? He is doing Lion with our beloved Mountain Lion kernel...



#5
Andy Vandijck

Andy Vandijck

    InsanelyMac Deity

  • Coders
  • 1,619 posts
  • Gender:Male
  • Location:Tienen
  • Interests:Programming stuff for Mac OS X...
    Hacking...
    Hard rock (also really big Metallica...

Are you graphics working flawlessly? No glitches, artifacts etc...?

Andy, Bronzovka, Sinetek and all the task force: is there an explanation for this? He is doing Lion with our beloved Mountain Lion kernel...

ML is closer to lion than Mavericks to ML.
ML is in fact an optimized Lion.
EDIT: No glitches on my Intel rig with Mavericks and HD6450 and Clover connectors patch.

#6
FaefLemon

FaefLemon

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Are you graphics working flawlessly? No glitches, artifacts etc...?

Nope. My GPU works fine, even without GraphicsEnabler=Yes. That just shows it as a properly HD6450.

 

I´m currently having an issue... With this kernel, 64 bit apps runs flawlessly, but from time to time, 32-bit only apps (in this case, DVD Player and Skype) show the "Quit unexpectedly" error. Two days ago, DVD Player was not working and now it does, but Skype doesn't. Weird.

 

Cinebench shows the red dot glitch.

 

Attached Files


Edited by FaefLemon, 15 August 2013 - 12:01 PM.


#7
AkimoA

AkimoA

    AMD

  • Local Moderators
  • 213 posts
  • Gender:Male
  • Location:Black Forest (GER)

what is your Solution for Audio?  if it is VoodooHDA  there were some issues with Skype  back in the days  

 

if VoodooHDA was used and no Mic Line IN is detected by it , no matter what Skype would crash  in Snow Leopard  

 

was to be fixed with either pluging a USB Mic/Camera  for example  

 

or installing AppleAzaliaAudio.pkg  if supported with that old driver Skype would even start up without a Mic connected (chat only offcourse)

 

or roll back to a very old version of it like 3.51 







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy