Jump to content

Radeon 7650m vga port worked but LVDS not work please guide me

Radeon 7650m vga port worked

  • Please log in to reply
15 replies to this topic

#1
boy_iran_64

boy_iran_64

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

hello
i install os x 1.9 dp1 on my laptop vaio sve15117fdb

i not install DSDT and not install kext ( my friend Trucker MK before make kext but this not work and i have to use vga port and external monitor)
My Graphics card is 7650m and i when boot with GraphicsEnabler=Yes AtiConfig=Duckweed or GraphicsEnabler=Yes AtiConfig=Gibba VGa port worked but my laptop LVDS not work
with AtiConfig=Shirke or AtiConfig=Pondweek or AtiConfig=Hoolock but vag port Not work lvds not work
AtiConfig=Pondweek vga Worked but displayed only mouse poiner and White screen...LVDS not work
only when i boot GraphicsEnabler=No my Lvds worked.
please guide me



#2
freeuser16

freeuser16

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Location:Lithuania

What? You enabled 7 series card using ATI5000 fremebuffer (Duckweed, Gibba)? That's something new :)

Can you post your video bios? Also would be interesting to know what screen resolution do you have?



#3
boy_iran_64

boy_iran_64

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

yes. but vga only worked for me..

screen resolution is 800x600

i upload all below items:

1-MY laptop Bios (Unlocked advanced menu)

2-my Graphics card Bios by AIDA64 Extreme Edition

3- my DSDT by AIDA64 Extreme Edition and DSDTSE 1.4

4-my IOREG

http://www.mediafire...sve15117fdb.rar

or

http://d-h.st/qag

my friend Trucker MK make kext for me but not work lvsd only vga worked for me

(i not install modified kext in new install mac today i not install any kext )

http://www.insanelym...33#entry1936722

result for modified kexts (modified by Trucker MK)

10_00 vga work   lap top lcd not work and this is very dark (i feel  my lvsd is turn off :D)

20_00 vag not work and my laptop lcd not work and this is light dark (same below picture)

20_01 vga work and and my laptop lcd not work and this is light dark (same below picture)

17895746268904052663.jpg



#4
freeuser16

freeuser16

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Location:Lithuania

Yes, this is a common problem. If you provided information I asked you in the last post, maybe we can do something about it.



#5
boy_iran_64

boy_iran_64

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

please you say : how i provided information for you?



#6
vrondena

vrondena

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts
if you are interested 
7650 hdmi works, with right id on .....6000 - show  2gb qe\ci full resolution - ati muskgrass
same work vga with another ati.....but 800x600
for LVDS..........forget it on sony any model
perhaps only method bios mods,disable ati,active hd4000 and......pray for lvds 
 
if it works for freeuser16 explain how did


#7
thuvn205

thuvn205

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

 

if you are interested 
7650 hdmi works, with right id on ...capri - and...6000 - show  2gb qe\ci full resolution - ati muskgrass
same work vga with another ati.....but 800x600
for LVDS..........forget it on sony any model
perhaps only method bios mods,disable ati,active hd4000 and......pray for lvds 
 
if it works for freeuser16 explain how did

 

Did your Sony works on any Mac OS?, I see you have a Sony SVE1512.

 

Iam testing on my VPCSB Sony I5 Sandy, Ati 6630m & HD3000. I try bios mod and disable switch VGA but also get only external LCD full resolution but still no QE/CI.


please you say : how i provided information for you?

 

Maybe you may like to take a look at here:

 

http://www.osx86.net...-hd-3000-a.html



#8
vrondena

vrondena

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

hdmi works qe\ci, with right id on...6000 ML 10.8.3\4 and 10.9.1\2\3 native kexts 

Vga work good with kexts 

http://www.insanelym...s-fixed/page-32 - 631 kexts

LVDS -pending solutions



#9
freeuser16

freeuser16

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Location:Lithuania

If integrated card is not disabled by manufacturer, there is no chance LVDS would ever work. OS X kernel can't work with switchable graphics on normal notebooks because in real Macs it works differently. Even on Linux there are many problems with switchable graphics. I explained in more detail in other topic:

 


On normal notebooks only integrated graphics card has connectors to display, while discrete card is connected to integrated one. On real Mac Books both cards are connected to display, thus switchable graphics works differently. There are some notebooks where switchable graphics works as on real Mac Books (fe. Dell Alienware series), but their price is almost identical to Mac Book Pro  :)

 

The only solution is to disable discrete card and use only integrated one.



#10
Trucker MK

Trucker MK

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 397 posts
  • Gender:Male
  • Location:Republic Of Macedonia

only when i boot GraphicsEnabler=No my Lvds worked.
 

Without too much explaining, does your LVDS work somehow or not? :wallbash:

If yes, in that case did you used the DSDT i patched for you?



#11
boy_iran_64

boy_iran_64

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

Only in the case of i use GraphicsEnabler=No My lvds worked (vga not work ) but in this case my Graphics Card not work perfectly and my Hackintosh recognize ati card with 7mb ram (not recognize my graphic cards model = 7650m)

but in the case of i use GraphicsEnabler=Yes Aticonfig=Gibba My lvds not worked but vga worked and i have to i use other monitor

in this case My hackintosh recognize ati radeon 7600/7500 correctly and recognize 1024Mb ram for Graphics Card i can see movie easily and safari browser and other program run faster and without  slowly.

but Game not work for me and my computer is stoped in loadin game (limbo and  plant vs zombie)

thanks Trucker MK for your attention .



#12
pheonix137

pheonix137

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

I have the same problem with vaio nw160j. The weird thing is I can get the card to detect LVDS but nothing is displayed on screen, probably because of eDP. Is there any way around eDP? How can I find out more using linux gallium drivers which work fine for multiple display?



#13
boy_iran_64

boy_iran_64

    InsanelyMac Protégé

  • Members
  • Pip
  • 45 posts

anybody help me?

what is not work my lvds ?

what is not work vga port and lvds with AtiConfig=Pondweed?

please guide me



#14
styrian

styrian

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 831 posts
  • Gender:Male

Hello Boy_Iran_64!

 

It seems to me that you are either  a bit lazy or just wanting to get a cheap replacement for a real macbook for playing with it. The goal of this platform is to do some educational work in computing and especially with OSX.

If you are not able to find a fully finished an totally working solution for your Vaio, then you have to do some research by yourself. To learn, how to edid kexts and plists  and how to get, edid and patch a DSDT.aml and so on is at your own.

The starting point for my Lenovo Edge E320 had been only the hardware specs. At this time I could not find a working solution for it. I had to spent much time for looking for with my given hardware working elements, reading many pages, patching kexts and dsdt.aml and so on. There had been many tries and errors til I got a my Edge up and working.

 

A good starting point for you to learn something about gfx is the following link: http://rampagedev.wo...er-personality/

Other aspects you can find with the forums-search or you have simply to google for them.

 

Until now it looks like, that you are not interested in learning something by yourself. This could be the reason for your getting very rare support.

 

My intention is not at all mobbing you. If it looks for you like that, I beg your pardon!

Please do not forget to share your improvments with others and give credits to people for sharing their by themselves done work!

 

Have fun and no harm meant!



#15
ShubhamSSJ

ShubhamSSJ

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:India

If integrated card is not disabled by manufacturer, there is no chance LVDS would ever work. OS X kernel can't work with switchable graphics on normal notebooks because in real Macs it works differently. Even on Linux there are many problems with switchable graphics. I explained in more detail in other topic:

 


 

 

The only solution is to disable discrete card and use only integrated one.

Does this also mean , the discrete card should be disabled for Windows as well in a dual boot scenario ??

Sorry to post in an old thread but I was searching for solution and stumbled upon this post.

My discrete card gets disabled in windows after installing osx 10.8.2 .

http://www.insanelym...tain-lion-1082/

 

Thanks in advance !!



#16
freeuser16

freeuser16

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Location:Lithuania

Why are you using dual boot? I have never tried this, thus I don't know how it works. Just install OS X, some bootloader and it should work fine on your Intel HD card.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy