Jump to content

How to Install OS X 10.x (Snow Leopard, Lion, Mountain Lion, Mavericks and Yosemite) in VMware Workstation 10 or Player 6

VMware OS X 10.8 Mountain Lion OS X 10.9 Mavericks Unlocker Workstation 10 Player 6 Yosemite OS X 10.10

  • Please log in to reply
192 replies to this topic

#141
Aidzer0

Aidzer0

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Okay so i finally got OS X 10.9 installed.

 

Thanks A lot For the help guys,

 

All i did was update my Vmware Workstation.

 

 



#142
pmac100

pmac100

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Hi...

 

I have a Snow Leopard Server 10.6.8 VM that I'm trying to upgrade to Mavericks. I downloaded the Mavericks installer via the App Store in the VM, ran the installer, which rebooted the VM, gets as far as the Apple logo, and there it sits with brief HD activity every couple of seconds.

 

Some info:

 - Using Workstation 7, which I know isn't officially listed as a supported version, but I'm stuck on this version for compatibility with software on another VM

 - ran the unlocker

 - host machine is Dell M 4700, Win 7, intel i7. I added the cpuid line to the vmx file per some earlier posts

 

Any thoughts would be appreciated...

 

thx...

 



#143
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 984 posts
  • Gender:Male
  • Location:Darlington UK

Hi...

 

I have a Snow Leopard Server 10.6.8 VM that I'm trying to upgrade to Mavericks. I downloaded the Mavericks installer via the App Store in the VM, ran the installer, which rebooted the VM, gets as far as the Apple logo, and there it sits with brief HD activity every couple of seconds.

 

Some info:

 - Using Workstation 7, which I know isn't officially listed as a supported version, but I'm stuck on this version for compatibility with software on another VM

 - ran the unlocker

 - host machine is Dell M 4700, Win 7, intel i7. I added the cpuid line to the vmx file per some earlier posts

 

Any thoughts would be appreciated...

 

thx...

pmac100,

 

The CPUID should only be required for your Snow Leopard Install, once upgraded to 10.6.8 your CPU should be supported. I think you are going to struggle with Workstation 7, see posts by Aidzer0. You should be able to run either Workstation 10 or Player 6 and provided you leave your hardware compatibility at Version 7 for your other VM all should work as expected, and you will be able to either upgrade your 10.6.8 to 10.9 or having extracted the DMG, see the second post in this thread, do a clean install of Mavericks.



#144
pmac100

pmac100

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

pmac100,

 

The CPUID should only be required for your Snow Leopard Install, once upgraded to 10.6.8 your CPU should be supported. I think you are going to struggle with Workstation 7, see posts by Aidzer0. You should be able to run either Workstation 10 or Player 6 and provided you leave your hardware compatibility at Version 7 for your other VM all should work as expected, and you will be able to either upgrade your 10.6.8 to 10.9 or having extracted the DMG, see the second post in this thread, do a clean install of Mavericks.

 

I appreciate the reply MSoK...

 

I uninstalled Workstation 7 and installed Player 6. Re-ran the unlocker (not sure it was necessary just to upgrade 10.6.8 to Mavericks). Started 10.6.8 VM, double-clicked the Mavericks installer, it rebooted the VM... back to 10.6.8, no attempt to upgrade. Tried a couple more times, same result.

 

So... I thought I'd go the route of creating a new VM using the 10.9 installer downloaded in 10.6.8, using the Create Mavericks Installer script mentioned in the second post of this thread. Downloaded the script, removed the .txt extension, left the source and destination locations as is. Confirmed the Mavericks installer was in the Applications folder, and that the destination location used by the script did exist. Right-clicked the script, opened with Terminal, Terminal opened and just sat there at the prompt. Nothing created in the destination...

 

So, I appear to be 0 for 2...



#145
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 984 posts
  • Gender:Male
  • Location:Darlington UK

I appreciate the reply MSoK...

 

I uninstalled Workstation 7 and installed Player 6. Re-ran the unlocker (not sure it was necessary just to upgrade 10.6.8 to Mavericks). Started 10.6.8 VM, double-clicked the Mavericks installer, it rebooted the VM... back to 10.6.8, no attempt to upgrade. Tried a couple more times, same result.

 

So... I thought I'd go the route of creating a new VM using the 10.9 installer downloaded in 10.6.8, using the Create Mavericks Installer script mentioned in the second post of this thread. Downloaded the script, removed the .txt extension, left the source and destination locations as is. Confirmed the Mavericks installer was in the Applications folder, and that the destination location used by the script did exist. Right-clicked the script, opened with Terminal, Terminal opened and just sat there at the prompt. Nothing created in the destination...

 

So, I appear to be 0 for 2...

pmac100,

 

I have updated the second post in this thread, with the original version of the "Create Mavericks Installer.tool" and relevant instructions to use it, hopefully you will be able to create the required OS X Mavericks DMG file for a clean install. I have also added the processor and memory changes required to your Snow Leopard virtual machine to allow upgrade to Mavericks.

 

Hope this helps.



#146
pmac100

pmac100

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

pmac100,

 

I have updated the second post in this thread, with the original version of the "Create Mavericks Installer.tool" and relevant instructions to use it, hopefully you will be able to create the required OS X Mavericks DMG file for a clean install. I have also added the processor and memory changes required to your Snow Leopard virtual machine to allow upgrade to Mavericks.

 

Hope this helps.

 

MSoK-

 

Just wanted to say thanks for your help, I'm up and running with a 10.9 VM via VMPlayer 6.

 

For some reason, I still was not able to upgrade my 10.6.8 VM; even with the suggested changes, the installer kept rebooting the VM back to 10.6.8.

 

So I went the route of a clean install, using the script to create a bootable .dmg of the 10.9 installer downloaded in the 10.6.8 VM. The trickiest part for me on this route was getting the .dmg back into the Win7 host machine so VMPlayer could use it for the install. Couldn't copy it via Shared Folders, couldn't put it on a USB stick (not visible to the 10.6.8 VM). I eventually mounted the 10.6.8 public folder via SMB in Win 7 and copied the file from there into where I needed it....



#147
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 984 posts
  • Gender:Male
  • Location:Darlington UK

MSoK-

 

Just wanted to say thanks for your help, I'm up and running with a 10.9 VM via VMPlayer 6.

 

For some reason, I still was not able to upgrade my 10.6.8 VM; even with the suggested changes, the installer kept rebooting the VM back to 10.6.8.

 

So I went the route of a clean install, using the script to create a bootable .dmg of the 10.9 installer downloaded in the 10.6.8 VM. The trickiest part for me on this route was getting the .dmg back into the Win7 host machine so VMPlayer could use it for the install. Couldn't copy it via Shared Folders, couldn't put it on a USB stick (not visible to the 10.6.8 VM). I eventually mounted the 10.6.8 public folder via SMB in Win 7 and copied the file from there into where I needed it....

pmac100,

 

Glad you are all sorted, do not quite understand the issue with shared folders, just checked in Snow Leopard and was able to transfer the Mavericks DMG (6GB) both ways, you did remember to set the share to Enabled not Read-only?



#148
jujeki

jujeki

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Thank you for such a straight forward guide. I managed to install OS X 10.9.2 from a dmg onto a Guest OS in Player 6, as per the instructions in the 2nd post. I also went through the VMTools and drivers, etc. and now all the sluggishness is gone except for a couple apps in the VM that I don't really care about. 

 

One thing that I still need help with that was not addressed in your guide is the screen resolution when in full screen. Everything is so tiny! Granted, my laptop has a small screen to start...

 

The VM is picking up my host's native resolution (2560 x 1440) and that's the only option I have. I can change the resolution inside the VM by changing the resolution in my Windows host, but then I'm stuck using crayons on my Windows machine if I want a usable resolution in my OS X VM. There must be a more elegant solution?



#149
vandenk

vandenk

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hello,

 

I try to install os x 10.6.3 on VMWare Workstation 10.
I have installed VMWare 1.3.0 Unlooker but I do not have OSX 10.6 (only 10.6 osx server) ...
I use the dvd osx directly and I tested with Mac OS X Server 10.6 64-bit and Mac OS X Server 10.6.
The installation starts normally but then I get an error: Setup was unable to copy the files necessary support.



#150
an7oine

an7oine

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

In case anyone is wondering, the instructions and tools in this thread also seem to work with OS X v10.10 "Yosemite" (DP), as upgraded from a pre-existing Mavericks system.



#151
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,022 posts
  • Gender:Male
  • Location:Manchester UK

In case anyone is wondering, the instructions and tools in this thread also seem to work with OS X v10.10 "Yosemite" (DP), as upgraded from a pre-existing Mavericks system.

 

They do work with a clean install as well. However performance is poor for me.



#152
an7oine

an7oine

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Indeed. Much of the lack of performance was, for me, though, already present in Mavericks, and can be attributed to the aging, 32-bit, 3 GB Windows 7 work machine I am hosting my vm on. Talk about beating a dead horse...



#153
jawnskeel

jawnskeel

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

After installing the graphics packages, it seems the minimum resolution isn't small enough imo. Full screen works great though.

 

Also, I have a wired apple keyboard and I was wondering if there was any way to enable the Fn keys up top.



#154
trungpt

trungpt

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts

I have just installed Mac OS X 10.9 on VMware Workstation v9. I followed the second post. It is a great post :D



#155
Zombie_ii

Zombie_ii

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Has anyone upgraded to VMware Workstation 10.0.3 and if so, did anything break?



#156
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 984 posts
  • Gender:Male
  • Location:Darlington UK

Has anyone upgraded to VMware Workstation 10.0.3 and if so, did anything break?

Yes, upgraded to Workstation 10.0.3 and all is well with OS X, since the install process un-installs the previous version as part of the "upgrade" process, the unlocker (1.3.0) needs to be re-installed once the "upgrade" to 10.0.3 has completed. I always do a cold re-boot after a workstation "upgrade" and applying the unlocker, and follow the unlocker install with another cold re-boot, just to make sure all the networking and services are running correctly.



#157
trungpt

trungpt

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts

It is nice to know that VMware Unlocker v1.3 works well with VMware workstation 10.0.3 :)



#158
davidm71

davidm71

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 172 posts
  • Gender:Male

Yes, upgraded to Workstation 10.0.3 and all is well with OS X, since the install process un-installs the previous version as part of the "upgrade" process, the unlocker (1.3.0) needs to be re-installed once the "upgrade" to 10.0.3 has completed. I always do a cold re-boot after a workstation "upgrade" and applying the unlocker, and follow the unlocker install with another cold re-boot, just to make sure all the networking and services are running correctly.


Weird that I did not need to reinstall unlocker though I had the VM suspended. Who knows what will happen upon a reboot..

#159
MSoK

MSoK

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 984 posts
  • Gender:Male
  • Location:Darlington UK

Weird that I did not need to reinstall unlocker though I had the VM suspended. Who knows what will happen upon a reboot..

david,

 

Since your OS X VM was suspended it will not have carried out the check to confirm the presence of Apple hardware, I expect you to get an error on re-boot of your VM, until you install the unlocker, but please let us know, not something I have ever tried.



#160
Zombie_ii

Zombie_ii

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Yes, upgraded to Workstation 10.0.3 and all is well with OS X, since the install process un-installs the previous version as part of the "upgrade" process, the unlocker (1.3.0) needs to be re-installed once the "upgrade" to 10.0.3 has completed. I always do a cold re-boot after a workstation "upgrade" and applying the unlocker, and follow the unlocker install with another cold re-boot, just to make sure all the networking and services are running correctly.

Thanks.  Went just as you said it would.  All is working well.







Also tagged with one or more of these keywords: VMware, OS X 10.8, Mountain Lion, OS X 10.9, Mavericks, Unlocker, Workstation 10, Player 6, Yosemite, OS X 10.10


7 user(s) are reading this topic

1 members, 6 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy