Jump to content

ASUS G73 with 5870M: Resolution Troubles

ati and radeon g73 5870m nomascus resolution

Best Answer CaptSilver, 31 July 2013 - 03:26 PM

Solved: Dual Link Fix for dsdt 

Go to the full post


  • Please log in to reply
3 replies to this topic

#1
CaptSilver

CaptSilver

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

I have almost everything working, but I cannot get resolution changes to work with my video card. It messes up and I get like 4 duplicate desktops showing on my LVDS. I tried EDID overrides but to no avail. I am guessing this is a video driver issue, but I have no idea what to change in order to correct this. I tried different but similar framebuffers but they do not help at all.

Standard Nomascus but only using the first three connectors:

Personality: Nomascus
ConnectorInfo count in decimal: 4
Disk offset in decimal 591808

0000000 02 00 00 00 40 00 00 00 09 01 00 00 00 00 00 05
0000010 02 00 00 00 00 01 00 00 09 03 00 00 12 04 03 03
0000020 00 04 00 00 04 06 00 00 00 73 00 00 11 02 01 01
0000030 00 04 00 00 04 07 00 00 00 73 00 00 21 03 02 02
0000040

ATOM BIOS Rom: 
SubsystemVendorID: 0x1028 SubsystemID: 0x043a
IOBaseAddress: 0x3000
Filename: 13B96101.104
BIOS Bootup Message: 
BROADWAY XT B96101 GDDR5 64Mx16 4CH 400m/300e @0.9V UCODEv:128 

ATOM BIOS Rom: 
SubsystemVendorID: 0x1043 SubsystemID: 0x1c02
IOBaseAddress: 0x0000
Filename: BR35992.001 
BIOS Bootup Message: 
Asus G73 BROADWAY XT GDDR5 64Mx16 4CH ASID:A33G73.002$ UCODEv:1195 

PCI ID: 1002:68a0
Connector at index 0
Type [@offset 45122]: LVDS (7)
Encoder [@offset 45126]: INTERNAL_UNIPHY (0x1e)
i2cid [@offset 45196]: 0x94, OSX senseid: 0x5
Connector at index 1
Type [@offset 45132]: HDMI-A (11)
Encoder [@offset 45136]: INTERNAL_UNIPHY1 (0x20)
i2cid [@offset 45219]: 0x91, OSX senseid: 0x2
Connector at index 2
Type [@offset 45142]: VGA (1)
Encoder [@offset 45146]: INTERNAL_KLDSCP_DAC2 (0x16)
i2cid [@offset 45246]: 0x97, OSX senseid: 0x8

My HDMI seems to work perfectly, do not ask me how as the type of connector is wrong, but it refuses to boot when I change to HDMI type. Any suggestions would be helpful.



#2
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,558 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

the ati is primary card ?

 

if so try orangutan

 

and see if in kext are u dev id ..

 

ati5000controller

 

i don't know what mac os x version u are trying to run

 

must see in accelerator kext

 

http://olarila.com/f....php?f=28&t=736

 

good hack



#3
CaptSilver

CaptSilver

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

The ati is the primary and only card. Orangutan has the same problems as it is the same info on connector 0. I am running 10.8.4 and I have QE/CL just cannot change resolutions from 1600x900 or things go wonky. My device is in the ati5000controller so no need for injection.



#4
CaptSilver

CaptSilver

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Best Answer

Solved: Dual Link Fix for dsdt 







Also tagged with one or more of these keywords: ati, and, radeon, g73, 5870m, nomascus, resolution


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy