Jump to content

Haswel i7 4770k + ga-z87x-ud5h + gtx 650 ti Works! 10.8.4


Best Answer Picasso, 18 August 2013 - 12:54 AM

Yes!!! I did it!

 

Mach_Kernel 10.8.5 from the last Beta!

 

Everything native except Audio: I Use Vodoo, but I listen to loud. But I'm not trying other kext. THe first part of this topic it's correct: Only MyHack and the Kernel.

 

Boot: 

-v -f GraphicEnabler=No  (Nvidia)

NOthing else!

 

Good Hack!

Go to the full post


  • Please log in to reply
112 replies to this topic

#41
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts

Great for Network!!!! That´s the file!!!!!! Thanks for this!!!

I will try the Audio at night! 

 

After that i will try the HD4600, I read in Maverics topics that you can get both videos working, one for the system and the other one for processing, video, edition, etc!

i'll wait till 10.9 is out.

 

------

now tried the tony version of patched 10.8.4 kernel (needs NullCPUPowerManagement.kext, else kernel panic) with applehda.kext mic is working, but sound out not.... testing....



#42
VladeK231

VladeK231

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts

I tried again. Yes again on my system, with details as folllow:

_ CPU: Xeon 1230v3 (Haswell).

_ Mainboard: Gigabyte GA H87 D3H.

_ VGA: GTX 560ti.

 

I'm following your method:

_ I formated the USB with GUID option.

_ Restore Based dmg from mac 10.8.4

_ Copy package from installed to USB

_ Copy the march_kernel 10.8.5 to USB

_ Copy fakesmc.kext and NullCPU to USB/System/Library/Extension

_ Install Chameleon 2.2 to the USB

 

Now I'm back to zero: Stuck at: Still waiting for root device.

Can anyone help me what I'm missing here.

 

The same process I did with ML 10.9 DP1, I passed the still waiting for root device. But stuck at DSMOS has arrived.



#43
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts

Audio Voodoo works perfect. i was trying Toleda but has more problems than a Monkey without Bananas.

I don´t know which one is better... the difference in quality i mean...

 

thanks again!

 

Have you tried get dsdt from windows?

i never did that, I never had windows machine...



#44
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts

I tried again. Yes again on my system, with details as folllow:

_ CPU: Xeon 1230v3 (Haswell).

_ Mainboard: Gigabyte GA H87 D3H.

_ VGA: GTX 560ti.

 

I'm following your method:

_ I formated the USB with GUID option.

_ Restore Based dmg from mac 10.8.4

_ Copy package from installed to USB

_ Copy the march_kernel 10.8.5 to USB

_ Copy fakesmc.kext and NullCPU to USB/System/Library/Extension

_ Install Chameleon 2.2 to the USB

 

Now I'm back to zero: Stuck at: Still waiting for root device.

Can anyone help me what I'm missing here.

 

The same process I did with ML 10.9 DP1, I passed the still waiting for root device. But stuck at DSMOS has arrived.

try: GraphicsEnabler=Yes PCIRootUID=1 npci=0x2000 (or try it with 0x3000) -f -x -v 



#45
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts

Audio Voodoo works perfect. i was trying Toleda but has more problems than a Monkey without Bananas.

I don´t know which one is better... the difference in quality i mean...

 

thanks again!

 

Have you tried get dsdt from windows?

i never did that, I never had windows machine...

i can get the dsdt from osx/windows, but after patching the compiling does not work. i got a lot of errors. i tried "fix errors", but there was still a lot of errors.



#46
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts

WOOHOOO!

 

Got AppleHDA with 10.8.4 to work.

 

Edit:

The Attachment contents a patched 10.8.4 Kernel. If you like the 10.8.5 Kernel look here

 

for the patched 10.8.4 kernel you need the NullCPUPowerManagement.kext and for the 10.8.5 kernel you don't need the NullCPUPowerManagement.kext

Attached Files



#47
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts

this is my /Extra Folder

Attached Files



#48
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts

the DVD-Player-Fix

-make a backup before from DVDPlayback.framework

 

-replace it with this attachment at /System/Library/Frameworks

 

-repair permissions with disk utility

 

-reboot

 

-test it with a dvd

 

----------------------

 

you also can try the DVD Switcher app from there: http://www.osx86.net...player-app.html

Attached Files



#49
EvgeniX

EvgeniX

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
hi all,

does usb3 works after sleep? sleep is work normal?

#50
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts

hi all,

does usb3 works after sleep? sleep is work normal?

osx 10.8.4 with 10.8.4 kernel and NullCPUPowerManagement.kext the pc is freezing after sleep. putting to sleep with power button before logging in, waking with mouse. than the mouse is shortly working.

 

without NullCPUPowerManagement.kext kernelpanic

 

after login and completely loaded the autosleep and sleep with powerbutton is working good

 

cpu/gpu speedstepping NOT working

 

hwmonitor says CPU idle 27 watt

 

Audio works

 

 

------------------

 

osx 10.8.4 with 10.8.5 kernel and WITH NullCPUPowerManagement.kext the pc is working correctly after sleep

cpu/gpu speedstepping NOT working

hwmonitor says CPU idle 13 watt

 

Audio works

 

 

 

-----------------

 

 

 

osx 10.8.4 with 10.8.5 kernel and WITHOUT NullCPUPowerManagement.kext the pc is working correctly after sleep

 

cpu/gpu speedstepping IS working

 

hwmonitor says CPU idle 5,5 watt

 

Audio works

 

 

------------------

 

if needed, there is the usb3 driver http://www.insanelym...-x-with-source/



#51
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts

osx 10.8.4 with 10.8.4 kernel and NullCPUPowerManagement.kext the pc is freezing after sleep. putting to sleep with power button before logging in, waking with mouse. than the mouse is shortly working.

 

without NullCPUPowerManagement.kext kernelpanic

 

after login and completely loaded the autosleep and sleep with powerbutton is working good

 

cpu/gpu speedstepping NOT working

 

hwmonitor says CPU idle 27 watt

 

Audio works

 

 

------------------

 

osx 10.8.4 with 10.8.5 kernel and WITH NullCPUPowerManagement.kext the pc is working correctly after sleep

cpu/gpu speedstepping NOT working

hwmonitor says CPU idle 13 watt

 

Audio works

 

 

 

-----------------

 

 

 

osx 10.8.4 with 10.8.5 kernel and WITHOUT NullCPUPowerManagement.kext the pc is working correctly after sleep

 

cpu/gpu speedstepping IS working

 

hwmonitor says CPU idle 5,5 watt

 

Audio works

 

 

------------------

 

if needed, there is the usb3 driver http://www.insanelym...-x-with-source/

Great work!!!! Congrats!!!!!

 

Let´s go for the HD4600. I´ve read that the system can work with hd4600 leaving the Video Card for processing!!!!!

If you work with video, it´s Radiohead performer Queen.



#52
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts

Network-Kext-Update:

http://sourceforge.n...Kext/Snow_Lion/

AppleIGB.kext   
AppleIntelE1000e.kext (now working with 10.8.5 12f30, but only with -v -f command )

 

the applehda.kext with the enabler is not working with 10.8.5
 

 

for the hd4600: http://www.insanelym...r-intel-hd4600/ (not tested myself)



#53
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts

I have HD4600 in 10.8.4 with mach_kernel 10.8.5 No CE/QC

I put in the bios: Enable video on board.

 

I boot with -f -v GE=Yes and after that I corrected in smbios GE and 1920x1080x32

 

I´m downloading 10.8.5, I´ll try again...



#54
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts

the DVD-Player-Fix

-make a backup before from DVDPlayback.framework

 

-replace it with this attachment at /System/Library/Frameworks

 

-repair permissions with disk utility

 

-reboot

 

-test it with a dvd

 

----------------------

 

you also can try the DVD Switcher app from there: http://www.osx86.net...player-app.html

This is not working for me, even the framework replaced as the file in the link. Any suggestion?



#55
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts

This is not working for me, even the framework replaced as the file in the link. Any suggestion?

 

-you need only rename DVDPlayback.framework to DVDPlayback.framework.bak 
-copy DVDPlayback.framework into /System/Library/Frameworks
-after that you need to open the disk utility, click on your hdd, where os x is installed and than repair the permissions.
-reboot
 
if not working, try the app dvd switcher.app


#56
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts

I had install 10.8.5 Last Beta, and give "bluetooth" erros. I boot with usb stick, copy mach_kernel, FAKE, etc, and have the same problem.

 

I formatted the disk and start again from 10.8.4. 

 

Do you know something?



#57
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts

I had install 10.8.5 Last Beta, and give "bluetooth" erros. I boot with usb stick, copy mach_kernel, FAKE, etc, and have the same problem.

 

I formatted the disk and start again from 10.8.4. 

 

Do you know something?

what smbios.plist? same chameleon bootlist?

 

perhaps the intel hd4000/5000 kexts or bootsettings making the error



#58
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts

Maybe the Kernel its different. Or the NullPowermanagment...



#59
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts

Maybe the Kernel its different. Or the NullPowermanagment...

the NullCPUPowerManagement you only need with patched 10.8.3 or patched 10.8.4 kernel



#60
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts

I have deleted last week and I create a SSDT (thanks Cobra03 ) to get better performance from the processor.

 

Right now, in 10.8.4 with mach 10.8.5 I have my shut down stuck and I have to press reset button. Any idea?

 

EDIT: Repared: I used to enable trim the command in MyHack ¨Enable TRIM¨, that add a kext IOAHCIBlockStorage, that have some problems. I deleted from EXTRA, but I loose TRIM. Waiting for something better.

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy