Jump to content

Haswel i7 4770k + ga-z87x-ud5h + gtx 650 ti Works! 10.8.4


Best Answer Picasso, 18 August 2013 - 12:54 AM

Yes!!! I did it!

 

Mach_Kernel 10.8.5 from the last Beta!

 

Everything native except Audio: I Use Vodoo, but I listen to loud. But I'm not trying other kext. THe first part of this topic it's correct: Only MyHack and the Kernel.

 

Boot: 

-v -f GraphicEnabler=No  (Nvidia)

NOthing else!

 

Good Hack!

Go to the full post


  • Please log in to reply
112 replies to this topic

#21
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 239 posts

Going!

Attached Files



#22
thewarlock97

thewarlock97

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

once youre done with it, can you please post a full step by step installation guide?



#23
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts

once youre done with it, can you please post a full step by step installation guide?

installing a kext: download the tool kext utility from here: http://cvad-mac.narod.ru/index/0-4

 

drag and drop the kextfile on this software. enter your password. wait a bit. installed.

 

but before you are trying different kext make a backup of kext (they are at /System/Library/Extensions/) at desktop. the kext utility makes a backup at extension folder and entering *.bak as suffix. restart your pc/mac. kext is working.



#24
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts

the AppleHDA + toledas HDAEnabler1.kext and also tested with HDAEnabler2.kext was not working at 10.8.4 with 10.8.5 kernel and at 10.8.5 12F30 was not working...

 

 

do you have a dsdt.aml (at the folder /Extras/ on your HDD you've installed osx)

do you also have a HDAEnabler kext at /S/L/E/?



#25
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 239 posts

No dsdt

HDA Enabler here!

 

 


Have you know how to separate HDA from Maverick? I think could be a solution. I don´t know too much except  the things I put and talk  here...

Attached Files



#26
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 239 posts

Other Combo Upgrade Beta

http://blog.shade.sh/



#27
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts

i tested the new patch for ALC898 from toleda. on 10.8.4 with 10.8.5 kernel. tested with hdaenabler 1 and 2. i can hear a click sound short after plugging in a headphone at frontpanel at the speakers plugged in at rear. but no sound. at 10.8.5 i tested the patched 10.8.4 applehda and also the patched 10.8.5 applehda. no device found with hdaenabler 1 and 2.

 

 

edit:

 

got sound working with voodoohda at 10.8.4

 

asmall bug.

i need to plug of the orange and green port. plug in orange and than green.

 

edit 2:

same bug at 10.8.5....



#28
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 239 posts

HDA from 10.8.5 las beta ;)

 

 

Attached Files



#29
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts

the applehda from 10.8.5 is the same as at 10.8.4. its version 2.4.7



#30
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 239 posts

I'm trying to get video without card, I mean, onboard. 

Can't.

I tried GraphicsEnabler=No

0x2000

-v -x

 

Not working. Only Black screen.



#31
VladeK231

VladeK231

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts

Can you share the kext to install with the 650ti ?



#32
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts

Can you share the kext to install with the 650ti ?

 

 

Can you share the kext to install with the 650ti ?

you only need GraphicsEnabler=No for the Nvidia. Disable the Onboard Graphic-Card.

for the onboard graphics look here: https://pikeralpha.w...ull-resolution/

and here http://www.insanelym...600/?hl=+hd4600

or here  http://www.insanelym...dio/?hl=+hd4600



#33
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 239 posts

No works for me hd 4600

 

I am creating again the original USB, and installing the 650Ti in the mobo. 

 

I feel frustrated with this. I need an stable hackintosh. 

 

Can you describe the full process to get OSX? I think we need more people working on it, editing text and all that stuff. And my experience it's only with MyHack, and Multixxxx... it's not the best way.

 

Thanks!


I forget! Tell me where I take the 650ti kext and I will send you.



#34
VladeK231

VladeK231

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts

But sadly, I dont have the on-board or interated graphic (My CPU is Xeon 1230 v3 and mainboard is H87 D3H). Is there a way to install with gtx 560ti? I'm stuck at "DSMOS has arrived" ...



#35
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 239 posts

Download and Try Multi... 5.4.1 http://www.tonymacx8...php?do=cat&id=3

in graphics select Fermin patched



#36
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts

But sadly, I dont have the on-board or interated graphic (My CPU is Xeon 1230 v3 and mainboard is H87 D3H). Is there a way to install with gtx 560ti? I'm stuck at "DSMOS has arrived" ...

did you tried

 

GraphicsEnabler=Yes / No (i think to remember, that the 5xx needs Yes)

PCIRootUID=1 / 0

-v

-f

-x

-s

npci=0x2000 / 0x3000

UseKernelCache=Yes / No

GenerateCStates=Yes / No

GeneratePStates=Yes / No

 

 

at the first post of this topic, there's the 10.8.5 Kernel attached and my bootflags.

changed the kernel (from the 10.8.5 to the 10.8.4 installer or edited the 10.8.3 kernel (works not with 10.8.4) you can have 2 kernels at HDD. i'm having a backup from the 10.8.5 kernel and renamed it to mach_kernel1085.

bootflag:  Kernel=mach_kernel1085

 

you can generate a document (clean text, not R)F) copy and paste, than edit the org.chameleon.Boot.plist from this post  and save it to the Extra Folder of your USB-Stick. you can also copy the other kernel on the root of the Stick (e.g. renamed to mach_kernel1085 and bootflag at org.chameleon.Boot.plist)


No works for me hd 4600

 

I am creating again the original USB, and installing the 650Ti in the mobo. 

 

I feel frustrated with this. I need an stable hackintosh. 

 

Can you describe the full process to get OSX? I think we need more people working on it, editing text and all that stuff. And my experience it's only with MyHack, and Multixxxx... it's not the best way.

 

Thanks!


I forget! Tell me where I take the 650ti kext and I will send you.

 

 

No works for me hd 4600

 

I am creating again the original USB, and installing the 650Ti in the mobo. 

 

I feel frustrated with this. I need an stable hackintosh. 

 

Can you describe the full process to get OSX? I think we need more people working on it, editing text and all that stuff. And my experience it's only with MyHack, and Multixxxx... it's not the best way.

 

Thanks!


I forget! Tell me where I take the 650ti kext and I will send you.

for the gtx 650ti you need only GraphicsEnabler=No

 

here is the cuda-driver: http://www.nvidia.co....61-driver.html

here is the driver from nvidia for 10.8.4: http://www.nvidia.de...-driver-de.html (for Mac Pro 5,1 (2010), Mac Pro 4,1 (2009) and Mac Pro 3,1 (2008) users only)

for driver you need to edit your smbios.plist to make it a mac pro

 

perhaps you'll need nvda_drv=1 as bootflag



#37
VladeK231

VladeK231

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts

did you tried

 

GraphicsEnabler=Yes / No (i think to remember, that the 5xx needs Yes)

PCIRootUID=1 / 0

-v

-f

-x

-s

npci=0x2000 / 0x3000

UseKernelCache=Yes / No

GenerateCStates=Yes / No

GeneratePStates=Yes / No

 

 

at the first post of this topic, there's the 10.8.5 Kernel attached and my bootflags.

changed the kernel (from the 10.8.5 to the 10.8.4 installer or edited the 10.8.3 kernel (works not with 10.8.4) you can have 2 kernels at HDD. i'm having a backup from the 10.8.5 kernel and renamed it to mach_kernel1085.

bootflag:  Kernel=mach_kernel1085

 

you can generate a document (clean text, not R)F) copy and paste, than edit the org.chameleon.Boot.plist from this post  and save it to the Extra Folder of your USB-Stick. you can also copy the other kernel on the root of the Stick (e.g. renamed to mach_kernel1085 and bootflag at org.chameleon.Boot.plist)


 

 

for the gtx 650ti you need only GraphicsEnabler=No

 

here is the cuda-driver: http://www.nvidia.co....61-driver.html

here is the driver from nvidia for 10.8.4: http://www.nvidia.de...-driver-de.html (for Mac Pro 5,1 (2010), Mac Pro 4,1 (2009) and Mac Pro 3,1 (2008) users only)

for driver you need to edit your smbios.plist to make it a mac pro

 

perhaps you'll need nvda_drv=1 as bootflag

thx you, I will try it. 



#38
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 239 posts

Best Answer

Yes!!! I did it!

 

Mach_Kernel 10.8.5 from the last Beta!

 

Everything native except Audio: I Use Vodoo, but I listen to loud. But I'm not trying other kext. THe first part of this topic it's correct: Only MyHack and the Kernel.

 

Boot: 

-v -f GraphicEnabler=No  (Nvidia)

NOthing else!

 

Good Hack!



#39
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts

Youasked me at PM about the sound. here is the solution, that you need: google for the VoodooHDA-Installer

 

Included:

-VoodooHDA.kext

-AppleHDADisabler.kext

-VoodooHdaSettingsLoader.app (you need to add this to the startup)

-VoodooHDA.prefPane

-2 Images for help

 

-make a backup from the working voodoohda.kext

-install the pkg

-add the app to the startup from your account

-reboot

-perhaps you need to repair the permissions and rebuild the cache (or deleting at /system/library/caches/ the folder com.apple.kext.caches) and reboot again

-settings of the sound you can edit at the system preferences

-if not working install again the wiring voodoohda.kext with kext utility

-reboot 

-if not working: perhaps you need to repair the permissions again and rebuild the cache (or deleting at /system/library/caches/ the folder com.apple.kext.caches) and reboot again

 

i don't know what i used.

http://sourceforge.n...ects/voodoohda/

http://www.osx86.net..._installer.html

 

and you asked for network: Look at this post



#40
Picasso

Picasso

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 239 posts

Great for Network!!!! That´s the file!!!!!! Thanks for this!!!

I will try the Audio at night! 

 

After that i will try the HD4600, I read in Maverics topics that you can get both videos working, one for the system and the other one for processing, video, edition, etc!







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy