Jump to content

MACVIDIA 1.0.8 - 1.0.7 [GUIDA]


  • Please log in to reply
23 replies to this topic

#1
Midral

Midral

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,383 posts
  • Gender:Male
  • Location:Buggiano, Italia
Premetto che non dovete assolutamente scaricare gli installer!!!
Per poter scaricare i drivers dovete registrarvi al sito macvidia

GUIDA PER LE VERSIONI 1.0.7 ; 1.0.8

1- Scaricate i drivers
2- aprite terminale (fino alla fine della guida si userà terminale non chiudetelo)
3- Digitate sudo -s
4- Digitate nano /etc/rc ---> controllate ke non ci sia all'inizio del file nessuna scritta kextload ecc... .... ....
5- Digitate rm -R /system/library/extensions/NV* (cancellare tutti i kext che cominciano per NV
6- Digitate mv -f /System/Library/Extensions/IONDRVSupport.kext / (spostare il file IONDRVSupport nella directory principale) NON CANCELLATELO!!!!
7- Estraete i file all'interno dell'archivio zip in /System/Library/Extensions/
8- Digitate chown -R root:wheel /System/Library/Extensions/NV* && chmod -R 755 /System/Library/Extensions/NV* (serve a impostare i permessi di lettura/scrittura)
9- Digitate kextcache -k /System/Library/Extensions (vi apparira un messaggio. ignoratelo e andate avanti)
10- Digitate rm -f ~/library/preferences/byhost/com.apple.window* && rm -f ~/library/preferences/byhost/com.apple.pref* && rm -f /library/preferences/com.apple.window* (rimuovete tutte le vecchie configurazioni di monitor e finder
11- Reboot

PROBLEMI e INFO:
il 1.x.x sono gli ultimi drivers senza supporto 3D. SOLO LA VERSIONE 1.0.8[u] ha il supporto 2D che si traduce in visualizzazione di divx ad un framerate abbastanza decente, supporto per applicativi quali powerpoint, adobe reader e softwareCAD 2D; a proposito di filmati è uscita la versione definitiva del DIVX 6 per MAC-INTEL.
I prossimi drivers conterranno il supporto QUARZ E CORE, l'unica cosa che secondo me non andra mai è il supporto Turbocache quindi per i possessori di 6xxx o 7xxx TC rassegnatevi alla ram dimezzata.
per sicurezza e per evitare skermate nere all'avvio post macvidia vi consiglio di editare il file com.apple.boot.plist inserendo nella stringa graphics mode oltre alla risoluzione anke la frequenza:
ES: NVIDIA GEFORCE 6200 TURBOCACHE
risoluzione max 1280x800 frequenza con monitor integrato (notebook) 60Hz
la stringa sarà questa:
1280x800x32@60
per info non intasate il forum, scrivete kui

#2
SaxMachine

SaxMachine

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,607 posts
  • Gender:Male
  • Location:Sicily
  • Interests:Music...music...music...( I play the Saxophone ) and I'm a sys admin for job and passion.
Grazie aggiorno i link!

#3
Midral

Midral

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,383 posts
  • Gender:Male
  • Location:Buggiano, Italia

Grazie aggiorno i link!

ke link?

#4
SaxMachine

SaxMachine

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,607 posts
  • Gender:Male
  • Location:Sicily
  • Interests:Music...music...music...( I play the Saxophone ) and I'm a sys admin for job and passion.
Discussioni importanti...

#5
Midral

Midral

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,383 posts
  • Gender:Male
  • Location:Buggiano, Italia

Discussioni importanti...

ok thanks

#6
Psygon

Psygon

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 305 posts
  • Gender:Male
  • Location:Taranto [ITALY]
Io su un laptop asus A7V ho usato l'installer e x fortuna è andato tutto a buon fine,
ma ritengo ke l'installazione manuale, è di migliore auspicio.

CIAO A TUTTI!

#7
kilthedog91

kilthedog91

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Bari
Ragazzi mi sono registrato sul sito del macvidia ma non mi arriva la mail di attivazione, non è ke qualcuno mi manda per mp un link alternativo per scaricare i driver?

#8
Midral

Midral

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,383 posts
  • Gender:Male
  • Location:Buggiano, Italia

Ragazzi mi sono registrato sul sito del macvidia ma non mi arriva la mail di attivazione, non è ke qualcuno mi manda per mp un link alternativo per scaricare i driver?

nn puoi sax
scusa nn ricordavo
eccoti il link

DRIVER MACVIDIA 1.0.8

#9
kilthedog91

kilthedog91

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Bari
Gli ho installi ma ho problemi con la risoluzione. Ho creato un post a riguardo di questo problema in questa sezione.

#10
mspr

mspr

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 338 posts
Ciao a tutti,
ho installato i driver 1.0.8 ma il tutto si impianta all'avvio...
Ho provato ad avviare in modalità -v ma non cambia...
Il problema è sempre lo stesso ossia una frequenza troppo elevata come viene comunicato dal display (LCD Hyundai L90D+)
Il fatto è che non riesco ad arrivare al desktop...
Ho provato anche col comando "Graphics mode = 1280x1024x32@60" ma non cambia... sembra che non lo veda nemmeno...
Come posso correggere il tutto ?
Grazie 1000
Ciao

#11
Midral

Midral

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,383 posts
  • Gender:Male
  • Location:Buggiano, Italia

Ciao a tutti,
ho installato i driver 1.0.8 ma il tutto si impianta all'avvio...
Ho provato ad avviare in modalità -v ma non cambia...
Il problema è sempre lo stesso ossia una frequenza troppo elevata come viene comunicato dal display (LCD Hyundai L90D+)
Il fatto è che non riesco ad arrivare al desktop...
Ho provato anche col comando "Graphics mode = 1280x1024x32@60" ma non cambia... sembra che non lo veda nemmeno...
Come posso correggere il tutto ?
Grazie 1000
Ciao

prova ad attakkare il monitor alla presa DVI oppure usa il programma cscreen

#12
mspr

mspr

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 338 posts

prova ad attakkare il monitor alla presa DVI oppure usa il programma cscreen

Ciao, ho collegato il monitor alla DVI e funziona...
C'è un abisso in qualità di immagine rispetto alla VGA... e non solo con Mac ma anche su WinXP e in fase di boot... non so perchè non l'avessi fatto prima...
Resta un piccolo problema... durante la fase di avvio di OSX compaiono ancora le righe dovute ad una frequenza troppo elevata con impossibilità di leggere qualunque cosa (in avvio -v) probabilmente perchè in quella fase va a caricare una risoluzione non supportata... una volta avviato infatti oltre alla risoluzione da me impostata di 1280x1024 mi ritrovo altre due risoluzioni enormi tipo 2600x... e simili
Come posso far sì che anche in fase di avvio mantenga solo la mia risoluzione e quindi poter vedere l'intera fase di avvio correttamente ?

#13
SaxMachine

SaxMachine

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,607 posts
  • Gender:Male
  • Location:Sicily
  • Interests:Music...music...music...( I play the Saxophone ) and I'm a sys admin for job and passion.
Hai provato a settarlo nel file com.apple.boot.plist ? Alcune hanno bisogno però di una vera e propria forzatura della risoluzione al boot.

#14
mspr

mspr

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 338 posts

Hai provato a settarlo nel file com.apple.boot.plist ? Alcune hanno bisogno però di una vera e propria forzatura della risoluzione al boot.

Sì l'ho impostato nel file apple.boot.plist ed infatti una volta caricato OSX funziona tutto al meglio... il problema è limitato alla fase di boot... avviando in modalità grafica dopo la prima mela su sfondo grigio con la rotellina che gira compaiono righe e 3 mele poco distinguibili... in modalita -v parte normalmente all'inizio ma da metà del boot in poi le scritte si trasformano in righe indecifrabili...
Credo che il problema stia nel fatto che qualche file fra quelli installati del driver include un'informazione su risoluzione o frequenza che vengono letti in fase di boot prima del file apple.boot.plist
Ciao e grazie

#15
Midral

Midral

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,383 posts
  • Gender:Male
  • Location:Buggiano, Italia

Sì l'ho impostato nel file apple.boot.plist ed infatti una volta caricato OSX funziona tutto al meglio... il problema è limitato alla fase di boot... avviando in modalità grafica dopo la prima mela su sfondo grigio con la rotellina che gira compaiono righe e 3 mele poco distinguibili... in modalita -v parte normalmente all'inizio ma da metà del boot in poi le scritte si trasformano in righe indecifrabili...
Credo che il problema stia nel fatto che qualche file fra quelli installati del driver include un'informazione su risoluzione o frequenza che vengono letti in fase di boot prima del file apple.boot.plist
Ciao e grazie

prova a impostare come parametro di boot -f

#16
Albythestar

Albythestar

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
  • Gender:Male
  • Location:Italy
Ciao io ho un problema strano...
In pratica ho installato i driver con installazione manuale, ma in pratica come risoluzione mi da 1200x800 e poi mi carica le impostazioni per due monitor...cioè è come se avessi due monitor...infatti se sposto la freccia del cursore a sinistra mi ritorna a destra...perchè lo vede come un'altro monitor..e se apro le impostazioni dei monitor mi da due impostazioni..una per monitor principale e una per il secondario...come faccio??
nvidia geforcego 7300 in portatile asus f3jc MAc Osx 10.4.7

#17
Midral

Midral

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,383 posts
  • Gender:Male
  • Location:Buggiano, Italia
backuppa e cancella il kext iondrvsupport.kext

#18
Jack Layne

Jack Layne

    iDeneb Maker

  • Members
  • PipPipPipPipPipPipPip
  • 988 posts
  • Gender:Male
scusami MiDr4L DJ a cosa servono i macvidia.
scusa se la domanda e' un po' stupida

#19
_Mac4ever_

_Mac4ever_

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
Semplice, per aumentare la risoluzione e andare oltre 1024x768...

#20
spicke

spicke

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Ciao a tutti,
Mi rendo conto che il discorso è vecchio, ma dopo aver cercato nel sito mi pare che questa discussione sia quella che maggiormenti si avvicina alla soluzione del mio problema.

ho seguito la guida ma purtroppo mi sono trovato ad avere un certo numero di problemi.
La mia configurazione HW è la seguente:
cpu AMD 86_64 3000+
mobo Asus con chipset VIA (non ricordo la serie, ma viene ben riconosciuta e prima di installare i driver macvidia tutto funziona bene... a 1024x768)
HD eide
xfx 7600gs 256 mb
flat pannel compaq w19q su uscita dvi.
mac osx 10.4.6 (inst nativa)

In parole molto povere dopo aver seguito passo passo il processo di installazione dei driver 1.0.8 mi trovo con il sistema che si blocca al reboot subito dopo avetr tentato di caricare i driver.
si legge qualcosa tipo:" scheda riconosciuta... flat pannel max res 1440x900...
Panic (cpu 0 caller 0x0019c352): unresolved kernel trap...

Da questo punto in avanti mi sono logato come single user (-s) e ho tentato un recupero del sistema, ma senza risultati apprezzabili.

Qualcuno sa buttare un o di lice in questa "tenebra"? Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy