Jump to content

Asus Z87-Deluxe & 4770K - A Guide to Mavericks

haswell asus z87-deluxe mavericks installer guide

  • Please log in to reply
253 replies to this topic

#21
rgb

rgb

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

Hi

 

I am Z87 Pro user, installed ML 10.8.4 and everything works normal except sound

 

Just want to share for overclocked user, to make turbo boost working, use SSDTPRGEN and set BIOS "CPU Speed before enter OS" into Turbo mode



#22
Gus93

Gus93

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
  • Gender:Male
  • Location:St. Louis

Hi

 

I am Z87 Pro user, installed ML 10.8.4 and everything works normal except sound

 

Just want to share for overclocked user, to make turbo boost working, use SSDTPRGEN and set BIOS "CPU Speed before enter OS" into Turbo mode

What did you use to install ML? Also, how did you get the bootloader to function? I am still having issues with this sometimes. Did you format as MBR?



#23
rgb

rgb

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

What did you use to install ML? Also, how did you get the bootloader to function? I am still having issues with this sometimes. Did you format as MBR?

(sorry for poor english)

I use myHack created 10.8.4 usb installation disk with modified 10.8.4 kernel, everything will install just like normal hackintosh

I format my target drive as GUID, because it is the only and best option for further use and partition modification, most importantly, Fusion Drive is required to use a GUID partition to create

 

I would recommend everyone to format and install with GUID table, and use MBR created installation USB or any drive with chameleon installed to boot with

Just select the USB drive to boot, and select installed OS to go

This is a temporary solution and can be end until ASUS fixed that

After Asus fixed it, install chameleon on boot drive and should able to boot directly

 

Really thank you for pointing out the new ASUS BIOS has bug that makes GUID disk not bootable (I spend full 48hrs, tried >20 times but still no go before I found this post LOL!!!!!!)



#24
jsl

jsl

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 331 posts

Thanks for this post and bcc9's post which made my Asus Z87 Deluxe Dual working in Mavericks 10.9 DP3/DP4.

Too bad only AppleHDA & Thunderbolt not working yet.

However another issue bothers me more than that.

When I leave from Mac OS 10.9 DP3/4 and booting in Windows 7 (both x86 and x64 versions), my WiFi function always became abnormal and unable to find any wireless AP nearby.

Only after power off PC and remove one DRAM or clear its CMOS to regain its WiFi function.

Is there anyone suffering from the similar problem like me ?



#25
rgb

rgb

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts

attachicon.gifbcm4352.kext.zip

Thanks,  interesting the WiFi card has no description.  Regarding WiFi and BT patches, try the attached kext; it injects the same information you are patching without editing the kexts.  It is appropriate for Asus Haswell native Superfast 802.11ac Wi-Fi.

attachicon.gifbcm4352.kext.zip

 

Hi, would you find out a way to use onboard wifi on 10.8.4 ML?

Thanks



#26
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 1,270 posts
  • Gender:Male

Hi, would you find out a way to use onboard wifi on 10.8.4 ML?

 

Not possible; 10.8.5, when released.



#27
cmwilliams72

cmwilliams72

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Thanks for your information and help which made my Asus Z87 Deluxe Dual working in Mavericks 10.9 DP1-->DP 3.

However there are several items need more help here :

1. Have your Intel HD 4600 (internal graphic card) working with CI/QE enabled at resolution of 1920x1080 or more ?

2. Have your ALC 900 or 1150 HD Audio working by your DSDT.aml ?

3. Up to now I can get PCIe Nvidia GTX 780 card working only without Intel HD 4600 enabled, and need VooDooHDA 2.8.4 for audio.

4. I can not find Device (IGPU), Device (GFX0), or Device (HDAU) in your DSDT which are required for HDMI audio working.

Do you have any comment or advice for me ?

Thanks again !


In order to boot in this Asus Z87 Deluxe or Deluxe Dual MB, both USB flash and installed HDD should be formated in MBR instead of GPT.

 

Thanks...I know this is a newbie question, but how can I get the OSX installer to continue if my HDD is formatted as MBR?  I format the USB flash with MBR with no problem but the installer on my Hackintosh Asus DD forces me to change it to MBR.

 

Besides that major issue, I've been able to get through the full install (with HDD formatted as GUID) but at the end of the install, I ALWAYS get an internal fatal error where I cannot recover.  My system will show me the very long error long, but when i restart my system, I'm just taken to my bios welcome screen.



#28
Gus93

Gus93

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
  • Gender:Male
  • Location:St. Louis

Thanks...I know this is a newbie question, but how can I get the OSX installer to continue if my HDD is formatted as MBR?  I format the USB flash with MBR with no problem but the installer on my Hackintosh Asus DD forces me to change it to MBR.

 

Besides that major issue, I've been able to get through the full install (with HDD formatted as GUID) but at the end of the install, I ALWAYS get an internal fatal error where I cannot recover.  My system will show me the very long error long, but when i restart my system, I'm just taken to my bios welcome screen.

 

 

Are you using the installer from the beginning of my tutorial? If you use that installer then you should not have issues with MBR. If you try that installer and still have issues, update me and I will find you the right one.



#29
cmwilliams72

cmwilliams72

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

No because I cannot get to the installer using those instructions; I've been using myHack (and it's pretty much the only one that's worked).



#30
Gus93

Gus93

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
  • Gender:Male
  • Location:St. Louis

No because I cannot get to the installer using those instructions; I've been using myHack (and it's pretty much the only one that's worked).

In that case there should be a place during the myHack USB creation process where you select MBR:

 

"Posted on 

2013/06/11

 by Conti

This has taken a lot longer than I anticipated to actually release. I have not had the time, energy or financial resources to dedicate more time to this project than a day here or there for many months. There are still more changes planned for the 3.2 milestone and I like to avoid releasing minor builds or revisions these days but in this case it is quite justified due to this years WWDC and the release of the 10.9 developer preview.

The download is available on the guide page.

Changelog:

  • Bugfix: Fixed “user canceled exiting error”.
  • Bugfix: Fixed (and improved) dialog icons.
  • Made MBR Patch optional (yes/no dialog)."

From MyHack Installation Page



#31
cmwilliams72

cmwilliams72

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

In that case there should be a place during the myHack USB creation process where you select MBR:

 

"Posted on 

2013/06/11

 by Conti

This has taken a lot longer than I anticipated to actually release. I have not had the time, energy or financial resources to dedicate more time to this project than a day here or there for many months. There are still more changes planned for the 3.2 milestone and I like to avoid releasing minor builds or revisions these days but in this case it is quite justified due to this years WWDC and the release of the 10.9 developer preview.

The download is available on the guide page.

Changelog:

  • Bugfix: Fixed “user canceled exiting error”.
  • Bugfix: Fixed (and improved) dialog icons.
  • Made MBR Patch optional (yes/no dialog)."

From MyHack Installation Page

Okay now I've had a little time to give a couple things a try.  I'm using Christ111's installer and once I used the following flags: -v PCIRootUID=0 cpus=1 I was able to get into the installer.  I partitioned my SSD HD drive to MBR through Disk Utility on the installer USB, as recommended, and sadly, I keep getting this error message.

 

"To install on this disk, open Disk Utility by choosing Utilities > Disk Utility, and repartition this disk using "GUID Partition Table." Important: you will lose all data on this disk by repartitioning it."

 

I'm not sure where to go from here, as I have no options to continue, if my HD is MBR.  Any other recommendations would be greatly appreciated...sad that I cannot get this beautiful new computer working with OSX Maverick.



#32
cmwilliams72

cmwilliams72

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Okay major update so here it goes:

 
I've tried almost everything to get Mac OSX Maverick on my Asus Z87 Deluxe/Dual and I don't know where to go from here.  I followed the following manuals to the letter...yes I've done that many installs and re-installs: Gus's manual for his Z87 Deluxe, Rockiron's vanilla install instructions (see insanelymac guides), and I've installed via myHack and I cannot get any of the installs to boot with my HDD; even after following all of the post-install recommendations.  
 
I know my biggest issue is that during all of the above installs, I do not have the option to choose MBR as a format option.  OSX Installer ONLY allows me to continue my install with a GUID partition (no matter what option above).
 
Based on various recommendations, I even went to the great length of continuing to install on my Hackintosh with a GUID partition and using my MacBook Pro to format a separate hard drive as MBR and copy all of the files from the prior install on the MBR drive...again to no avail.
 
I'm not sure how individual's are getting past the MBR issue or how they got their systems working, but if someone could spare some time to help that would be great.
 
Best,
 
CW


#33
snatch

snatch

    InsanelyMac Geek

  • Donators
  • 189 posts

I just did another clean install of DP5. No problem and no MBR. Just create 2 GUID partitions on USB... Installed Clover UEFI on the first partition and DP5 on the second...

 

Used this guide for the DP5 partition:  http://osxdaily.com/...-install-drive/



#34
jay_phoenix

jay_phoenix

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male

Hey Guys , I'm new to this and haven't attempted a hack since my i7-970-WHICH is STILL a BEAST getting geeekbench  3 scores of 18,469 @ 4.08ghz.WOOOT, however I'm not here to gloat.I also have an asus impact ROG itx board I'm trying to hack and have a question

 

 is it absolutely necessary to flash the bios? Ive been able to boot and install without any issues aside from the fact that i still need the USB to do it after install

So far everything is working except audio...and well BT and WIFI...so pretty much nothing is working cept lan OOB



#35
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 1,270 posts
  • Gender:Male

 

 is it absolutely necessary to flash the bios? Ive been able to boot and install without any issues aside from the fact that i still need the USB to do it after install

So far everything is working except audio...and well BT and WIFI...so pretty much nothing is working cept lan OOB

Z87I-Deluxe, no BIOS patching required (tested on 0403 and 0702); Console/kernel[0]: XCPM: registered. For Asus 802.11ac WiFi and BT, install the attached kext in S/L/E.  What audio codec?

9/21/13 - Updated bcm4352.kext 

Attached Files



#36
jay_phoenix

jay_phoenix

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male

Z87I-Deluxe, no BIOS patching required (tested on 0403 and 0702); Console/kernel[0]: XCPM: registered.  For Asus 802.11ac WiFi and BT, install the attached kext in S/L/E.  What audio codec?

Alc 1150 codec is 900 i believe..I installed the kext attached and wifi works but no  bluetooth:(


Alc 1150 codec is 900 i believe..I installed the kext attached and wifi works but no  bluetooth:(

By the way my build is Rampage VI impact 

4770k

Gtx 660ti



#37
jay_phoenix

jay_phoenix

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male

confirmed everything now working on asus impact with this guide



#38
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 1,270 posts
  • Gender:Male

confirmed everything now working on asus impact with this guide

Including BT and audio?



#39
jay_phoenix

jay_phoenix

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male

Including BT and audio?

Yes sir!! Had to use voodoo for audio.. SAys my cpu is 4.3ghz zeon though


Including BT and audio?

i didnt use a dsdt though..should i have:?



#40
Vasko Tsintsev

Vasko Tsintsev

    InsanelyMac Protégé

  • Donators
  • 14 posts

Yes sir!! Had to use voodoo for audio.. SAys my cpu is 4.3ghz zeon though


i didnt use a dsdt though..should i have:?

Talking about Audio, try the attachment, don't forget about the permissions and send all gratitude for "toleda".







Also tagged with one or more of these keywords: haswell, asus z87-deluxe, mavericks, installer, guide


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy