Jump to content

Asus Z87-Deluxe & 4770K - A Guide to Mavericks

haswell asus z87-deluxe mavericks installer guide

  • Please log in to reply
248 replies to this topic

#201
Khid

Khid

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 190 posts

Clearly...

 

I'm talking about the Z87, and mentioned having to decide between the GB or this... 

 

If anyone knows whether or not TB2's working that would be greatly appreciated.

 

Gracias.



#202
bergoulle

bergoulle

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
  • Gender:Male

Thank you all for your input. Coming from a P5K ... :plane:



#203
swerve23

swerve23

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

ok i've been trying to keep up but im kind of lost, help would be appreciated.

 

can someone give me a run down on how to install mavericks, etc. with this build.

 

Processor: Intel Core i7-4770K CPU @ 3.50GHz 801 MHz 
Motherboard: Asus Z87-Deluxe/Dual 
Graphics Card: MSI GeForce GTX 770 2GB Twin Frozr Gaming OC 



#204
cdnGHOST

cdnGHOST

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:Calgary AB,Canada

Hey all i followed a guide on a "different site" to get my Maximus VI Impact working, so far all but 3 things are working possibly 4 ill update the last when i get home... but the first 3 are as follows..

 

1) Video card is a Radeon HD 5870 it shows up under about this mac as a Radeon 5000 series... any clue how to fix this?

2) Bluetooth was working on 10.9.0 but once i update to 10.9.1 it no longer works.... shows but can't connect anything... anyone know of an updated kext?

3) iMessage is not working, add the FileNVRAM.dylib into my /Extra/modules folder, changed my iCloud password and updated my credit card info in iTunes but am still getting the activation error....

 

Any help would be great, otherwise everything is working so far just need to test the sleep and awake functions... but i never use standby so not a big deal to me if it does not work...

my system components are in my sig



#205
treyboy484

treyboy484

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Interests:Hackintoshing, Photography, and Modern Architecture
Since I am not at my PC I can answer:

1) Not really a problem. It's just a cosmetic issue. Not sure how to fix that tho sorry.

#206
bonsaigardener

bonsaigardener

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

I've been attempting the WiFi kext installation on my Asus Z87-Pro mobo with no luck.  I tried bcm4352.kext files but the system never recognized a wireless interface.  BTW I want to use the on-board wifi interface.  Anyone have luck with the Z87-pro yet?



#207
treyboy484

treyboy484

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Interests:Hackintoshing, Photography, and Modern Architecture
If you can't get the Wireless working, try buying the TP-Link TP-WDN4800 (I think that's what it's called). Works OOB with OS 10.

#208
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 875 posts
  • Gender:Male

10.9 - BCM4352/AW-CE123H BT Pairing

 

Testers needed:

 

For Mavericks (10.9 and newer),  BCM20702A0 BT moved from EHCI (USB 2.0) in 10.8.5 to XCHI (USB 3.0) in 10.9.  It is not possible to reliably pair BCM20702A0 BT devices on XCHI (new Intel XCHI driver may help).  In the interim, an alternate pairing procedure is proposed:

 

1. Remove an previously paired devices.

2. Power down

3. Set BIOS/Advanced/USB Configuration/xHCI/Disabled (note current setting)

4. Restart

5. Pair all BT devices

6. Power down

7. Set BIOS/Advanced/USB Configuration/xHCI/Enabled (previous setting)

8. Restart

 

Disabling XHCI forces BCM2070A2 BT to load in EHCI, allowing pairing. Once paired, BCM2070A2 BT works on XCHI as expected.



#209
bergoulle

bergoulle

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
  • Gender:Male

 

10.9 - BCM4352/AW-CE123H BT Pairing

 

Testers needed:

 

For Mavericks (10.9 and newer),  BCM20702A0 BT moved from EHCI (USB 2.0) in 10.8.5 to XCHI (USB 3.0) in 10.9.  It is not possible to reliably pair BCM20702A0 BT devices on XCHI (new Intel XCHI driver may help).  In the interim, an alternate pairing procedure is proposed:

 

1. Remove an previously paired devices.

2. Power down

3. Set BIOS/Advanced/USB Configuration/xHCI/Disabled (note current setting)

4. Restart

5. Pair all BT devices

6. Power down

7. Set BIOS/Advanced/USB Configuration/xHCI/Enabled (previous setting)

8. Restart

 

Disabling XHCI forces BCM2070A2 BT to load in EHCI, allowing pairing. Once paired, BCM2070A2 BT works on XCHI as expected.

 

 

Hi toleda, 

 

I have tried your tip  on ASUS Maximus VI impact. Unfortunately it didn't work. 

 

Thx anyway. 



#210
cdnGHOST

cdnGHOST

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:Calgary AB,Canada

Hi toleda, 

 

I have tried your tip  on ASUS Maximus VI impact. Unfortunately it didn't work. 

 

Thx anyway. 

Hey I have an ASUS Maximus VI impact as well, I followed a guide on a different site to get my hack to work.

To get the bluetooth working after updating from 10.9.0 -> 10.9.1 all i did was go to my bios and under

Advanced \ USB configuration 

I enabled EHCI Hand-off loaded OS X and was able to pair my magic mouse and track pad for some reason though I can't pair my apple keyboard....

but everything else works great..



#211
peter2162

peter2162

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hi,

sorry for my English...

This installation instructions works great on Z87-DELUXE, I can even recommend you few more things which you can do. So, let's start: 

 

LAN cards:

Realtek -> you know from the first post - how to set it up. 

Intel -> There is "AppleIntelE1000e.kext" attached, or you may find it googling. 

 

WiFi card:

This is the easiest part,

Just edit: /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortBrcm4360.kext/Contents/Info.plist ,

and add your device/vendor IDs, for example this is mine: <string>pci14e4,43b1</string>.

it works just great. 

 

Bluetooth:

Using System Profiler we can see that the device is: BCM20702A0, with ProductID/VendorID = 0x17cf/0x0b05 = 6095/2821(from hex).  

So you have to edit this file:

/System/Library/Extensions/IOBluetoothFamily.kext/Contents/PlugIns/BroadcomBluetoothHostControllerUSBTransport.kext/Contents/Info.plist

and add new record: 

<key>BroadcomUSBBluetoothHCIController - MediaLink BT4.0 Adapter</key>

<dict>

    <key>CFBundleIdentifier</key>

    <string>com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport</string>

    <key>IOClass</key>

    <string>BroadcomBluetoothHostControllerUSBTransport</string>

    <key>IOProviderClass</key>

    <string>IOUSBDevice</string>

    <key>idProduct</key>

    <integer>6095</integer>

    <key>idVendor</key>

    <integer>2821</integer>

</dict>

Be careful with the syntax, use tabs wherever it's needed. 

After this step it's recommended to clear, rebuild the Extensions cache, and you will see the new device in System Profiler.

 

Audio:

Here we are talking about ALC1150, which is actually ALC900, but with a little bit better quality. I'm almost sure that this codec is too similar to ALC882, and will be happy if some guru from the forum help a little bit with AppleHDA.kext. I have attache Linux codec dumps for this, and will be really happy to assist with the tests. Meanwhile we can use  VoodooHDA , which works for me, but in my case i have few more changes which I have made in the DSDT and I'm not sure - will it work or not without the modifications, will be great if someone make tests. 

 

Updates: thanks again "toleda", here it is: link

 

System:

In my case it is configured as: iMac/Mac13,2 from /Extra/smbios.plist , and the /Extra/Extensions/ are all attached on the link below.

This system build is very stable and fast ...

 

Good Luck .

 

For the lazy people:

http://tsintsev.com/...es/packz87d.zip

 

how did you edit the p list for the wifi?!?! i dont have one.  by the way i have an asus z87 pro could i still use this set up for it? i really need the wifi please get back to me.  thank you



#212
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 875 posts
  • Gender:Male

Bluetooth Revisited

Asus/BCM4352 BT

 

Two choices:

1. bcm4352bt.kext (no firmware update) - attached

2. BTFirmwareLoader - http://forum.osxlati...mware-uploader/ (Registration required)

 

Reply with result and IOReg.

 

Credit: EMlyDinEsH http://forum.osxlati...mware-uploader/

Attached Files



#213
bergoulle

bergoulle

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
  • Gender:Male

Installation made with the new kext. 

Attached File  IOBluetoothHCIController.tiff   152.88KB   33 downloads

 



#214
kuhnnl

kuhnnl

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Bluetooth Revisited

Asus/BCM4352 BT

 

Two choices:

1. bcm4352bt.kext (no firmware update) - attached

2. BTFirmwareLoader - http://forum.osxlati...mware-uploader/ (Registration required)

 

Reply with result and IOReg.

 

Credit: EMlyDinEsH http://forum.osxlati...mware-uploader/

 

Asus Z87-Deluxe/Quad ( bcm20702a0 )

 

Cannot install the bcm4352bt.kext in the S/L/E folder it shows an stop sign on bcm4352bt.kext, installed manually and with kext utility no success, BT gets recognized but shows no devices with the other bcm4352.kext

 

- xHCI on enabled in bios 



#215
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 875 posts
  • Gender:Male

Cannot install the bcm4352bt.kext in the S/L/E folder it shows an stop sign on bcm4352bt.kext,

My mistake, permissions problem, fixed,  Two choices: 1. download and install updated kext or 2. Terminal/chmod 755 bcm4352bt.kext.  

Rebuild kernel cache and restart.



#216
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 875 posts
  • Gender:Male

WiFi Update, 5 GHz OK.  See Post #1, Airport - PCIe Half Mini - LAN and Wireless - InsanelyMac Forum  Credit: Skvo



#217
treyboy484

treyboy484

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Interests:Hackintoshing, Photography, and Modern Architecture
I tried the new kext but I get some Bluetooth USB Transport errors.

#218
rtwick

rtwick

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male

WiFi Update, 5 GHz OK.  See Post #1, Airport - PCIe Half Mini - LAN and Wireless - InsanelyMac Forum  Credit: Skvo

 

installed the patch. 5GHz now working. getting 300Mbps in a/n mode.

 

Thanks



#219
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 875 posts
  • Gender:Male

I tried the new kext but I get some Bluetooth USB Transport errors.

Which kext?



#220
treyboy484

treyboy484

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Interests:Hackintoshing, Photography, and Modern Architecture
bcm4352.kext
Attached File  ImageUploadedByTapatalk1393910189.675551.jpg   188.46KB   3 downloads

Here's an image. It works great in safe mode, just not out of -x. I am using Clover if that matters.





Also tagged with one or more of these keywords: haswell, asus z87-deluxe, mavericks, installer, guide


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy