Jump to content

Compatibility of GA-Z87MX-D3H & Core i7 4770K


  • Please log in to reply
24 replies to this topic

#21
bcc9

bcc9

    InsanelyMac Legend

  • Coders
  • 1,277 posts
  • Gender:Male

@bcc9:
Try a different binary patch. Several people with ALC892, including myself, had the oscillation issue when using the ALC895 device id. As with other codecs, just use AD1984 or AD1988.
(http://www.insanelym...7108/?p=1888843)

Thanks I had already tried ADI 1984B (0x11d4198b), and I get no sound before&after sleep. Just tried ADI 1984 (0x11d41984), and same thing. Only my original try with ALC 885 as the patch codec is giving me some success. Haven't had time to look any deeper myself yet.

#22
Pike R. Alpha

Pike R. Alpha

    InsanelyMac Geek

  • Developers
  • 213 posts
  • Gender:Male

I also have this board in my collection and I don't have any problem whatsoever so what exactly do you mean with "no sound before/after sleep"? Is AppleHDA.kext not loading, are interrupt numbers missing or what else can you tell me?



#23
toleda

toleda

    InsanelyMac Legend

  • Gurus
  • 907 posts
  • Gender:Male

With 10.9 z87 alc892, the audio ports are showing up as:

Line Out Audio line-out port
Line Out Audio line-out port
Line Out Audio line-out port
Digital Out Optical digital-out port

I posted some feedback on your github page in your master thread.
I've updated my post, the AppleHDA patching is 2 EZ steps (if you leave out the AppleHDAHardwareConfigDriver part like I currently have).
I could do you 1 better and make a script that does those 2 steps for you, if it's OK with toleda to repack his xml.

 

The 10.9 audio ports showing suggests the correct pinconfigs (Info.plist) are not installed in the AppleHDA.kext that loaded.  Likely, the reason for no sound.

I have not found your comments on Github.

Absolutely interested in that 1 better script.



#24
bcc9

bcc9

    InsanelyMac Legend

  • Coders
  • 1,277 posts
  • Gender:Male

I also have this board in my collection and I don't have any problem whatsoever so what exactly do you mean with "no sound before/after sleep"? Is AppleHDA.kext not loading, are interrupt numbers missing or what else can you tell me?

For all 3 patch codecs I tried with my patch-hda script, the result appears the same as in post #19 under system preferences, and the audio volume controls are available. Of course AppleHDA is loaded. But sound is only present after wake from sleep and only when I use patch codec ALC 885.
If you have a working config, you could share your details like I did. Just claiming you have it working for yourself isn't really of any help. Thanks.

#25
René_

René_

    InsanelyMac Protégé

  • Donators
  • 74 posts
  • Gender:Male
  • Location:Maassluis, Netherlands
This ALC892 is working perfect on my GA-Z87M-D3H with Mavericks:
http://www.insanelym...11#entry1936022





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy