Jump to content

AppleHDA Patching in 10.9 Mavericks

applehda binary patch

  • Please log in to reply
148 replies to this topic

#141
joe2108

joe2108

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 102 posts

You will have to use the AppleHDA on my blog for now on the non 10.9 DMG and use the DSDT and AppleHDA on the DMG for Gigabyte until we can get it working. 

 

Sorry  I'll try every update on your site,

Your appleHDA patch never work on my gigabyte mobo. 



#142
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,958 posts
  • Gender:Male

Sorry  I'll try every update on your site,

Your appleHDA patch never work on my gigabyte mobo. 

I was referring to the old DMG and DSDT's for Pre 10.9. That works fine in 10.9 but the DSDT's have sleep issues unlike the ones on the 10.9 DMG. 

 

 

The latest one on the 10.9 DMG is working on non x79 GB boards. Not sure... post a IOreg and install the one from the DMG I posted last night before you post it. Thanks. 



#143
joe2108

joe2108

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 102 posts

Still not working

 

screenshot

http://cl.ly/image/1F2v2l3j1X05

 

Ioreg

http://cl.ly/0k103T1p1r3x

 

Using Last AppleHDA on your DMG

http://cl.ly/2Z3l2I26321e

 

I was referring to the old DMG and DSDT's for Pre 10.9. That works fine in 10.9 but the DSDT's have sleep issues unlike the ones on the 10.9 DMG. 

 

 

The latest one on the 10.9 DMG is working on non x79 GB boards. Not sure... post a IOreg and install the one from the DMG I posted last night before you post it. Thanks. 



#144
quis

quis

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts

Anyone with ALC888? I've tried dozens of solutions posted by people since Snow Leopard, the only one that worked I couldn't recall where I got it, but it's a really old version, and gives out electric buzzes (don't know what you call it, but annoying as hell) in Mavericks from time to time. Stuck with Voodoo, which barely works, for now... :(

EDIT: Tried this...

Replace AD1984 to ALC662, and ALC884 to zero
 
8419d411 > 6206ec10
8408ec10 > 00000000


In addition to binary patch AppleHDA (8419d411 > 8808ec10), I just turn on the HDEF bit in Clover and HDAInject 888. Still no luck (grey icon in the menubar "no output device," and lots of sound assertion of course). Am I missing something?

Attached File  Screen Shot 2013-09-06 at 2.31.55 PM.png   111.47KB   20 downloads



#145
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 698 posts
  • Gender:Male

Hello. Can anyone give an advice of how to get rid of them?

30/09/13 14:32:12,000 kernel[0]: Sound assertion in AppleHDAWidget at line 2181
30/09/13 14:33:05,000 kernel[0]: Sound assertion in AppleHDAWidget at line 2181
30/09/13 14:33:56,000 kernel[0]: Sound assertion in AppleHDAWidget at line 2181
30/09/13 14:34:46,000 kernel[0]: Sound assertion in AppleHDAWidget at line 2181
30/09/13 14:35:36,000 kernel[0]: Sound assertion in AppleHDAWidget at line 2181



#146
Eloi Bermejo

Eloi Bermejo

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Hello! Thanks again for all the precious info!
Do you know the codec/string I should replace to enable ALC268? Thanks!

 

EDIT.: I received the info that ALC268 is one of the native AppleHDA codecs, so no replace is necessary. I need to confirm it.



#147
codedmind

codedmind

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Anyone with ALC888? I've tried dozens of solutions posted by people since Snow Leopard, the only one that worked I couldn't recall where I got it, but it's a really old version, and gives out electric buzzes (don't know what you call it, but annoying as hell) in Mavericks from time to time. Stuck with Voodoo, which barely works, for now... :(

EDIT: Tried this...


In addition to binary patch AppleHDA (8419d411 > 8808ec10), I just turn on the HDEF bit in Clover and HDAInject 888. Still no luck (grey icon in the menubar "no output device," and lots of sound assertion of course). Am I missing something?

attachicon.gifScreen Shot 2013-09-06 at 2.31.55 PM.png

I have some issue but my codec is AD 1988 :/



#148
NeXtor

NeXtor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 294 posts
hello, I installed mavericks on my second PC in my signature but I have a problem with the audio. 
 
In information system, inputs and outputs are recognized, but in the system preferences I have nothing. 
 
How can I fix? 
 
thanks
 
post-31099-0-95439100-1394668792.png


#149
NeXtor

NeXtor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 294 posts

 

hello, I installed mavericks on my second PC in my signature but I have a problem with the audio. 
 
In information system, inputs and outputs are recognized, but in the system preferences I have nothing. 
 
How can I fix? 
 
thanks
 
post-31099-0-95439100-1394668792.png

 

 

anyone?







Also tagged with one or more of these keywords: applehda, binary patch


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy