Jump to content

[Success] HP ProBook 4x30s 4x40s

4530s 4x30 Mavericks DP hp 10.9

  • Please log in to reply
142 replies to this topic

#101
alboz83

alboz83

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts

Not really.  The ProBook Installer is for Sandy/Ivy Bridge with Intel 6/7-series chipset HP ProBooks.  Your laptop is an HP, but that is where the similarities end.  Your laptop is gen1 Core i-series with 5-series chipset.

 

Probably your slowness is due to no QE/CI on graphics.  You might look at this thread for that: http://www.insanelym...-graphics-qeci/

Ok thanks, I know the thread of Intel HD 1st, and i can get QE/CI, but is not smooth how windows. Anyway, i use your kexts for touchpad and keyboard, and work very well, but i have problems with on/off led and brightness keys. Wifi led work (only at first boot is red), sound led work but when the sound is on the led became red and turn off after always 33 seconds. Brightness keys don't work, i have only one keys (pause keys) for increase brightness. It's possibile to adjust this things?



#102
juliopw

juliopw

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male

Actually, it sleeps the laptop, just like the power button does on my Apple MacBookAir6,2 :-)

Ctrl+Power will bring up the menu (with a bonk).  And surprising... Fn+Power will just sleep the display.

Ctrl+power did it, but if i press only the "power" it turn the display off (instead of sleeping the whole computer). Didn't knew how it works on real macs. :P

 

Also, with the files provided, when booting the Install USB key, there's a gray screen in some cases. To bypass that just close the screen and open it again.



#103
RehabMan

RehabMan

    InsanelyMac Legend

  • Coders
  • 1,278 posts
  • Gender:Male
  • Location:Bellingham, WA
  • Interests:skiing, software, classic cars

Ctrl+power did it, but if i press only the "power" it turn the display off (instead of sleeping the whole computer). Didn't knew how it works on real macs. :P

 

Also, with the files provided, when booting the Install USB key, there's a gray screen in some cases. To bypass that just close the screen and open it again.

On my 4530s, power alone sleeps the computer...

 

BTW, this behavior (sleep with power button, no menu) is new behavior with 10.9.  My MBA with ML 10.8.5 displays the menu.  Apple obviously intended to make this change.  I think most people will prefer the old way and will not be happy with this change.



#104
juliopw

juliopw

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male

On my 4530s, power alone sleeps the computer...

 

BTW, this behavior (sleep with power button, no menu) is new behavior with 10.9.  My MBA with ML 10.8.5 displays the menu.  Apple obviously intended to make this change.  I think most people will prefer the old way and will not be happy with this change.

Oh, my mistake. It did sleep now, but I forgot to change the sleep method to RAM, giving me a KP (sometimes). Here's the image http://d.pr/i/S8Yz



#105
whoareyou

whoareyou

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Location:Olathe, KS

Please read the post I made after this one...



#106
slarsah

slarsah

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Installed 10.9 GM and Probook Installer 6.1.6 on my 4530s. Everything works great! Thanks for help!

 

FYI:

10.9 GM and Probook Installer 6.1.6 works great on my wifes ProBook 6460b to:) Just had to install "VoodooHDA 0.2.7.3" for sound, and "hnak´s AppleIntelE1000e" for ethernet.

 

 

 

HP ProBook 4530s, HD 1920x1080 | F.40 | i7 2720qm (2.2 GHz) | 16 GB RAM DDR3 1600 MHz | Intel HD 3000 Graphics | OSX 10.9 and Windows 8 | Geekbench 64bit 10031
HP ProBook 6460b, HD 1366x768 | F.20 | i5 2410m (2.3 GHz) | Intel HD 3000 Graphics | OSX 10.9 | Geekbench 64bit 6034



#107
philip_petev

philip_petev

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
  • Gender:Male
  • Location:Haskovo, Bulgaria

Same here, installed GM yesterday, Probook Installer 6.1.6 works like a charm!



#108
whoareyou

whoareyou

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
  • Gender:Male
  • Location:Olathe, KS

Ok, I got it working mostly, finally after like 10 hours.... On my 6470b, Sleep, Audio, and mostly everything works but i still cant get my Intel HD 4000 working..... used a the kext from here, http://www.osx86.net...hd-4000-driver/

 

It recognizes that its an HD4000 with 1024mb of VRAM, but its clearly not working as all videos are VERY jotty, Launchpad is horrible, and its laggy all around with graphics.... any clue how to fix it please?



#109
azlvda

azlvda

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Male

installed gm on 4340 but cant login to apple id ..an error has occured

please help

 

edited: Solved...



#110
davemlinux

davemlinux

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

yes intaller 6.1.6works great on my hp probook 4530S version the only thing that i had to fix is the darnnn Boot0 error other than that works like a charm

Thanks PETE looking forward for your next update  :thumbsup_anim:



#111
antonioj

antonioj

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts

Hello, i need some help...i managed to install the GM on a 4340s with i5 processor (Ivy bridge) and hd4000 graphics, but i only get 1024x768 resolution...i runned the latest probook installer

 

edit: managed to solve the problem using this http://www.osx86.net...hd-4000-driver/



#112
AtomeX

AtomeX

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Hi RehabMan,

I need you're help, I can only start with -x flag in my hp5330m here is a part of the log

 

Oct  8 01:01:27 localhost kernel[0]: Kext com.apple.driver.AppleIntelHD3000Graphics - library kext com.apple.iokit.IOGraphicsFamily not found.Apple16X50PCI22: Identified 1 Serial channels at PCI Bus=0 Dev=22 Func=3
Oct  8 01:01:27 localhost kernel[0]: Can't load kext com.apple.driver.AppleIntelHD3000Graphics - failed to resolve library dependencies.Apple16X50UARTSync22: Detected 16550AF/C/CF FIFO=16 MaxBaud=115200
Oct  8 01:01:27 localhost kernel[0]: Kext com.apple.driver.AppleIntelHD3000Graphics failed to load (0xdc00800e).
Oct  8 01:01:27 localhost kernel[0]: Failed to load kext com.apple.driver.AppleIntelHD3000Graphics (error 0xdc00800e).
Oct  8 01:01:27 localhost kernel[0]: Kext com.apple.driver.AppleHDAController - library kext com.apple.iokit.IOGraphicsFamily not found.Couldn't alloc class "Gen6Accelerator"
Oct  8 01:01:27 localhost kernel[0]: Can't load kext com.apple.driver.AppleHDAController - failed to resolve library dependencies.
Oct  8 01:01:27 localhost kernel[0]: Kext com.apple.driver.AppleHDAController failed to load (0xdc00800e).
Oct  8 01:01:27 localhost kernel[0]: Failed to load kext com.apple.driver.AppleHDAController (error 0xdc00800e).
Oct  8 01:01:27 localhost kernel[0]: Couldn't alloc class "AppleHDAController"
 

And I post my DSDT to.

Thank you Rehab, best regards.

 

Last think if you have time, I can't use your last vodoops2 kext, it's not working ?

 

 

Attached Files



#113
RehabMan

RehabMan

    InsanelyMac Legend

  • Coders
  • 1,278 posts
  • Gender:Male
  • Location:Bellingham, WA
  • Interests:skiing, software, classic cars

Hi RehabMan,

I need you're help, I can only start with -x flag in my hp5330m here is a part of the log

 

Oct  8 01:01:27 localhost kernel[0]: Kext com.apple.driver.AppleIntelHD3000Graphics - library kext com.apple.iokit.IOGraphicsFamily not found.Apple16X50PCI22: Identified 1 Serial channels at PCI Bus=0 Dev=22 Func=3
Oct  8 01:01:27 localhost kernel[0]: Can't load kext com.apple.driver.AppleIntelHD3000Graphics - failed to resolve library dependencies.Apple16X50UARTSync22: Detected 16550AF/C/CF FIFO=16 MaxBaud=115200
Oct  8 01:01:27 localhost kernel[0]: Kext com.apple.driver.AppleIntelHD3000Graphics failed to load (0xdc00800e).
Oct  8 01:01:27 localhost kernel[0]: Failed to load kext com.apple.driver.AppleIntelHD3000Graphics (error 0xdc00800e).
Oct  8 01:01:27 localhost kernel[0]: Kext com.apple.driver.AppleHDAController - library kext com.apple.iokit.IOGraphicsFamily not found.Couldn't alloc class "Gen6Accelerator"
Oct  8 01:01:27 localhost kernel[0]: Can't load kext com.apple.driver.AppleHDAController - failed to resolve library dependencies.
Oct  8 01:01:27 localhost kernel[0]: Kext com.apple.driver.AppleHDAController failed to load (0xdc00800e).
Oct  8 01:01:27 localhost kernel[0]: Failed to load kext com.apple.driver.AppleHDAController (error 0xdc00800e).
Oct  8 01:01:27 localhost kernel[0]: Couldn't alloc class "AppleHDAController"
 

And I post my DSDT to.

Thank you Rehab, best regards.

 

Last think if you have time, I can't use your last vodoops2 kext, it's not working ?

Your graphics kexts are failing to load.  Are you sure you're using a genuine download from Apple? (eg. are you are registered/paid Apple developer?).  Latest VoodooPS2 kext is working just fine here.



#114
pokenguyen

pokenguyen

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 434 posts
  • Gender:Male

Installed 10.9 GM and Probook Installer 6.1.6 on my 4530s. Everything works great! Thanks for help!

 

FYI:

10.9 GM and Probook Installer 6.1.6 works great on my wifes ProBook 6460b to:) Just had to install "VoodooHDA 0.2.7.3" for sound, and "hnak´s AppleIntelE1000e" for ethernet.

 

 

 

HP ProBook 4530s, HD 1920x1080 | F.40 | i7 2720qm (2.2 GHz) | 16 GB RAM DDR3 1600 MHz | Intel HD 3000 Graphics | OSX 10.9 and Windows 8 | Geekbench 64bit 10031
HP ProBook 6460b, HD 1366x768 | F.20 | i5 2410m (2.3 GHz) | Intel HD 3000 Graphics | OSX 10.9 | Geekbench 64bit 6034

Just a note for your HP Probook 6460b, what wifi card are you using?



#115
Craigrox

Craigrox

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
  • Gender:Male

Brilliant work guys :)

 

I'm normally on "that other forum", but I've just installed Mavericks GM on my desktop and it's now working like a charm so my 4340s will be getting the same treatment shortly!

 

It's great to hear that the latest PBI *unofficially* supports 10.9, having an Ivy-Bridge system I hope to give you some feedback soon

 

Regards,

Craig



#116
slarsah

slarsah

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
"Just a note for your HP Probook 6460b, what wifi card are you using?"

I'm using dlink dwa-121 usb dongle for wifi

#117
davemlinux

davemlinux

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Unfortunately you will have to wait for the manufacture of your dongle to update the drivers since is not native out of the box i could only suspect that but i could be wrong wish you it gets resolved 😝✌

#118
pokenguyen

pokenguyen

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 434 posts
  • Gender:Male

"Just a note for your HP Probook 6460b, what wifi card are you using?"

I'm using dlink dwa-121 usb dongle for wifi

What's your internal Wifi card then? Is it Broadcom 43224 abg?



#119
hacer.barro

hacer.barro

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
  • Gender:Male

This is my first post here.  Really appreciate everyone's hard work.  Running 10.8.5 and 10.9 GM both on a triple boot 4530s and both have the same very minor issue with the built in HD webcam in FaceTime and Photo Booth.   I'm curious if anyone might know of a fix for the choppy pixelated video?  Works fine in other apps.  I know of the workaround found elsewhere using camwiz opened after either of the before mentioned, I'm using automator to open FaceTime or Photo Booth, followed by a pause then opening the camwiz free app and then shutting down camwiz and automator.  Wondering if there may be a real fix, if not, no big deal.  Again, thanks!



#120
antonioj

antonioj

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts

Hello,

 

My main problems right now are:

 

graphic glitches on launchpad/safari

 

 

Any suggestions to fix this?

 

 

And that´s right: dwa-125 wifi dongle is working with Snow Leopard drivers (version from 2011)







Also tagged with one or more of these keywords: 4530s, 4x30, Mavericks, DP, hp, 10.9


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy