Jump to content

[Problem] Radeon HD 4650


  • Please log in to reply
29 replies to this topic

#1
Extended

Extended

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
  • Location:Germany

I have installed OS X 10.7.3 on my Toshiba Satellite L555-10M

For the Graphics i used the Kext's from Smartie77 http://www.insanelym...ion-1073-final/

But in the Settings i can only choose 1366x768 (my resolution is 1600x900) and the screen colors get crazy so that i cant see anything.

 

Hope anyone can help me to get a solution for that



#2
plsh2me

plsh2me

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male
  • Location:Bangladesh

For more than 1366x768 resolution you have to do forced display edid. Can follow one of the following guide - 

http://www.insanelym...splay-problems/

 

http://legacy.tonyma...hp?f=15&t=53970

 

Hope this will help you :D .

 

Thank you

Palash



#3
Extended

Extended

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
  • Location:Germany

Will try it and give feedback! Thanks!



#4
Extended

Extended

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
  • Location:Germany

Okay ive tried it the whole night. Nothing will work  :(

 

I get the right screen resolution but my screen looks like this:

 

E6mZe.jpg

 

 

Hope anyone can help i dont have any idea how to fix it :(

 

I have attached my edid from windows

Attached Files



#5
plsh2me

plsh2me

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male
  • Location:Bangladesh

Did you see the change on About this mac>Graphics/Display?

Attached File  dis.jpg   166.45KB   1 downloads

 

Open Terminal and the execute command - ioreg -lw0 > ~/Desktop/ioregSaved.txt 

And send the file, I will try for you.



#6
Extended

Extended

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
  • Location:Germany

I attached the file  :D

 

Ngrhd.png

Attached Files



#7
plsh2me

plsh2me

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male
  • Location:Bangladesh

I think you have done something wrong, at least it might show on display info. 

Ok, Now try my one and let me know. 

Unzip, Paste it on System/Library/Displays/Overrides folder & repair permission with kext utility or others, then restart.

 

Good Luck

 

Palash

 

 

Attached Files



#8
Extended

Extended

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
  • Location:Germany

I've edited it like you did it

but it doesn't work :/

 

lNe6d.png

 

Now the Display is listed. But the error with the colored stripes didnt solved



#9
plsh2me

plsh2me

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male
  • Location:Bangladesh

Try using graphics flag GraphicsEnabler=No or delete GraphicsEnabler flag from boot.plist.

 

 

More than this if you have interest can use my kexts from - http://www.insanelym...v46501002-9480/

Update up to 10.7.5 (11G63) and install my kexts. Before update remember to delete ATY_Init.kext & voodooHDA.kext if you are using, I mean kexts which can cause KP must delete.

 

Thanks



#10
Extended

Extended

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
  • Location:Germany

I'm on 10.8.2 now and use your Kexts (ATI Mobility Radeon HD 550v 10.8.2(12C60) Peregrine.zip)

Same problem



#11
plsh2me

plsh2me

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male
  • Location:Bangladesh

So sad :(

If all are same, would like to play with latest version :P . Update up to 10.8.4, install kexts from - http://www.insanelym...os-x-108412e55/ . Boot with -v GraphicsEnabler=No. Let me know ....

 

Go to windows make a vga bios dump using AIDA64 soft. or others. Send.



#12
Extended

Extended

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
  • Location:Germany

Will try to update and install the Kexts

Idk how to make a vga bios dump :D



#13
plsh2me

plsh2me

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male
  • Location:Bangladesh

Download AIDA64 extreme version  - http://www.aida64.com/downloads

Install, Run the program, right click on bottom of the windows of this app. , do as pic & click on video bios dump

Attached File  Snap2.jpg   190.98KB   1 downloads

 

Save the file, done :D .



#14
Extended

Extended

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
  • Location:Germany

Updated to 10.8.4. Booted with flags. Same issue..

 

I attached the dump

Attached Files



#15
plsh2me

plsh2me

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male
  • Location:Bangladesh

Try these kexts  

Attached Files



#16
Extended

Extended

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
  • Location:Germany

Now i get this

 

IuESe.png



#17
plsh2me

plsh2me

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male
  • Location:Bangladesh

Seems ok, but you have to put the display EDID file to overrides folder & repair permission.

Boot with GraphicsEnabler=No important. Send me pic of display.

Good luck.

Palash



#18
Extended

Extended

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
  • Location:Germany

Did it

Looks the same



#19
plsh2me

plsh2me

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male
  • Location:Bangladesh

It is not possible, First it had show the display as "Toshiba Internal Display". So you might do something wrong, manually paste it again & repair permission. Feedback again.

Send me also your org.chameleon.boot.plist file.

 

Edit: ATI4600Controller.kext not loaded, delete the kexts & install them again. Boot with -v -f GraphicsEnabler=No.



#20
Extended

Extended

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
  • Gender:Male
  • Location:Germany

My Extensions folder

 

1Fbfe.png

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy