Jump to content

[FIXED by DSDT edit!] +10C temps, +500rpm fans


Best Answer nyolc8, 13 June 2013 - 04:48 PM

I just fixed it! :D I investigated the LPCB device with IORegistryExplorer and found out that 10.9 somehow reads the device differently from the same DSDT file. So I basically modified my DSDT (added name,ioname,compatibility injection) and got normal temps without any kext editing! :D

Go to the full post


  • Please log in to reply
45 replies to this topic

#41
calmesal

calmesal

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 167 posts

Try to add manually vendor-id and device-id to AppleLPC.kext's Info.plist

Yes I tried this before posting, that worked in ML10.8.5. But doesn't in Maverick. I solved the problem by AppleLPC.kext revert from 10.8.5. Now the kext is loading and the temp is down. But still think is high in idle about 50-55C. I try to find out what or where the the problem is. 

 

Thanks again.



#42
hugeschnauzer

hugeschnauzer

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts

Please Help Insanelymac

 

I've edded all the code recommended without sucess..

 

http://cl.ly/image/2Q3o053k3a45



#43
Benevides Lecontes

Benevides Lecontes

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male

Hi all! I'm trying to patch my DSDT with this method, but no sucess! Somebody help me. I will attach my modified DSDT with no sucess. Attached File  DSDT.zip   14.74KB   4 downloads



#44
djouija

djouija

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts
  • Gender:Male

Been messing with one of my systems today trying to get AppleLPC.kext to load in Mavericks (DELL M6400) , and couldn't get it load using any of these patches with my systems LPC device ID (2917,8086) but eventually found that by patching my dsdt using an ID that actually exists in the IONameMatch of the 10.9 AppleLPC.kext itself, then it would load (Currently I am using 2916, 8086). 
 
However, I don't like the fact that it didn't actually point to the correct ID of the LPC device in my system, so I am not a fan of this method.
 
UPDATE:  I've made use of an injector kext which now properly loads the new AppleLPC.kext using my correct device ID, and (after applying EHCI and USB fixes to my DSDT) have verified that sleep is working perfectly! :)
 

Here is the patch that I used in my DSDT with the correct device ID for my LPC device (note that in my system, the LPCB device is actually named ISAB - the default naming for the LPC device in Dell/Intel boards?):

into method label _DSM parent_adr 0x001F0000 remove_entry;
into device name_adr 0x001F0000 insert
begin
Method (_DSM, 4, NotSerialized)\n
{\n
    Store (Package (0x04)\n
        {\n
            "device-id",\n
            Buffer (0x04)\n
            {\n
                 0x17, 0x29, 0x86, 0x80\n
            },\n
            "name",\n
            "pci8086,2917"\n
        }, Local0)\n
    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))\n
    Return (Local0)\n
}
end

Attached is the injector kext that I used, and contains the following device IDs for identifying LPC (you may also add your own device ID to the info.plist within this kext): 
 

                                <string>pci8086,25a1</string>
				<string>pci8086,2640</string>
				<string>pci8086,2641</string>
				<string>pci8086,2642</string>
				<string>pci8086,27b0</string>
				<string>pci8086,27b8</string>
				<string>pci8086,27bc</string>
				<string>pci8086,27bd</string>
				<string>pci8086,2810</string>
				<string>pci8086,2812</string>
				<string>pci8086,2814</string>
				<string>pci8086,2910</string>
				<string>pci8086,2911</string>
				<string>pci8086,2912</string>
				<string>pci8086,2914</string>
				<string>pci8086,2917</string>
				<string>pci8086,2918</string>
				<string>pci8086,2919</string>
				<string>pci8086,3a10</string>
				<string>pci8086,3a14</string>
				<string>pci8086,3a16</string>
				<string>pci8086,3a1a</string>
				<string>pci8086,3a1e</string>
				<string>pci8086,3b04</string>
				<string>pci8086,3b06</string>
				<string>pci8086,3b08</string>
				<string>pci8086,3b0d</string>

 
Enjoy!

Attached Files



#45
vrishcons

vrishcons

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male

Nice work. I installed AppleLPCInjector kext. i checked in system profile, this kext is not loaded. how to get this kext to load.



#46
Onixs

Onixs

    Since 2007

  • Members
  • PipPipPipPipPipPipPip
  • 808 posts
  • Gender:Male

Nice work. I installed AppleLPCInjector kext. i checked in system profile, this kext is not loaded. how to get this kext to load.

if you are too lazy to edit your dsdt, here is the old but reliable way to inject LPC ( No DSDT edit needed). This was downloaded long time ago from projectosx. the main difference with this legacy compared to what djouija uploaded above is it uses IOPCIClassMatch instead of IONameMatch. 

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy