Jump to content

[Success] Gigabyte Z87-D3HP -- first Haswell hackintosh?


  • Please log in to reply
339 replies to this topic

#201
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,949 posts
  • Gender:Male

Wishlist:

 

AppleHDA

Sleep

HDMI Audio

 

Post a DSDT and IOreg with VoodooHDA removed and I will look into HDMI audio. 



#202
ameris_cyning

ameris_cyning

    I don't know what to write here

  • Donators
  • 956 posts
  • Gender:Male
  • Location:My apartment
  • Interests:OSx86, female anatomy, electronic music, Clover EFI

Danke mein Führer.

If you see a sound interface as active it is an Airplay connection and can be ignored.
 

 

Post a DSDT and IOreg with VoodooHDA removed and I will look into HDMI audio. 

 

 

Attached File  w00t.zip   493.08KB   39 downloads



#203
necrophagous

necrophagous

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Male
  • Location:3rd World Country

Attached File  applehda.zip   855.56KB   51 downloads

for those who don't already know 

there now exist an AppleHDA kext for our D3HP ( patched by this following user : Pinarek ) 

(all ports detected but there's no sound)



#204
ameris_cyning

ameris_cyning

    I don't know what to write here

  • Donators
  • 956 posts
  • Gender:Male
  • Location:My apartment
  • Interests:OSx86, female anatomy, electronic music, Clover EFI

attachicon.gifapplehda.zip

for those who don't already know 

there now exist an AppleHDA kext for our D3HP ( patched by this following user : Pinarek ) 

Not working, damn



#205
bcc9

bcc9

    InsanelyMac Legend

  • Coders
  • 1,277 posts
  • Gender:Male
My z87mx-d3h motherboard has alc892 as well. I have AppleHDA basically working for this system using the instructions I posted here:
http://www.insanelym...k/#entry1935102

#206
necrophagous

necrophagous

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Male
  • Location:3rd World Country

Not working, damn

my my , all ports detected but there's no sound 

sorry my mistake dude

 

 

My z87mx-d3h motherboard has alc892 as well. I have AppleHDA basically working for this system using the instructions I posted here:
http://www.insanelym...k/#entry1935102

i'll try this 



#207
ameris_cyning

ameris_cyning

    I don't know what to write here

  • Donators
  • 956 posts
  • Gender:Male
  • Location:My apartment
  • Interests:OSx86, female anatomy, electronic music, Clover EFI

My z87mx-d3h motherboard has alc892 as well. I have AppleHDA basically working for this system using the instructions I posted here:
http://www.insanelym...k/#entry1935102

 

Could ya share your AppleHDA, please?

 

Thank you



#208
Shasoosh

Shasoosh

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

strange bug in DP3 

sometimes my front USB3 port does not work at all ( let's say like 30 percent of the time) 

and ffs i can't wait for the new line of products from apple as i'm getting fed up by the number of turbo P-States i got like before sleep the 38 and 39 multiplier would not show up while after waking from deep sleep it would , the latest beta UEFI BIOS from gigabyte didn't help either 

Are you experiencing something similar to this? http://www.insanelym...d-then-into-ml/



#209
necrophagous

necrophagous

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Male
  • Location:3rd World Country

Are you experiencing something similar to this? http://www.insanelym...d-then-into-ml/

that's not it , one of my usb3 front header pin is bent to the point where it almost broken. It seems this motherboard i got is really crappy ( the cmos battery is dead too)

that's it i'm fed up , going to Gigabyte dealer tomorrow i'm thinking of getting a replacement ( or i might take a new z87x-ud3h / z87x-oc) 



#210
Pike R. Alpha

Pike R. Alpha

    InsanelyMac Geek

  • Developers
  • 159 posts
  • Gender:Male

@q64ceo,

 

What PinConfigurations data do you see in IORegistryExplorer? I have this:

40 d5 37 40 10 40 11 01 20 10 01 01 30 60 01 01 40 90 a1 90 50 90 81 02 60 30 81 01 70 40 21 02 f0 11 11 41 01 e6 45 40 90 61 4b 01

This is what I have in AppleHDAHardwareConfigDriver.kext

<dict>
<key>CodecID</key>
<integer>283904146</integer>
<key>ConfigData</key>
<data>
                                        IUccECFHHUAhRx4RIUcfASFXHCAhVx0QIVce
                                        ASFXHwEhZxwwIWcdYCFnHgEhZx8BIXcc8CF3
                                        HQAhdx4AIXcfQCGHHEAhhx2QIYceoSGHH5Ah
                                        lxxQIZcdkCGXHoEhlx8CIaccYCGnHTAhpx6B
                                        IacfASG3HHAhtx1AIbceISG3HwIh5xyQIecd
                                        YSHnHksh5x8BIfcc8CH3HQAh9x4AIfcfQCEX
                                        HPAhFx0AIRceACEXH0A=
                                        </data>
<key>FuncGroup</key>
<integer>1</integer>
<key>LayoutID</key>
<integer>892</integer>
</dict>

What I also do is that I set PinConfigurations to 00 in my (EFI) device-properties. Oh and I am using AppleHDA.kext v2.5.2.a.30 from DP4. I still have to figure out why property DigitalAudioCapabilities (DisplayPort/HDMI) isn't showing up, and that is most likely why I see some audio related errors with sudo dmesg

 

p.s. Make sure that the right version of AppleHDA.kext is loaded. I ran into this myself some time ago. Took some time before I figured out why audio was working.



#211
ameris_cyning

ameris_cyning

    I don't know what to write here

  • Donators
  • 956 posts
  • Gender:Male
  • Location:My apartment
  • Interests:OSx86, female anatomy, electronic music, Clover EFI

@q64ceo,

 

What PinConfigurations data do you see in IORegistryExplorer? I have this:

40 d5 37 40 10 40 11 01 20 10 01 01 30 60 01 01 40 90 a1 90 50 90 81 02 60 30 81 01 70 40 21 02 f0 11 11 41 01 e6 45 40 90 61 4b 01

This is what I have in AppleHDAHardwareConfigDriver.kext

<dict>
<key>CodecID</key>
<integer>283904146</integer>
<key>ConfigData</key>
<data>
                                        IUccECFHHUAhRx4RIUcfASFXHCAhVx0QIVce
                                        ASFXHwEhZxwwIWcdYCFnHgEhZx8BIXcc8CF3
                                        HQAhdx4AIXcfQCGHHEAhhx2QIYceoSGHH5Ah
                                        lxxQIZcdkCGXHoEhlx8CIaccYCGnHTAhpx6B
                                        IacfASG3HHAhtx1AIbceISG3HwIh5xyQIecd
                                        YSHnHksh5x8BIfcc8CH3HQAh9x4AIfcfQCEX
                                        HPAhFx0AIRceACEXH0A=
                                        </data>
<key>FuncGroup</key>
<integer>1</integer>
<key>LayoutID</key>
<integer>892</integer>
</dict>

What I also do is that I set PinConfigurations to 00 in my (EFI) device-properties. Oh and I am using AppleHDA.kext v2.5.2.a.30 from DP4. I still have to figure out why property DigitalAudioCapabilities (DisplayPort/HDMI) isn't showing up, and that is most likely why I see some audio related errors with sudo dmesg

 

p.s. Make sure that the right version of AppleHDA.kext is loaded. I ran into this myself some time ago. Took some time before I figured out why audio was working.

 

PinConfigurations isn't in my IORegistryExplorer



#212
necrophagous

necrophagous

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Male
  • Location:3rd World Country

anyone got the vanilla applehda from dp4?



#213
René_

René_

    InsanelyMac Protégé

  • Donators
  • 73 posts
  • Gender:Male
  • Location:Maassluis, Netherlands

Working ALC892 on GA-Z87M-D3H for Mavericks. AppleHDA 2.5.2a30, same as Pike R. Alpha
http://cl.ly/Qafx
 
Got it from this site but totally forget which post, sorry no credits my bad :(
 
I was searching so long for a working solution and now have a ton of AppleHDAs which doesn't work.
If I find the link I will give the credits.

Spoiler

[Edit]
Found the link :)
Credits and thanks to oolll
http://www.insanelym...-2#entry1928147
 
Now I only need speedstep.
At the moment only: 
AICPUPMI: CPU P-States [ 8 35 (36) 37 38 39 ]



#214
ameris_cyning

ameris_cyning

    I don't know what to write here

  • Donators
  • 956 posts
  • Gender:Male
  • Location:My apartment
  • Interests:OSx86, female anatomy, electronic music, Clover EFI

Working ALC892 on GA-Z87M-D3H for Mavericks. AppleHDA 2.5.2a30, same as Pike R. Alpha
http://cl.ly/Qafx
 
Got it from this site but totally forget which post, sorry no credits my bad :(
 
I was searching so long for a working solution and now have a ton of AppleHDAs which doesn't work.
If I find the link I will give the credits.

Spoiler

[Edit]
Find the link :)
Credits and thanks to oolll
http://www.insanelym...-2#entry1928147
 
Now I only need speedstep.
At the moment only: 
AICPUPMI: CPU P-States [ 8 35 (36) 37 38 39 ]

I love you



#215
Shasoosh

Shasoosh

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts

Working ALC892 on GA-Z87M-D3H for Mavericks. AppleHDA 2.5.2a30, same as Pike R. Alpha
http://cl.ly/Qafx
 
Got it from this site but totally forget which post, sorry no credits my bad :(
 
I was searching so long for a working solution and now have a ton of AppleHDAs which doesn't work.
If I find the link I will give the credits.

Spoiler

[Edit]
Find the link :)
Credits and thanks to oolll
http://www.insanelym...-2#entry1928147
 
Now I only need speedstep.
At the moment only: 
AICPUPMI: CPU P-States [ 8 35 (36) 37 38 39 ]

Not working on ML 10.8.4 + H87-D3H :(



#216
ameris_cyning

ameris_cyning

    I don't know what to write here

  • Donators
  • 956 posts
  • Gender:Male
  • Location:My apartment
  • Interests:OSx86, female anatomy, electronic music, Clover EFI

Not working on ML 10.8.4 + H87-D3H :(

 

The AppleHDA.kext is from Mavericks, so it won't work



#217
dolphans1

dolphans1

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts

Not working on ML 10.8.4 + H87-D3H :(

 

I love you

Can someone explain what improvement that HDAkext brings versus what we had before? I just got back from a long vacation so I have not been following?

 

What's the latest DP update release?

 

Thanks....

 

d-1



#218
eranj

eranj

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
  • Gender:Male
  • Location:Israel

I have this problem even in the installation. therefore I can't install. 4770k and Gigabyte GA-H87-D3H.

I hope you can help!

Bus ratio problem here on a Gigabyte Z87X-UD3H. So close to having this working...

 

Any thoughts on the bus ratio / fast timer tick problem?

 



#219
c0ercion

c0ercion

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts

Working ALC892 on GA-Z87M-D3H for Mavericks. AppleHDA 2.5.2a30, same as Pike R. Alpha
http://cl.ly/Qafx
 
Got it from this site but totally forget which post, sorry no credits my bad :(
 
I was searching so long for a working solution and now have a ton of AppleHDAs which doesn't work.
If I find the link I will give the credits.

Spoiler

[Edit]
Find the link :)
Credits and thanks to oolll
http://www.insanelym...-2#entry1928147
 
Now I only need speedstep.
At the moment only: 
AICPUPMI: CPU P-States [ 8 35 (36) 37 38 39 ]

Thanks for this. 

Btw, I have been struggling with speedstep for a while now as well. I have the MX version of that board and I get the same exact pstates with my 4770k.

My registry dump shows that the OS is recognizing the states I generated with Pike's ssdt script (I can dig up the link if anyone needs it) but is apparently not using them. I've tried using a patched AppleIntelCPUPowerManagement kext, and it removes some errors at boot time, but doesn't fix the states.

 

The PMPatch utility doesn't work on my BIOS... but I've loaded it up in a disassembler and found the location where I believe it is locking MSR 0xE2 (the reason unpatched AICPM.kext causes a panic). Hopefully I will have successful patch within the next few days (limited hacking time with work/gf/etc) and will report back with my results.



#220
René_

René_

    InsanelyMac Protégé

  • Donators
  • 73 posts
  • Gender:Male
  • Location:Maassluis, Netherlands

Not working on ML 10.8.4 + H87-D3H :(

Try this one it's for 10.8.5, ALC892: http://www.osx86.net...do=file&id=4098

Working for me with 10.8.5 on my GA Z87M-D3H with ALC892.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy