Jump to content

vimicro webcam drivers


  • Please log in to reply
28 replies to this topic

#1
PolishOX

PolishOX

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts
I bought this webcam from ebay to use with my laptop's xp/vista installations:

http://cgi.ebay.com/...I...N:IT&ih=014

Windows Drivers install the camera as a Popodino USB PC Camera (ZC0301PL).

OSX sees the device when plugged into the usb port as: vimicro PC Camera.

On the vimicro site are drivers:

http://www.vimicro.c...download_n.htm#

http://rapidshare.de..._MI360.rar.html

USB1.1 Digital Webcam driver 08/27/2004 653K (667,798 bytes) MAC Support Vimicro 300K pixel Video camera models: * 301P+HV7131R, * 301P+MI360 Video


When you download the package into OSX there is no installation apparently.
The files are listed as follows:

- ZCamISPLib (some plugin for quicktime)
- ZCamIMGLib (some plugin for quicktime)
- ZCam Driver
- ZCam Digitizer
- ZCam Panel
- Instructions.txt
- Read Me

None of the files that seem important have .kext extensions yet the instructions say to copy the files to:

/System/Library/Extensions

Then reboot. I tried it and that failed. I also tried to add the .kext extension and that failed! :)

I'm looking for any ideas as according to these directions the drivers should work MAC 9.2 and higher.
I know it's a long shot but I'd love to find a way to make this work.

Any help or ideas would be appreciated! :D

#2
Rammjet

Rammjet

    InsanelyMac V.I.P.

  • Gurus
  • 5,302 posts
  • Gender:Male
The date on the website for the drivers is 08/27/2004 which means they are at least a year before an Intel Mac was produced.

The file "301PL-R&MI360\note.txt" says: "2.only used in Mac 9.x"

The file "301PL-R&MI360\readme" says:
"0302 driver for Mac OS 9.X" and
"copy these files to your "System Folder"->"Extensions"".

So, let's recap:
can't be compatible with Intel OSX because it is too old.
Says it is for 9.X
Says copy files to "System Folder"->"Extension" (the OS9 config) not /System/Library/Extensions (the OSX config)which is consistent with a pre-OSX configuration

#3
PolishOX

PolishOX

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts
I wasn't sure if there was a way to convert these old drivers into the current configuration...

I have emailed the company requesting updated drivers for OSX.

:)

Thanks Rammjet.

#4
PolishOX

PolishOX

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts
Update...

vimicro has emailed me back...

they have agreed to make drivers for 0301PL chipsets for OSX!

the driver set will be available to me on Oct. 16th...

they are currently on vacation and we so glad I contacted them...

More updates later...

#5
PolishOX

PolishOX

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts
Vimicro's head programmer has sent me the drivers that support a vast majority of all cameras on the market using their chip/sensors.

They are NOT currently working for my machine but we are troubleshooting when time permits (as they are located in China).

The drivers can be found here:
http://rapidshare.de...8_V101.zip.html

More details as I continue to request usb drivers for unsupported devices directly from manufacturers. Sometimes all you gotta do is ask! :thumbsdown_anim:

#6
PaRRoT

PaRRoT

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Thank you for your work.
This driver works for my Vimicro USB webcam but... it's all "black".

I need to use a lamp pointed to my face for viewing my image in the screen... i tried to use HackTVCarbon (software included) but is always dark... :(

Sorry for my english.

#7
PolishOX

PolishOX

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts
@Parrot

Can you tell where you bought your cam and what make/model it is?

I'm highly interested as I bought mine on ebay and the seller said he bought them directly from ViMicro...

I'm hoping soon to find someone who speaks chinese and english fluently to help me resolve this issue.

#8
PaRRoT

PaRRoT

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
This is my cam:
http://195.110.141.2...l...amp;l=1&p=1

Cam works... but... if I try to use with Skype (and a usb phone) i've a kernel panic :D

This driver doesn't work fine...

#9
PolishOX

PolishOX

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts
I have been working with vimicro to improve their drivers with INTEL MACs and hopefully gain functionality under HACINTOSH...

HXR the admin of MACAM project is also now working with them.

Our biggest problem is most people don't have a real mac to test with or a vimicro camera...

Until recently that is...a friend of mine has a hacintosh and 3-4 real macs running various version of OSX. He just purchased the identical camera to mine and when it arrives we will begin testing soon.

With the help of HXR @ MACAM and ViMicro we will soon have working OSX drivers for all vimicro cameras.

I need more feedback from guys like you Parrot to help out with this effort.
Thanks so much for your feedback I will pass on these results to Hxr and Vimicro!

#10
aberracus

aberracus

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 950 posts
this is what my usb camera says i really dont know brand or anything, anyopne can help?


Vendor-Specific:

Version: 0.01
Bus Power (mA): 500
Speed: Up to 12 Mb/sec
Product ID: 0x010f
Vendor ID: 0x0923

#11
PolishOX

PolishOX

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts
@Aberracus

Have you tried the latest CVS build of Macam?

I see you haven't a VENDOR name...

Very odd...chances are I can do some research and attempt to ID your camera.

It would greatly help me if you could post an image of ur cam if possible... :)

Btw nice to finally cross paths with you...

@Aberracus

Check it out son:

http://webcam-osx.so...mera.php?id=296

Which of these is your cam?

http://www.conceptro...f...20&grp=2020

http://tienda.future...CMOBICAM-la.jpg
http://download.tuli...CMobiCam_ML.pdf

I have found the manual to your cam and sent the links and info to HXR of macam. Any information I receive I will post here.

With me helping HXR I am sure more cams will have support for OSX in the very near future.

In my other internet life I am what we commonly refer to as a: "SCANNER"

See yas soon with more updates! :D

#12
OSX86tester

OSX86tester

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
i bought the wanna be isight as well as own the real isight. the wannabe isight made by vimicro works like a charm on the pc. nuked osx so im not sure if ill be testing it on osx. I do know isightr on dell laptops donot work!. Due to stupid firewire needing 12volts, so dont bother wasting your time on that. as far as vimicro goes. I thought the webcam sourceforge was legit enough?

#13
PolishOX

PolishOX

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts
@aberracus

Here is the answer from hxr @ macam:

That camera should work fine with macam, probably even 0.8.8.
Thanks for the update,

Harald
<http://sourceforge.net/users/hxr>



#14
PaRRoT

PaRRoT

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts

Our biggest problem is most people don't have a real mac to test with or a vimicro camera...


I've a Mac mini Intel and a vimicro camera...

#15
PolishOX

PolishOX

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts
What version of OSX are you running and what model vimicro camera do you own?

Is the camera currently working and where did you obtain drivers?

Would you be willing to test new drivers or not?

#16
Miss Arebee

Miss Arebee

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
  • Gender:Female
  • Location:Paris, France
  • Interests:Far too many.
Hello to everyone..

I've been offered a webcam: vimicro, recognised by my ibook G4, Tiger 10.4.8 as this:
Posted Image

There's a minidisk with drivers for windows in the box, but hrmm.. Being a mac user those are really unuseful..

I've tried Macam, IOExpert... And many other drivers for mac... The ones on the vimicro website for mac are simply not available anymore..

Does anyone have an idea on which driver I could use for the webcam to "become" compatible?


Thank you by advance..


Raphale

#17
zu1u

zu1u

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts
I also tryied macam with no success it just tells me there's no webcam connected
i have a Genius VideoCam Look

In the System Profiler i have the following:

USB camera:

Version: 1.01
Bus Power (mA): 500
Speed: Up to 12 Mb/sec
Product ID: 0x60b0
Vendor ID: 0x0c45

can anyone help?

#18
paco.iigo

paco.iigo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
hi,
i am having the same problem as you are, I have searched tons of webpages concerning this. But it seems that luck is not on my side. Have you found a solution to this problem? I, too, have bought a vimicro web camera with exactly the same specifications as you do. If you found a driver pls tell me so. thanks very much.

Paco

Hello to everyone..

I've been offered a webcam: vimicro, recognised by my ibook G4, Tiger 10.4.8 as this:
Posted Image

There's a minidisk with drivers for windows in the box, but hrmm.. Being a mac user those are really unuseful..

I've tried Macam, IOExpert... And many other drivers for mac... The ones on the vimicro website for mac are simply not available anymore..

Does anyone have an idea on which driver I could use for the webcam to "become" compatible?
Thank you by advance..
Raphale



#19
PolishOX

PolishOX

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 240 posts
I know the developers of Vimicro directly from China...

They can and will make a new driver however, we need to help them with feedback.

Keep in mind though that we are dealing with HACINTOSHES so some drivers may be working on real MACS but not on our HACS.

So, let me contact those guys and tell them we need drivers for 10.4.4-10.4.8 for PPC and INTEL based MACS.

In the meantime, please test your cam with MACAM and post results here...

I also know Harold who writes MACAM! :tomato:

#20
rhcpnick

rhcpnick

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hey everyone, Yeah i'm having the same issues with my vimicro cam. Macam certainly recognizes it, but its a no-go in terms of producing any image :) I have an iBook and it just appears black on macam v9.0





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy