Jump to content

Osx i7 920 asus p6t

- - - - -

  • Please log in to reply
18 replies to this topic

#1
soniclmusic

soniclmusic

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
  • Interests:music production
Hello to everyone.

This is a guide for you to install leopard 10.5.5 on asus p6t and i7 920 full working - Full working cores!!

Very simple because i was searching a lot and you deserve smt simple..like apple :dev:

What you need:

1) Leopard 10.5.5 Kalyway
2) DSDT_Patcher1.0.1e 2
3) DSDTPatcherGUI_1

thats all..

Hardware now:

1) Asus P6T
2) i7 920 intel
3) 8600 GT
4) As plenty RAM you want..
5) DVD sata conection

<<<<METHOD>>>>>

1) Update your bios motherboard from windows
2) Go to bios and disable Hyperthreading & enable 1 core
3) Set to ACHI your hdd controller

Recommended: Put your sata dvd to sata 1 and your hdd to sata 2

----------------------------------------

1) Boot your pc from cdrom and just enter the installation.
2) On the apple menu customize check(kernel menu) the first kernel which is for amd/intel
3) On graphicks go nvidia and select the first box (nv go ject.smt like this)
4) Chech also all the application..are usefull.

<<<<<<<<<Install>>>>>>>>>>>


After install it restarts..When you are in the promt menu just hit enter..so simple
You will be waiting for about 7-10 minutes but dont worry..it will come to the welcome video.
Set up your information and you have a clean osx86 leopard install.

-------------------------------------------

DSDT install for enable 8 Cores & HT ..Oh yes..so simple

1) Create a folder and name it: DSDT_Patcher1
2) Take "DSDT_Patcher1.0.1e.zip" and extract the contents to your OSX desktop in folder named "DSDT_Patcher1(there are 3 files)
3) Open up the DSDT patcher GUI folder and go to the tools folder. Run the bootloader installer pkg.
4) Run the DSDT patcher file and when asked enter "0" to emulate Darwin OS.

5) Open the terminal and type:

cd Desktop/DSDT_Patcher1 -enter and then type

nano Debug/dsdt.dsl -enter

6) In nano modify the patched dsdt to delete all lines that start with Alias(just delete these lines with your keyboard)

7) Press Ctrl+O (that's the letter "o") and [ENTER] to save the file, then press Ctrl+X to close nano.

8) (right click on the terminal >(new basic)In terminal again type:

./DSDT\ Patcher Debug/dsdt.dsl

9) Run the patcher again, you will get 3 errors about files not existing or already existing, that's fine, don't worry about it

10) In terminal again type:

cp dsdt.aml /DSDT.aml

Close terminal.

You will see the file DSDT.aml in your hdd this file.(go finder and click on your hdd on your top left of finder). so simple


--------------------------------------------

<<<<<<<Apple boot list configuration>>>>>>


1) go to applications - idenebapp folder and run the efistudio
2) Hit the boot.plist Editor
3) Copy these :<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>busratio=20</string>
<key>Timeout</key>
<string>1</string>
<key>device-properties</key>
<string></string>
</dict>
</plist>

4) Save changes(down right)
5) Quit everything.

----------------------------------------------

Restart your pc go to the bios and enable all cores and Hyperthreading.You can also have an overclock.

I have a boot in just 11 seconds also.Very very fast boot.My cs4 suite is working excellent and my pro tools 8 .

#2
defjae

defjae

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
I have the same Mobo and CPU, where did you get the Kalyway 10.5.5 I can't seem to find it anywhere....

#3
soniclmusic

soniclmusic

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
  • Interests:music production

I have the same Mobo and CPU, where did you get the Kalyway 10.5.5 I can't seem to find it anywhere....

its iDeneb v 1.03 10.5.5 iso..

#4
defjae

defjae

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
I downloaded iDeneb v1.4 10.5.6, it works for our board, only issue im stuck with is the slow SATA access. Also the Kernel Panic shutting down and restarting. I will give the one you suggested a try and see if that gives better result.

#5
soniclmusic

soniclmusic

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
  • Interests:music production

I downloaded iDeneb v1.4 10.5.6, it works for our board, only issue im stuck with is the slow SATA access. Also the Kernel Panic shutting down and restarting. I will give the one you suggested a try and see if that gives better result.

The guide is only for iDeneb 10.5.5. and gives top results. Check the geekbench and you will understand...http://browse.geekbe...ch2/view/129119

#6
defjae

defjae

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts

I downloaded iDeneb v1.4 10.5.6, it works for our board, only issue im stuck with is the slow SATA access. Also the Kernel Panic shutting down and restarting. I will give the one you suggested a try and see if that gives better result.

The guide is only for iDeneb 10.5.5. and gives top results. Check the geekbench and you will understand...http://browse.geekbe...ch2/view/129119

Sweet iDeneb 1.3 did the job. I'm not having the issue with slow SATA access. Now my Audio is not working and all my Hard Drives icons are Orange not the regular Metalic looking ones. Did you have to manually fix that? or did I miss to select few kext from the Install? Also I was curious if you tried updating to 10.5.6? Any sort of input on how to fix the issue mentioned is greatly appreciated.

#7
soniclmusic

soniclmusic

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
  • Interests:music production

I downloaded iDeneb v1.4 10.5.6, it works for our board, only issue im stuck with is the slow SATA access. Also the Kernel Panic shutting down and restarting. I will give the one you suggested a try and see if that gives better result.

The guide is only for iDeneb 10.5.5. and gives top results. Check the geekbench and you will understand...http://browse.geekbe...ch2/view/129119

Sweet iDeneb 1.3 did the job. I'm not having the issue with slow SATA access. Now my Audio is not working and all my Hard Drives icons are Orange not the regular Metalic looking ones. Did you have to manually fix that? or did I miss to select few kext from the Install? Also I was curious if you tried updating to 10.5.6? Any sort of input on how to fix the issue mentioned is greatly appreciated.

Try looking for the sata a kext for ""ich10"".About the audio i dont know.Just search.For the update i dont get to trouble cause its a mystirious operation..and smt it gets panic..so i let it ...wait to release ""snow"" so to experiment with that...It will be far ahead the software for our hackintosh so dont get in bother..Just love your new hack and wait a litle bit to enjoy ""Snow"" with full cores memory fsb and overclocking..Im waiting for a mac case to put the hardware inside...beautiful..

#8
D. Starr

D. Starr

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Canada
Great work thanks for this walkthrough! I am running 10.5.7 vanilla (combo updated from iPC 10.5.6 voodoo) on an ASUS Rampage II Gene and found your guide the most accurate and useful. I haven't been able to find any other users running OSX86 on this board so maybe I am the first!!?
  • I still have no sound. Had to disable/remove AppleHDA.kext to avoid panics. I tried AD8888.pkg during iPC setup but no luck.
  • I get AppleIntelCPUPowermanagement panics when booting with 2-4 cores or Hyperthreading enabled still...
I have yet to try your DSDT method trick. Can you please elaborate? I'm a just a bit wary, it took a few days to get this running but hooray it's my first hackintosh!

#9
kristalaz

kristalaz

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Does anyone tried to use raid0?

#10
gstream242

gstream242

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
will it work on msi platinum x58?

#11
Felix_ro

Felix_ro

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
Hi there, soniclmusicI just wondering if after this install did you successfully installed Apple's updates, and if yes what ELSE you did for that to work properly!Thanks!

#12
US la

US la

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Location:Los Angeles
:angel: Dude... this is what I needed. It looks clear enough for me to follow being a first timer.Thanks!

#13
wentakura

wentakura

    InsanelyMac Protégé

  • Members
  • Pip
  • 28 posts
Am I missing something here? I tried the patch to get the 8 cores working without succes.

#14
deggertsen

deggertsen

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Utah
I've followed all the instructions exactly as stated above and everything went well until I enabled hyperthreading and all cores. Then it gets stuck at the OSX loading screen (I waiting for at least 3 hours one time). I can switch off of hyperthreading and change back to a single core and it works but obviously that is not the desired result. Any ideas? I haven't been able to get the sound working yet either, maybe you have some ideas there? Hardware: Intel Core i7 920 Nehalem 2.66GHz LGA 1366 ASUS P6T SE LGA 1366 Intel X58 ATX Intel EVGA 256-P2-N753-TR GeForce 8600 GT 256MB 128-bit GDDR3

#15
makosx

makosx

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
  • Gender:Male
  • Location:EU
Mi equipo: ASUS P6T WSIntel Core i7 920Nvidia Quadro FX 3700 512 x2AD SoundMax 2000BRealtek (No se que modelo)Snow Version: Retail 10432Lo conseguí probando con todo tipo de guías. Y lo logré de esta forma. Me funciona todo (audio, red, graficos etc) Para la tarjeta grafica, lo mejor es buscar la tuya en Aquamac y seguir sus instrucciones para incluir el string correcto de tu tarjeta en apple.Boot.plist. Mi experiencia es que el sistema, con cualquier guia se instala bastante bien y no necesita tantos arreglos como parece. El problema de los KP de arranque es cosa de Chameleon 2. Lo primero, desde Leoopard 10.5 se instalan los kexts necesarios para cada hardware (y los que habitualmente se exponen en las guias) en System/Library/Extensions ya que no existe aun /Extra, así como una copia del DSDT.aml que tienes en Leopard 10.5 Hay gente que dice que no es necesario (el DSDT.aml), pero para mi si lo fue y si no lo tienes en el L 10.5, es necesario crearlo (google). Para el primer arranque, desde Leopard 10.5 es necesario instalar en SL el bootloader2.dmg (google). Aunque instala /Extra, realmente esa carpeta no será necesaria luego y la podremos borrar. Los ajustes del apple.boot.plist de /Library/Preferences/SystemConfiguration tambien conviene hacerlos antes de arrancar snow, desde Leopard. Ahí es recomendable incluir unos segundos (5 o 6) en el key Flag para que de tiempo a escribir en darwin en el arranque. Para que no de KP, el disco de arranque 1º en la bios debe ser el de SL y no el de Leopard. Se arranca con -x64 -v en darwin. No KP. Una vez dentro de snow, rapidamente (lo mas rapido que uno pueda) hay que abrir Preferencias de Spotlight y añadir todos los discos conectados al ordenador para que NO los indexe. A veces no da tiempo mas que a añadir uno o dos (si se tienen más) y se cuelga con la pantalla gris y te obliga a reiniciar con el botón del PC. No pasa nada. Se reinicia de nuevo con -x64 -v y otra vez rapidito, a terminar de desindexar los discos que no nos dio tiempo antes. Una vez desindexados todos de Spootlight, ya no se cuelga y podemos terminar la instalación tranquilos. Lo primero que hay que hacer ahora es correr la aplicación Kext Utility 2.3.2 (google) Dejarla hasta que acabe todo el proceso de ordenar y reparar la carpeta Extensions y el Extensions.mkext lo que viene siendo unos dos o tres minutos. Una vez hecho esto, hay que reinstalar el paquete BSD.pkg de la imagen de instalacion de SL para que nos deje reparar permisos desde Utilidad de Discos. Desde el disco de Leopard 10.5 copias el dmg del retail de SL al escritorio de SL. Montamos la imagen (si se cuelga hay que recurrir al viejo fix de seatbelt.kext que en SL tambien funciona (así como el fix "About This Mac.pkg" dicho sea de paso). Una vez montada la imagen, hacemos clic dentro de la carpeta donde se aloja. Shift+Cmd+G y se abre "Ir" Escribimos la siguiente ruta /Volumes/Mac OS X Install DVD/System/Installation/Packages, buscamos el BSD.pkg y lo instalamos (aunque te da la opcion de elegir carpeta, no hay que hacer nada, se instala donde debe por defecto). Cuando acabe, hay que ir a Utilidad de discos y reparar los permisos. Conviene reiniciar aquí. Al llegar otra vez a SL, ya le puedes decir a Spotlight que indexe los discos (tarda bastante), despues (o antes, eso da igual creo) ya se puede instalar Chameleon 2. Primero RC1 y después RC2. Y ya está. Espero que les funcione como ami. Suerte.

#16
Guest: kristenharper_*

Guest: kristenharper_*
  • Guests
hmmmm.... i have had my computer guy (professional IT) try to install mac on my machine for literally the past 3 weeks or so. okay, so of those weeks he was on vacation... regardless, he keeps having problems. i have basically the exact same specs on my machine as you have on yours. i have no idea how all of yall loaded this and it worked. he says he has followed the instructions and he's also read many other sites, but to no avail. i'm so bummed. if anyone has any advice or if you live in the austin texas area let me know :angel: it's depressing knowing i can do this, but it just isn't working for my machine. i have the computer guy's detailed list of what he's done as well. thanks

#17
Guest: zerorh75_*

Guest: zerorh75_*
  • Guests
Hello, I have have a problem fllowing your istruction, could you help me?I have this hardware1) Asus P6T 2) i7 920 intel3) 9600 GT with 1Gb4) 6Gb RAM5) DVD on sata16) maxtor hdd on sata27) maxtor hdd on sata3 is very similar to yours!I downloaded the software iDeneb 1.3 10.5.5 and follow the steps you have illustrated. After completing the installation the system reboots, I see the apple window, but after 4 minutes appears a window where I am asked to reboot the system by pressing the reset button . the system reboot and then the same screen appears again.Did I do something wrong?

#18
mr_christer

mr_christer

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 261 posts
  • Gender:Male
wow great geekbench score mate!i'm only getting 7150 ..a few questions i have to your setup:could you be a bit more specific about components...did you overclock your cpu? which cooling are you using? could you tell me exactly the components (ram eg). i wanna build the exact setup that you have... geekbench displays 8 cores. i assume it only has 4 cores and diplays as 8 because of hyperthreading right?i need a machine for rendering 3d stuff on osx. i just worked on the new mac pro with 2,23ghz which also reached 12000

#19
OPG

OPG

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Male
  • Location:Illinois
I have same setup with gtx296 vid card and 4 sata drives but have not been able to get this to workwent into bios and disabled ht set cpu tp 1 core and set hd tp achistill no luck woul you please send me a link to what ever image you used?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy