Jump to content

Installation problems ML 10.8.4 with Radeon 7970M

7970m 10.8.4 ML Mountain Lion Clover install notebook laptop hd4000

  • Please log in to reply
1 reply to this topic

#1
pommernfritze

pommernfritze

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hello everyone :)

I am currently trying to install Mountain Lion 10.8.4 on my notebook, but I did not have much success.
This is my hardware:
- Intel Core i7 3610QM 2,3 GHz (Ivy Bridge)
- AMD Radeon HD 7970M
- 8GB RAM
- Motherboard: Clevo P150EM

And here's what I tried so far and what kind of problems I had:
First I tried installing with ##### and myHack. They both had the same problems: I could only boot in safe mode and with GraphicsEnabler=No.
I searched a lot and often found guides about editing the DSDT. But since I could not find any for my hardware and I don't quite know how to patch them myself, I tried to find another way.

That's when I read about Clover. So I made a bootable USB stick with 2 partitions (one for Clover and the other one for the ML InstallESD.dmg).
I can boot into Clover just fine. It detects my two GPUs (Intel HD4000 and Radeon 7970M) and sets the native resolution correctly.
Now when I try to boot the installation of ML I have two problems:
1) My USB 3 ports get turned off. At least for any hardware besides my mouse. So I can only use my single USB 2 port.
2) If I boot with my install stick in the USB 2 port I get up to the GUI initialization I guess. After a bit of waiting the display turns black and if I insert a HDMI cable I can see a white background and the spinning cursor on the second screen. It stays that way.
I tried using different framebuffers in the Clover config (Aji, Buro, Chutoro), but nothing seems to get me further.

Also: I found one post, suggesting to remove the ATI7000Controller.kext for the time of installation and put it back later on. Now that I wanted to try that, I stumbled upon this: I searched my BaseSystem.dmg for the ATIxxxxController.kexts and to my surprise my ML 10.8.4 does not include any ATI7000Controller.kext!

My questions are:
- Is it possible, that it got removed with the update from 10.8.3 to 10.8.4? Can anyone confirm this?
- Do you guys have any ideas what I could try to make the installation not hang?
- Is there a way to get the USB 3 ports working during installation?
- Does anyone have any experience with AMD's Enduro technology (switching between IGPU and DGPU)?
- How do I get the internal screen of my notebook working?

I hope I got the most important aspects in this post and that someone can help me to get this installation working. Thanks in advance :)

#2
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
first read this: then post in correct place, in the forum have all info that you need , please read a bit. Graphics Cards - InsanelyMac Forum


For all those who don't yet know our position about tonymac, and your ##### software, your Forun, Tolls, links, thank you for reading http://www.insanelym...ort-tonymacx86/
p.s : pls read the forum rules !!!
InsanelyMac doesn't support tonymac's tools.





Also tagged with one or more of these keywords: 7970m, 10.8.4, ML, Mountain Lion, Clover, install, notebook, laptop, hd4000


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy