Jump to content

DSDT for Asus P8H77-M LE


  • Please log in to reply
9 replies to this topic

#1
Andy Vandijck

Andy Vandijck

    InsanelyMac Deity

  • Coders
  • 1,615 posts
  • Gender:Male
  • Location:Tienen
  • Interests:Programming stuff for Mac OS X...
    Hacking...
    Hard rock (also really big Metallica...

I just finished the optimized DSDT for the
Asus P8H77-M LE
Everything works including sleep.

 

- Graphics pre-patched for ATI HD6XXX (PEGP)
- Sleep fixed
- Optimizations done.

- USB3 fixed

- USB2 fixed

- Embedded Controller added (EC)

- LPC fixed

- RTC fixed

- Darwin added as OS type

- LAN fixed

 

Enjoy ;)

 

EDIT: New revised version.

It now works for latest revision (1302) with sleep and all...

My custom BIOS is also included in the zip (optimizations done and pmpatch applied)

 

EDIT2: New revised BIOS. (CorrectPM)

I repacked the patched PowerManagement module and now it should pass FTK flash verification.

I did this using extract of the MZ part and all after,

Next using GenSec to generate the security header and last,

Using GenFfs to remake the .ffs file and using MMTool to insert it into the firmware.

Attached Files



#2
beta992

beta992

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 338 posts
  • Gender:Male

I just finished the optimized DSDT for the
Asus P8H77-M LE
Everything works including sleep.
Graphics pre-patched for ATI HD6XXX (PEGP)
Sleep working
Optimizations done.
Enjoy ;)

May I ask what patches you have applied?

I already using patches from olarila, but I would like to here what you did to the DSDT. :)

#3
Andy Vandijck

Andy Vandijck

    InsanelyMac Deity

  • Coders
  • 1,615 posts
  • Gender:Male
  • Location:Tienen
  • Interests:Programming stuff for Mac OS X...
    Hacking...
    Hard rock (also really big Metallica...

May I ask what patches you have applied?

I already using patches from olarila, but I would like to here what you did to the DSDT. :)

See above, I just updated it.

It now also works with latest BIOS revision 100% right.



#4
partypoison1993

partypoison1993

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:India
  • Interests:3D Modeling, Animation, PC Gaming etc..

hey can i use this dsdt with asus p8h77 vle with bios version 1033..? thanks.



#5
praetorius

praetorius

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
I'm wondering if it's safe to use on the same board but only with the intel hd 4000 graphics?

#6
Andy Vandijck

Andy Vandijck

    InsanelyMac Deity

  • Coders
  • 1,615 posts
  • Gender:Male
  • Location:Tienen
  • Interests:Programming stuff for Mac OS X...
    Hacking...
    Hard rock (also really big Metallica...

I'm wondering if it's safe to use on the same board but only with the intel hd 4000 graphics?

The IGPU is included in the DSDT.

You can modify the AAPL,ig-platform-id using _DSM method...



#7
Metalcored00d

Metalcored00d

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Belgium
  • Interests:hackintosh, iOS, android, linux, windows, guitars, metal

First of all, many thanks for the effort you did to provide us with both the dsdt and the BIOS.

 

I flashed the BIOS and installed Mavericks 10.9.2 using the MyHack method. However, it only works using the "-X" flag. This is also true for booting to the desktop. I already set the PCIE gfx card as primary in the BIOS and have moved the intel gfx related kexts into another folder. Still, every time I boot normal, it hangs on "iobluetooth... missing transport".

 

Any ideas on what I should do?



#8
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,990 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

First of all, many thanks for the effort you did to provide us with both the dsdt and the BIOS.

 

I flashed the BIOS and installed Mavericks 10.9.2 using the MyHack method. However, it only works using the "-X" flag. This is also true for booting to the desktop. I already set the PCIE gfx card as primary in the BIOS and have moved the intel gfx related kexts into another folder. Still, every time I boot normal, it hangs on "iobluetooth... missing transport".

 

Any ideas on what I should do?

Try dart=0 at boot



#9
Metalcored00d

Metalcored00d

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Belgium
  • Interests:hackintosh, iOS, android, linux, windows, guitars, metal

Try dart=0 at boot

 

Thanks so much, it friggin' worked :D



#10
praetorius

praetorius

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
Hi to everyone. It's been a while since I did a hackintosh so i'm in bad need of brushing up on things.

Installed 10.9 Mavericks on my Asus P8H77M-LE with i3770 CPU,bootloader is Clover.

Updated to 10.9.4 immediately.

ISSUES:
1. No Audio. Windows uses Realtek 887 and I tried several kexts already.
2. Installed Clover (legacy mode, non uefi since i have win7 still), but whenever I boot directly to the HDD, I lose functionality of keyboard and mouse. Works fine if I use the USB installer to boot the HDD.

Video is detected properly. So my main task for now is to get the boot working,and the audio fixed.

Thanks.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy