Jump to content

Activity Monitor/System Memory doesn’t recognize the whole amount of RAM


  • Please log in to reply
5 replies to this topic

#1
Emagical

Emagical

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:London
Hi there, please help me to understand what is going wrong with my machine.

What I have:

Gigabyte GA-X58A-UD3R Motherboard

i7-960 3.2GHz 8MB LGA1366 CPU

GIGABYTE GV-R6870C-1GD video,

Kingston SSD 120GB HyperX SATA3 6G SH100S3/120G system HD

40GB RAM (Kingston HyperX Genesis 8GB memory sticks (KHX16C9/8) x4; 4GB memory sticks (KHX1600C9D3/4G) x2)

OSX 10.6.8 Snow Leopard

##### Bootloader


Previously I had 32GB of RAM that worked fine (Kingston HyperX Genesis 8GB memory sticks (KHX16C9/8) x2; 4GB memory sticks (KHX1600C9D3/4G) x4).

Because I constantly use Kontakt’s sound library under Logic I needed to upgrade my RAM to 40 GB. This amount of RAM memory would be enough for me. So, I bought two 8GB sticks and now I have 40 GB RAM inside my machine.

The System Profiler shows the 40GB is recognized (see the picture). But when I open Activity Monitor (System Memory page) to see what's going on, I find that the pie graph only shows 32GB (see the picture).

What’s wrong?

What do I need to do to get Snow Leo to recognize the whole amount (40GB) of RAM, not to ‘see’ 32GB only?

Dear professionals, how do I solve my problem?

I tried swapping memory sticks into different slots, but it didn’t help.
Attached File  memo2.jpg   39.7KB   6 downloadsAttached File  memo1.jpg   176.16KB   12 downloads

#2
Maniac10

Maniac10

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,249 posts
  • Gender:Not Telling
It's the bootloader's job to tell the system how much ram you've got. You should tell the developer so he can look at your case and fix it (if he can)

#3
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,123 posts
  • Gender:Male
  • Location:Brazil
Install the latest version of Chameleon.

See commit 2203: http://forge.voodoop...ce/commit/2203/

Hopefully that fixes this bug for good.

#4
Emagical

Emagical

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:London

Install the latest version of Chameleon.

See commit 2203: http://forge.voodoop...ce/commit/2203/

Hopefully that fixes this bug for good.


Thank you very much for your reply, I appreciate it.

I had a look at the link you gave me and I understood that without further advice I won't be able to fix the problem - it's quite complicated for me.

Would you mind giving a step-by-step explanation of how I need to install latest Chameleon?

#5
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,123 posts
  • Gender:Male
  • Location:Brazil
My manual install guide:
http://forum.voodoop...x.php/topic,649
You must register to download.

There are automated installers around as well, if installing manually seems intimidating to you you can look for those.

The bootloader itself comprises of 3 files. Make sure you know exactly where on your drives and partitions those were installed so that you properly replace the old version when upgrading.

#6
Emagical

Emagical

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:London
Thank you very much Gringo Vermrlho!
Hopefully the problem is solved.
##### 3.10.1 helped me to upgrade Chimera to the latest version1.7.0 r1394
Now Activity Monitor recognize 40GB of RAM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy