Jump to content

[Osx86] on XPS 420

- - - - -

  • Please log in to reply
22 replies to this topic

#1
Froyr

Froyr

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Salut all,
Bien heureux d'avoir enfin réussi les 2 Tests,
je viens vers vous afin de trouver solutions a mes problèmes...

Voila plus d'une semaine que j'essaye d'installer un OS X sur mon XPS 420
pas en virtuel mais en fix et je sais que cela est possible,
en voila la preuve --> OSX/Win7 dual boot on XPS420

Voici ma Configue :
-- XPS 420 --
- Proc: Intel core 2 Quad Q 6600 @ 2.40 Ghz
- Bios: Dell Inc A07
- CarteMère: Dell Inc. OTP406
- Chipset: Intel X38
- Southbridge: Intel 82801 IR
- Ram: DDR2 4096 MBytes
- CarteG: NVIDIA GeForce 8600 GTS

j'ai essayé de multiple OS X (Iatkos ML3U, ML2, L2, Hazard 10.8x, ML officiel Hack, et mon CD officiel de SL obtenu avec mon MBpro)
j'ai monté une clef avec plusieurs processus comme Iatkos, Chamelon et autres... mais je préfère MyHack.
les seul fois ou j'ai réussi a atteindre l'option d'installation de l'OS X, étaient en utilisant la version Iatkos ML2 et/ou avec mon CD officiel de SL booter sur clef USB via Myhack.

seulement mon problème est celui ci...
lorsque j'arrive sur l'utilitaire de disque afin de pouvoir formater mes DDI, ceux ci ne sont pas visible... seul ma clef USB ou mon DDE le sont...

j'ai eu beaux chercher, je n'arrive pas a trouver la solution.
j'ai trouvé un Tuto ici --> Hackintosh sur ton Dell.... mais sans succès... mon anglais et moi ça fait 2 faut dire...
il me faut peut être ajouter des Kext sur ma clef afin d'aider l'installation ? mais a partir de la je suis perdu !
j'en ai téléchargé quelques un, est ce les bon et me faut' il faire quelque chose afin de les lancer ?

un autre problème aussi, mon Bios est très simplifié et ne peux savoir si mon installation est en AHCI ou pas,
car j'ai juste les options suivante :
External Sata --> Off ou On
SATA Operation --> RAID Autodetect / Ata ou bien RAID On
j'ai essayé toutes les possibilités et rien ne change...

bref...
si quelqu'un d'entre vous est assez patient afin de pouvoir m'aider a poursuivre l'idée, je lui en serai reconnaissant ;)
je pourrais par la suite offrir un tuto cette fois ci en français afin d'aider d'éventuel personnes en possession d'un XPS420 et dans le désire d'installer un OS X.

Amicalement :)

#2
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,820 posts
  • Gender:Male
salut :)

ta configuration devrait supporter aisément les derniers OS X

je te conseille de faire une installation "Retail", utilise la FAQ pour avoir un peu plus d'info sur c'est quoi une installation dite "Retail". :)

et aussi, surtout ça, un conseille, lis bcp, essaie de comprendre comment fonctionne OS X sur un PC et sois patient ;)

bonne chance ;)

#3
Froyr

Froyr

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

ta configuration devrait supporter aisément les derniers OS X

C
'est une bonne nouvelle oui, mais je m'en doutais un peut ^^

je te conseille de faire une installation "Retail", utilise la FAQ pour avoir un peu plus d'info sur c'est quoi une installation dite "Retail". :)

Oui c'était le but vu que j'ai un DVD OS X Install et aussi par la suite d'acheter un ML pour essayer de l'installer.


et aussi, surtout ça, un conseille, lis bcp, essaie de comprendre comment fonctionne OS X sur un PC

Ça déjà été fait sur plusieurs forum, c'est pour cela que j'en suis venu a poster ici.


sois patient ;)
bonne chance ;)

Même si pour le coup tu ne ma pas été d'une grande aide, je te remercie en tout cas pour l'encouragement ! :D


#4
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,820 posts
  • Gender:Male

Même si pour le coup tu ne ma pas été d'une grande aide


:o

en faite, ce que je voulais dire c'est que tu as ici sur InsanelyMac tout ce qui faut pour t'en passer à 95% de l'aide des autres. ;)

d'où ma suggestion de lire un max, même si je ne doute pas que tu en a déjà lu pas mal (je suppose), mais on apprend toujours. ^_^

utilise la fonction "recherche", c'est un bon outil, bien pratique. Pour un peu plus d'info, tu peux aller aussi sur OSx86 Wiki

des tutos à gogo (pas gaga, hein), bref de quoi t'occuper pour des heures :D

#5
Froyr

Froyr

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Lu!

:o

:D (c'était en toute amitié hein!)

en faite, ce que je voulais dire c'est que tu as ici sur InsanelyMac tout ce qui faut pour t'en passer à 95% de l'aide des autres. ;)

oui, je m'en doutais un peut, le problème est que je suis une quiche en anglais et que je fonctionne avec un traducteur... et avec tous les langages de Geek qu'ont peut y lire, j'arrive a rien...


enfin si !

Update :
j'ai réussi tout de même a avancer un peut...

j'ai réussi a trouvé plusieurs Kext dont un "legacy_kernel-10.8.0.v2.pkg" qui lui, ma permis de voir (je ne sais pas pourquoi) mon HD interne, avec l'installation retail !
j'ai donc tout de suite fais en sorte de les formater au bon format... mais malheureusement ça ne ma pas permis d'installer SL.
l'installation m'indique toujours directement, que l'installation ne peut se faire et ça me lance l'installation a l'aide d'une sauvegarde...

j'ai donc refait une clef bootable Iatkos ML2 et la je ne voyais toujours pas mon HD dans l'utilitaire de disque,

mais ! comme je l'avais auparavant formater, l'installation elle, me proposa de se lancé sur le HD formaté qui etait quand même vu ? o_O à n'y rien comprendre...

donc j'ai lancé l'install, elle c'est bien effectué...
mais au redémarrage... blocage sur la pomme Iatkos, avec un petit logo sens interdit qui s'affiche dessus....

bref...
j'ai déjà passé énormément de temps dessus, et franchement je me demande si je ne vais pas tout simplement abandonner...
ça me parrait un peut trop complexe pour quelque chose qui devait être simple...


sauf si une bonne âme charitable daigne bien me dire ce qu'il me faut exactement comme Kext en m'expliquant leur correspondance ? ça serait top !

Amicalement.

#6
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,820 posts
  • Gender:Male

:D

(c'était en toute amitié hein!)


j'avais compris :D

bref...


j'ai déjà passé énormément de temps dessus, et franchement je me demande si je ne vais pas tout simplement abandonner...


ça me parrait un peut trop complexe pour quelque chose qui devait être simple...


oulala, tu baisses facilement les bras, dis donc ^_^

c'est exactement pour cette raison que je voulais dire ceci:

et aussi, surtout ça, un conseil, lis bcp, essaie de comprendre comment fonctionne OS X sur un PC et sois patient ;)


aucun de nous n'est arrivé du premier coup et même si certains ont galèré moins que d'autres, ça ne s'était pas passé tout le temps comme on l'avait souhaité.

pour commencer, quel est la version de ton DVD SL ? Il est inutile d'utiliser un legacy-kernel, çàd un noyau original modifié pour prendre en compte le ou les processeurs pas supportés officiellement et celui-ci est de la version 10.6.8, ton processeur dois être compatible avec le noyau (kernel) original. Donc tu n'as pas besoin de ce legacy-kernel pour faire fonctionner SL sur ta machine.

Ensuite, formate ta clé usb en GUID, et fais une partition en Mac OS étendu (journalisée), tu peux prendre toute la totalité de ta clé usb (prends-en une de 8 Go minimum)

Après mets ton DVD SL dans ton lecteur DVD et fais une restauration du dvd sur ta clé usb

Une fois que ceci est fait, télécharge la dernière version de chameleon et installes-le sur ta clé usb (décoches toutes les options, seulement laisse celle du bootloader qui sera grisée). Une fois celui-ci installé, copie ce dossier nommé Extra sur la racine de ta clé usb

Attached File  XPS_420_Extra.zip   143.66KB   11 downloads


Avec tout ceci, ta clé usb sera prête et tu devrais pouvoir booter avec. :)

Fais déjà tout ceci et si ça marche, on verra bien pour la suite. ;)


Allez, courage !!! :D

#7
andgest

andgest

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Pourquoi n'installe tu pas Mountain Lion ?
Moi aussi j'ai un XPS 420 et il tourne sur Mountain Lion nickel même si quelque bug persistant comme le son et le fait que j'arrive à booter 1 fois sur 3 XD.
J'ai utilisé ##### avec une clef USB et une image de Mountain Lion 10.8.3 (la dernière version à l'heure actuel)
Pour voir mes disques dur j'ai utilisé LegacyAppleAHCIPort.kext et LegacyAppleAHCIPortIntelICHx.kext dans le répertoir Extra/Extension et System/Lybrari/Extension (mais je me demande si ça ne vient pas de ces kexts qui m'empêche de booter de temps en temps).

Afin de booter sur ma clef usb avec ma carte graphique GTX 470 j'utilise la commande PCIRoot=1 -v -x
Après l'installation le PC démarre sans soucis ;)

Bon courage et garde espoir
Perso j'ai mis 1 mois avant de comprendre qu'il fallait utilisé la commande PCIRoot=1 pour ma carte Graphique :s

PS : Censure ???!

#8
Froyr

Froyr

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Ouah ! vous êtes top ! merci pour vos encouragements :D

pour commencer, quel est la version de ton DVD SL ?

J'ai la version 10.6.4

copie ce dossier nommé Extra sur la racine de ta clé usb
Attached File  XPS_420_Extra.zip   143.66KB   11 downloads

!! je ne sais pas comment tu t'es débrouiller pour réussir a récupérer un dossier Extra XPS 420 car j'ai cherché pendant des jours sans succès !!

bon, j'ai essayer plusieurs façon et malheureusement cela n'a pas fonctionné... je n'ai même plus accès a la pomme et l'install, ça bloque sur une erreur /mach_kernel après le lancement du bootloader.

Pourquoi n'installe tu pas Mountain Lion ?
Moi aussi j'ai un XPS 420 et il tourne sur Mountain Lion nickel même si quelque bug persistant comme le son et le fait que j'arrive à booter 1 fois sur 3 XD.
J'ai utilisé ##### avec une clef USB et une image de Mountain Lion 10.8.3 (la dernière version à l'heure actuel)
Pour voir mes disques dur j'ai utilisé LegacyAppleAHCIPort.kext et LegacyAppleAHCIPortIntelICHx.kext dans le répertoir Extra/Extension et System/Lybrari/Extension (mais je me demande si ça ne vient pas de ces kexts qui m'empêche de booter de temps en temps).
Afin de booter sur ma clef usb avec ma carte graphique GTX 470 j'utilise la commande PCIRoot=1 -v -x
Après l'installation le PC démarre sans soucis ;)
Bon courage et garde espoir
Perso j'ai mis 1 mois avant de comprendre qu'il fallait utilisé la commande PCIRoot=1 pour ma carte Graphique :s
PS : Censure ???!
U.n i._be-a.s,t


Eih ! lu ^^
alors tout d'abord je ne voulais pas télécharger ML pour le moment car SL me suffit largement sur mon MBP mais il est vrai que j'avais dans l'idée de l'installer sur mon PC par la suite.
mais avant ça, je voulais d'abord tester la compatibilité de mon XPS avec mon SL pour savoir si le pc pouvait tourner avec un OS X
maintenant que je sais que tu as réussi a l'installer sur ton Dell, je vais surement revoir mes positions ;)
j'ai déjà testé les Kext dont tu parle, mais pourrais tu me donner la config de ton bios en plus ? car j'ai certainement du faire une erreur aussi ?
pour la commande de la carte graphique, comme je n'ai pas la même je ne pense pas qu'elle sera utile, de plus je suis déjà arrivé auparavant sur la page d'install, mais bon.. WHy not, a tester aussi !
aurai tu la possibilité de me upload ton Extra pour que j'essaye aussi ! si tu en as la possibilité
je t'en remercie par avance

PS: oui censuré, suis le lien qui remplace le mot, tu comprendra... mais j'avais tout de même compris ton installation^^


#9
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,820 posts
  • Gender:Male

je ne sais pas comment tu t'es débrouiller pour réussir a récupérer un dossier Extra XPS 420 car j'ai cherché pendant des jours sans succès !!


je l'ai concocté moi-même ^_^, rien de bien difficile ;)

bon, j'ai essayer plusieurs façon et malheureusement cela n'a pas fonctionné... je n'ai même plus accès a la pomme et l'install, ça bloque sur une erreur /mach_kernel


tu pourrais faire une capture de l'erreur, stp ? je pense qu'il n'arrive pas à booter sur le noyau. Tu as regardé s'il s'y trouve sur ta clé usb ? (c'est un fichier caché)

si non, au démarrage, boot avec -v mach_kernel

#10
Froyr

Froyr

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

tu pourrais faire une capture de l'erreur, stp ? je pense qu'il n'arrive pas à booter sur le noyau. Tu as regardé s'il s'y trouve sur ta clé usb ? (c'est un fichier caché)
si non, au démarrage, boot avec -v mach_kernel


Voici la capture:
Posted Image


#11
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,820 posts
  • Gender:Male
tu as utilisé quoi comme bootloader et quelle version ?

#12
Froyr

Froyr

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

tu as utilisé quoi comme bootloader et quelle version ?

le Chameleon-2.2svn-r2191, Chameleon-2.2svn-r2223 qui était sur insanelymac et aussi le Chameleon-2.1-r2109 que j'ai trouvé sur le site officiel.
et je bloque toujours sur un page m'indiquant de redémarrer en appuyant longtemps sur le bouton démarrer de mon pc.

sinon hier soir j'ai essayé une autre façon avec ######## (je n'avais pas sous la main de cd vierge...) et c'est toujours pareille, j'arrive a passer l'option de langue d'OS X mais ensuite il affiche directement,
voulez vous redémarrer ou restaurer a partir d'une sauvegarde... du coup je fais restaurer a partir d'une sauvegarde pour tester, du coup là, j'ai accès a l'utilitaire de disque mais dedans je ne vois toujours pas mon HD...

#13
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,820 posts
  • Gender:Male
je ne pense pas que cela aidera beaucoup, mais supprime <key>device-properties</key> avec son <string>6e0200...</string> de ton org.chameleon.Boot.plist et essaie de redémarrer pour voir.


p.s: InsanelyMac ne supporte pas les outils de tonymacx86. Pour plus d'infos, veuillez lire ça et ça. Cordialement, staff

#14
Froyr

Froyr

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

je ne pense pas que cela aidera beaucoup, mais supprime <key>device-properties</key> avec son <string>6e0200...</string> de ton org.chameleon.Boot.plist et essaie de redémarrer pour voir.
p.s: InsanelyMac ne supporte pas les outils de tonymacx86. Pour plus d'infos, veuillez lire ça et ça. Cordialement, staff


Ça ne change rien, je vois toujours cette image:
Posted Image

#15
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,820 posts
  • Gender:Male
ok, merci

juste boot avec -v pour voir si c'est la même cause du KP


SATA Operation --> RAID Autodetect / Ata ou bien RAID On


ça fait quoi avec RAID Off (si tu as cette option) ? ton dd devrait être vu via l'utilitaire de disque

#16
Froyr

Froyr

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

juste boot avec -v pour voir si c'est la même cause du KP

voici la capture:
Posted Image

ça fait quoi avec RAID Off (si tu as cette option) ? ton dd devrait être vu via l'utilitaire de disque

quand je test, j'essaye toujours avec les 4 options possible puisque comme j'ai indiqué sur mon 1r post mon bios n'indique que 2 réglage possible.
et dans tout les cas, c'est toujours pareille, mon HD ne s'affiche pas, le seul moment ou il à été possible de le voir c'est avec le "kernel"
et je sais pas pourquoi mais j'ai eu l'impression qu'en fait ça lançait le truc en x86 plutôt qu'en 64

#17
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,820 posts
  • Gender:Male
essaie ce nouveau "Extra"

Attached File  XPS_420_Extra.zip   991.12KB   7 downloads

J'y ai ajouté 3 kexts pour la reconnaissance de ton DD

espérons que ça soit bon ^_^

#18
Froyr

Froyr

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

essaie ce nouveau "Extra"

Attached File  XPS_420_Extra.zip   991.12KB   7 downloads

J'y ai ajouté 3 kexts pour la reconnaissance de ton DD

espérons que ça soit bon ^_^


toujours pareille, je n'arrive pas a aller au delà de la page qui me demande de redémarrer même avec le nouveau dossier extra que tu ma fais.
donc je n'ai même pas la possibilité de voir si tes Kext me permettent de voir le HD... :'(

#19
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,820 posts
  • Gender:Male
tu as essayé de booter sans dsdt ?

#20
Froyr

Froyr

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

tu as essayé de booter sans dsdt ?


?? peux tu m'expliquer stp :s





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy