Jump to content

HD4000 VGA


  • Please log in to reply
4 replies to this topic

#1
tochange

tochange

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Hello, anyone can help me enable hd4000 vga?
I ve been searching and trying for some weeks now, before annoying other human beings, but i can't go any further without straight help. Informations floating here and there for different cases but i can't combine or adapt them . All these things are way too complex for my brain…(Basically, all this reading is general very difficult and overwhelming for me, due to my ADHD)

Anyway, i ve installed and have been inside Mountain lion 10.8.2 very easy without a need to type in any flags in the boot screen.
Bios has been flashed before anything else with modified version downloaded from biosrepo.

Sleep and step speeding don't work, and i only have network if i boot through the USB installer ,but these are ok at least for now, first concern is to enable graphics support and with 1366x768 resolution.So:

With the guides below, i think i altered the kext AppleIntelSNBGraphicsFB.kext with hex friend, which is needed for enabling VGA .
http://forum.osxlati...tel-hd3000-gpu/
same thing here:
http://www.osx86.net...-hd-3000-a.html

However, I can't edit the DSDT with "Method (_DSM, 4, NotSerialised)….." because my DSDT already has a "Method (_DSM, 4, Serialised)" under GFX0, and if i add it, it is causing error ("Name already exists in the scope"). If i delete the original one, more errors occur. I couldn't find a google answer for that. (Not that i am sure what i exactly i have to alter inside a DSM method to adapt it to my hardware, even if i could find an answer).
So, maybe the same thing could be done with EFI string instead (?), but i couldn't understand how to do this one.
Best (most complete and easiest to follow) guide for EFI strings i could find was this :
http://www.insanelym...to-efi-strings/
but unfortunately its a different case and the first part of this guide ("part one") is confusing me...


MB : ASUS P8Z77-V LE
CPU : i7 3770
GPU : HD4000

#2
fau7i

fau7i

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 111 posts
  • Gender:Male
  • Location:Malaysia

With the guides below, i think i altered the kext AppleIntelSNBGraphicsFB.kext with hex friend, which is needed for enabling VGA .
http://forum.osxlati...tel-hd3000-gpu/
same thing here:
http://www.osx86.net...-hd-3000-a.html

Those guide are for Intel HD 3000 which uses AppleIntelSNBGraphicsFB.kext. Meanwhile, your Intel HD 4000 framebuffer depends on AppleIntelFramebufferCapri.kext. Most likely EFI strings might helps you getting video output. But I doubt you will have full graphics acceleration if you were talking about output from a VGA port since OS X (Apple) doesn't bother about it.

#3
tochange

tochange

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
(man , how much easier is if you just ask someone... )
First of all thanks from my heart, for reading this and replying.
Ok, i see, then i ll try to find a DVI monitor in some days or a few weeks, and if i do ,and then i ll post back.
Thnks again

#4
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,537 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
hello

hd 4000 how to

http://olarila.com/f...php?f=28&t=3111

good hack

#5
tochange

tochange

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
I may misunderstood the first reply. What i asked can be done, one just have to edit the AppleIntelFramebufferCapri.kext instead.

Anyway, i did it, thanks God its working, i love you!
(i already had your post bookmarked but wouldn't know it was the solution)

I wrote in a pdf (attached) all the steps i did trying to follow those instructions, if someones wants to see what worked for me ,in combination with the the above links ..
(i hope i didn't write something wrong inside)

After that, AppleGraphicsPowerManagement.kext doesn't seem to be loaded if i type kextstat in the terminal.
I should do my efforts on that, so ,again, If anyone already knows a realtivily easy to follow guide to point me for enabling it ...

(thanks again for the links..! )

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy