Jump to content

AMD APU mountain lion support

APU AMD Pavilion

  • Please log in to reply
299 replies to this topic

#1
TonyHailway

TonyHailway

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
I have a question about why mountain lion will not run on amd's APU. In this thread (http://www.insanelym.../page__st__1560) it says it will never be supported. Can anyone explain why some people have APU support in snow leopard and not in mountain lion?

#2
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
Hi!

Man, you cannot pick a statement from a debate and assume it was its conclusion. ;)

Answer both quizzes so you can post anywhere, then get answers for your doubts in the appropriate place: http://www.insanelym...md-development/

All the best!

#3
TonyHailway

TonyHailway

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
:)

Edited by theconnactic, 28 March 2013 - 08:10 PM.
Edited because the original topic was moved here by Fantomas. It was a duplicate of the first post. Deleted all other posts non-related to the subject to avoid confusion. Thanks =]


#4
TonyHailway

TonyHailway

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Some help please, I really want to try hackintoshing :)

#5
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male

Some help please, I really want to try hackintoshing :)


I suggest you start the project, and when i problem appears, you report here, for other APU users to see. You might as well be a pioneer. :)

As a starting point, i suggest:

1) Start with Lion, since it's easier to set up and is, by far, the most stable OSX release for AMD machines. When you have the perfect Lion machine, update to Mountain Lion. Go get the latest kernel for Lion here, and rename it to amd_kernel: http://www.mediafire...lnlecqnv20yvol6

2) Before you begin, make sure SATA mode is set as AHCI (or RAID if AHCI is not available) and C1E is disabled

3) Follow this method exactly as described, just adding the amd_kernel to the root of the USB installer (EDIT: the one i linked previously was for Mountain Lion) http://www.insanelym...erimental-only/

4) Boot from your USB stick using the flags amd_kernel arch=i386 -v -f GraphicsEnabler=No (it's case sensitive, type exactly as written).

When you're done with these steps, post here. :)

All the best!

#6
TonyHailway

TonyHailway

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Can this be done with iAtkos? Cause if I want to first see if my laptop is compatible/stable enough to be my daily driver than switch to vanilla, which is apparently better

#7
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
I don't know.

#8
TonyHailway

TonyHailway

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Ah well, calling me a pioneer got me pumped :) (im a noob at this) going to buy lion disk anyway :)

#9
AkimoA

AkimoA

    AMD

  • Local Moderators
  • 221 posts
  • Gender:Male
  • Location:Black Forest (GER)
But this is a fact not a conclusion ! .... as of now nobody got it to work and if .... without any quartz enabled ....wich is useless ...

#10
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
Hi, Akimoa!

Well, since he stated so assertively that them APUs are supported in Snow Leopard, i think he could try to be the first to successfuly run Lion/Mountain Lion with them. If it proves to be a failed project, at least he would have spent the $20 price tag of the OS - which is the price of two Big Mac combos, i must remind you - in something that effectively will add knowledge to his brains, not cholesterol to his veins.

All the best!

#11
pmmc

pmmc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:Lisbon
  • Interests:Hackintosh, Gaming, Mechanical Engineering and so on :P
Hi, can you guys sort things out for the APU's ? I've got an A6-4400M and all I get is instant reboots!! help!

#12
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 2,010 posts
  • Gender:Male
  • Location:marocain

Hi, can you guys sort things out for the APU's ? I've got an A6-4400M and all I get is instant reboots!! help!



it can have various causes!
Once the try this:

boot with -s

then give:
/sbin/fsck -fy
then you give:
/sbin/mount -uw /
than give
exit or reboot

#13
pmmc

pmmc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:Lisbon
  • Interests:Hackintosh, Gaming, Mechanical Engineering and so on :P

it can have various causes!
Once the try this:

boot with -s

then give:
/sbin/fsck -fy
then you give:
/sbin/mount -uw /
than give
exit or reboot


didnt even get me to -s mode..once i finish typing the kernel and flags..what happens is that it shows the loading of the kexts but then it reboots..doesnt even show the verbose part.. get it ? :s so..i guess there is something missing on the kernel.. this CPU handles anything (sse3, ssse3, ...) as you can see here: https://www.dropbox....ZAPUAMDA6.png?m

#14
gils83

gils83

    DJ Officiel d'InsanelyMac

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,951 posts
  • Gender:Male
  • Location:France
  • Interests:le soleil du var et l'informatique

didnt even get me to -s mode..once i finish typing the kernel and flags..what happens is that it shows the loading of the kexts but then it reboots..doesnt even show the verbose part.. get it ? :s so..i guess there is something missing on the kernel.. this CPU handles anything (sse3, ssse3, ...) as you can see here: https://www.dropbox....ZAPUAMDA6.png?m


hello ,

Clover 1050 or 1208 ;)

#15
pmmc

pmmc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:Lisbon
  • Interests:Hackintosh, Gaming, Mechanical Engineering and so on :P

hello ,

Clover 1050 or 1208 ;)


humm thats interesting :P my BIOS has UEFI..I already tried here an EFI boot..it worked..but it rebooted.. question that pops out is do I turn off legacy boot so I can boot into Clover? and..what kernel should I use?

#16
gils83

gils83

    DJ Officiel d'InsanelyMac

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,951 posts
  • Gender:Male
  • Location:France
  • Interests:le soleil du var et l'informatique
:)

Clover 1208 fonctionne aussi pour AMD et les vieilles cartes mères S 939/940 .
Merci Slice et Mark...... :)
une fois fini , boot sur la clef usb , va très bien notamment sur les CPU FX , plus besoin de FakeSMC.kext et de NullCPUPowerManagement.kext

Clover also works for AMD in 1208 and the old motherboards S 939/940.
Slice and thank you Mark ...... :)
once finished, boot on USB key, goes very well especially on FX CPU, no need FakeSMC.kext and NullCPUPowerManagement.kext




#17
pmmc

pmmc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
  • Gender:Male
  • Location:Lisbon
  • Interests:Hackintosh, Gaming, Mechanical Engineering and so on :P

:)

Clover 1208 fonctionne aussi pour AMD et les vieilles cartes mères S 939/940 .
Merci Slice et Mark...... :)
une fois fini , boot sur la clef usb , va très bien notamment sur les CPU FX , plus besoin de FakeSMC.kext et de NullCPUPowerManagement.kext

Clover also works for AMD in 1208 and the old motherboards S 939/940.
Slice and thank you Mark ...... :)
once finished, boot on USB key, goes very well especially on FX CPU, no need FakeSMC.kext and NullCPUPowerManagement.kext


http://www.youtube.com/watch?feature=player_detailpage&v=YWum8sju69g


I couldnt boot into clover...tried all the ways..it used to actually work** any other method?

#18
gils83

gils83

    DJ Officiel d'InsanelyMac

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,951 posts
  • Gender:Male
  • Location:France
  • Interests:le soleil du var et l'informatique
:)

yes, as your CPU is the same architecture as the FX, normally, it works.

#19
clemj06

clemj06

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 135 posts
  • Gender:Male
  • Location:London
  • Interests:Hackintosh, System building
Similar architecture but does not have sse4.1/4.2 or ssse3

#20
gils83

gils83

    DJ Officiel d'InsanelyMac

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,951 posts
  • Gender:Male
  • Location:France
  • Interests:le soleil du var et l'informatique

Similar architecture but does not have sse4.1/4.2 or ssse3


Posted Image

;)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy