Jump to content

Activating a PC numpad in a real Mac

PC keyboard num lock numpad

  • Please log in to reply
3 replies to this topic

#1
Sotirios Papakonstantinou

Sotirios Papakonstantinou

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts
Hello!

Sorry if this is not the right place to ask. I work in a computer shop and recently I sold a cheap noname USB keyboard to an Apple user. I don't know which model his Mac is, but he told me it originally had MacOS 9 installed and he upgraded to MacOS X 10.4 Tiger which is the maximum supported by the hardware. The new keyboard works fine, except for the numeric keypad. It is always off and I wonder if there is any way to enable it so he can type numbers from there. I went to his place, had a look in Settings/Keyboard but could not find anything relevant. I also tried Google, but I didn't manage to find anything useful. I hope you know which setting or key combination or third-party utility can enable the numpad in a non-apple keyboard at a real Mac. If the keyboard where Microsoft or Logitech, I could try the respective driver, but as I already said this is noname.

Any help appreciated.

Thank you in advance

Sotirios Papakonstantinou.

#2
JahStories

JahStories

    InsanelyMac Legend

  • Local Moderators
  • 998 posts
  • Gender:Male
  • Location:Sicily, Italy.
  • Interests:Everything that got a screen on it, skateboarding, reggae music, PowerPcs, Amigas and retrogamin...
it's really strange, i had a lot of g3 and g4 systems that camed with os9 and then upgraded to tiger and then leopard but i've never seen anything like this...
you may try to update to leopard (that can be patched to be installed on almost any osx capable g3 or g4) and try...
you can even try to boot pressing the arrow button that should be located somewhere, that should boot open firmware and try to check if the keypad is working there...

#3
alexanderq

alexanderq

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 178 posts
  • Gender:Male
1) Make sure that num lock is OFF (not lighted)
2) Go to Apple Menu->System Preferences... and click Universal Access
> In Universal Access, make sure "Enable access for assistive devices" is not checked
> Click the "Keyboard" tab
> Make sure that Sticky keys and Slow Keys are both off
> Click the "Mouse & Trackpad" tab
> Make sure Mouse Keys is off

#4
Sotirios Papakonstantinou

Sotirios Papakonstantinou

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 119 posts

1) Make sure that num lock is OFF (not lighted)
2) Go to Apple Menu->System Preferences... and click Universal Access
> In Universal Access, make sure "Enable access for assistive devices" is not checked
> Click the "Keyboard" tab
> Make sure that Sticky keys and Slow Keys are both off
> Click the "Mouse & Trackpad" tab
> Make sure Mouse Keys is off


Thank you, I'll try these. The keyboard works fine when connected on a PC, so there is a software issue, no hardware.

it's really strange, i had a lot of g3 and g4 systems that camed with os9 and then upgraded to tiger and then leopard but i've never seen anything like this...
you may try to update to leopard (that can be patched to be installed on almost any osx capable g3 or g4) and try...
you can even try to boot pressing the arrow button that should be located somewhere, that should boot open firmware and try to check if the keypad is working there...


The keyboard works fine when connected on a PC, so this is a software issue, not hardware. Have you ever tried using a standard PC keyboard on one of these models? Without special software (eg Microsoft or Logitech) of course! Were you able to use the numeric keypad to type numbers? My client can only use it for navigation (num lock off, arrow mode). My question was how can I switch it to number mode.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy