Jump to content

How to launch ATI-card by DSDT


  • Please log in to reply
95 replies to this topic

#81
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 706 posts
  • Gender:Male
If you have a laptop, it is impossible to disable your card by bios.(At least with official bios) Only desktop.
What I can recommend is to try start up your second card. Patch framebuffer-langur, and take second graphics-part for config.

#82
edipo2s

edipo2s

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Brazil

Using Langur fbname, I put your connector patch using Clover, but nothing new when boot... and patch manually the AMD5000Controller with hexedit to test with Chamelleon and nothing too.. framebuffer kext don't load.

No black screen



#83
edipo2s

edipo2s

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Brazil

I have flashed a modded BIOS that unlock the advanced menu. But in video configuration I don't understand how to disable the integrated. =/  Any idea?

 

here the picture

DSC03351.jpg

 

DSC03350.jpg



#84
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 706 posts
  • Gender:Male

Oh. Greate!

See Primary Video adapter to disable it, like this

Attached File  cb408d700c33.jpg   27.91KB   2 downloads


--------

Afterwards, Use this program to check on how many ATY devices you have.

Attached File  Screen Shot 2013-09-03 at 11.30.01.png   129.69KB   2 downloads

Attached Files



#85
edipo2s

edipo2s

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Brazil
 
I have bad new man, after I change the Primary Graphic Adapter to 'Ext Graphics (PEG)', my notebook don't show more anything in the screen. :(
 
I took out the battery and left out all night to see if it reset the bios settings but still the same. And there is the LED on the caps lock is just blinking at 5 times.
With pen drive recovery bios (following this tutorial http://donovan6000.b...k-recovery.html) also did not succeed, put the USB drive, secure Win + B, push the button and turn, and after about 3 seconds, and is direct only beeping. I waited about two minutes but nothing changed. :'( 


#86
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 706 posts
  • Gender:Male
Year, problems with bios are serious. Bios is what a computer is.
What you can try.
Return old parameters of graphics blindly, if you remember each step.
Dig the internet in order to find another solution.
Restore bios with the help of progromator on your own or ask service center to do that instead.

#87
edipo2s

edipo2s

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Brazil

well.. the main problem is that all that my notebook does is "keep blinking the capslock le 5 times" and here hp say: 'System board - General system board failure' (http://h10025.www1.h...=c01732674#N551) but they wont say nothing to fix it =/

I'm asking me, how change the main graphic adapter can do this? In my head, pull off the battery, would reset bios settings bring the main cad back to IGD and everything bring to normal back =[



#88
RobertX

RobertX

    Yosemite Sam

  • Members
  • PipPipPipPipPipPipPip
  • 573 posts
  • Gender:Not Telling

...just remember, pulling the battery may NOT always reset bios... you may have to move jumpers on the motherboard to achieve this...check your board manual for instructions... :smoke:



#89
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 3,028 posts
  • Gender:Male

To the AMD users in this topic: this method won't solve the graphics artifacts and glitches specific of AMD machines on Mountain Lion: these are resultant of a bug in the current's kernel patch set of which the cause is yet to be isolated. Please don't waste your and Alex's time.

 

Edipo2s, even if you manage to disable the primary card somehow, the secondary one won't work as it should because of the above mentioned bug. But even disable the primary card is a nigh-impossible task: there's not a single report yet of an AMD APU laptop working with graphics acceleration. Blame also that crapy, unbelievable InsideH2O BIOS chosen by most manufacturers, that is as locked as it can be.

 

All the best!



#90
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 706 posts
  • Gender:Male

To the AMD users in this topic: this method won't solve the graphics artifacts and glitches specific of AMD machines on Mountain Lion: these are resultant of a bug in the current's kernel patch set of which the cause is yet to be isolated. Please don't waste your and Alex's time.

Edipo2s, even if you manage to disable the primary card somehow, the secondary one won't work as it should because of the above mentioned bug. But even disable the primary card is a nigh-impossible task: there's not a single report yet of an AMD APU laptop working with graphics acceleration. Blame also that crapy, unbelievable InsideH2O BIOS chosen by most manufacturers, that is as locked as it can be.

All the best!

Thanks that brought in some clearness.I also noticed that edipo2s has not so good configuration. But I was shy to offer him the rejection of hackintoshing as it is not in the spirit of our forum. We all "mad and insane" wasting a lot of time for hackintosh and helping each other. Always trying to get it better. And for the most cases we are sucessful, but practice shows there are exclusions as well
But for this case, this configuration is bad., to be honest. What I can advise is to use Mac on a Virtial Machine. Or to change the computer or to buy a real Mac and forget about all hackintoshing problems. No another way around.

#91
edipo2s

edipo2s

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Brazil

Well, now only remains for me discover how resolve this black screen with "keep blinking the capslock le 5 times". Any suggestions? or similar case?



#92
Alex Auditore

Alex Auditore

    InsanelyMac Legend

  • Donators
  • 706 posts
  • Gender:Male

Caps/Num LED Part Error Condition 
LEDs blink 1 time CPU CPU not functional
LEDs blink 2 times BIOS BIOS corruption failure
LEDs blink 3 times Memory Module error not functional
LEDs blink 4 times Graphics Graphics controller not functional
LEDs blink 5 times Mainboard General system board failure
LEDs blink 6 times BIOS BIOS authentication failure


Try to restore it by FAT usb stick, Perhaps you need to try several ports if one of them doesn't work.

Everththing will be happening blidnly. Look at indicator of USB Sticke to be sure that something occurs.

http://translate.goo...7:38124&act=url



#93
edipo2s

edipo2s

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Brazil

No luck with bios recover, I've tried with donavan's blog tutorial too. So I'm replacing the motherboard. Anyway, very thanks all that tried help me here and especially Donators for your great attention. And sorry for waste your time.  ^_^



#94
edipo2s

edipo2s

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:Brazil
After repair my notebook, I tried it again and found a way to get CI(transparency menu bar) in my dedicated radeon 5650m, but no QE(acceleration) yet =s

Here the description:
http://www.insanelym...e/#entry1992570

#95
khe91

khe91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Male
  • Location:Germany
I have a problem with an 7970 and trying to solve it with DSDT injection, but can't find the correct position for the GFX0 inject behind PCI bridges.
Don't wanna double post the files.
Please take a look at:
http://www.insanelym...1092/?p=1994636

Thanks

#96
Rockey12

Rockey12

    InsanelyMac Protégé

  • Members
  • PipPip
  • 95 posts
  • Gender:Male
  • Location:Earth
  • Interests:no comi

Hi Guys anybody can fix the ATI 48XX Series ATIFramebuffer

 

Can anybody help me please?

 

Wekiva RV770 B50102 Board                                                   

 

Subsystem Vendor ID: 174b

       Subsystem ID: e810

Object Header Structure Size: 354

Connector Object Table Offset: 50

Router Object Table Offset: 0

Encoder Object Table Offset: 10b

Display Path Table Offset: 10

Connector Object Id [2] which is [DVI_I]

encoder obj id [0x1e] which is [INTERNAL_UNIPHY (osx txmit 0x10 [duallink 0x0] enc 0x0)] linkb: false

Connector Object Id [2] which is [DVI_I]

encoder obj id [0x16] which is [INTERNAL_KLDSCP_DAC2] linkb: false

Connector Object Id [15] which is [DIN]

encoder obj id [0x16] which is [INTERNAL_KLDSCP_DAC2] linkb: false

Connector Object Id [15] which is [DIN]

encoder obj id [0x16] which is [INTERNAL_KLDSCP_DAC2] linkb: false

Connector Object Id [2] which is [DVI_I]

encoder obj id [0x15] which is [INTERNAL_KLDSCP_DAC1 (osx txmit 0x00 enc 0x10?)] linkb: false

Connector Object Id [2] which is [DVI_I]

encoder obj id [0x1f] which is [INTERNAL_KLDSCP_LVTMA] linkb: false

 

Kext /System/Library/Extensions/AMD4800Controller.kext/Contents/MacOS/AMD4800Controller

Personality: Cardinal

ConnectorInfo count in decimal: 2

Disk offset in decimal 649968

0000000    00  02  00  00  14  02  00  00  00  01  00  00  01  01  01  04

0000010    04  00  00  00  14  02  00  00  00  01  00  00  00  10  02  03

0000020

Personality: MotMot

ConnectorInfo count in decimal: 2

Disk offset in decimal 650000

0000000    00  04  00  00  04  01  00  00  00  01  00  00  10  00  02  03

0000010    04  00  00  00  14  02  00  00  00  01  00  00  01  11  01  04

0000020

Personality: Quail

ConnectorInfo count in decimal: 3

Disk offset in decimal 650032

0000000    02  00  00  00  40  00  00  00  09  01  00  00  22  01  00  07

0000010    02  00  00  00  00  01  00  00  09  01  00  00  20  01  03  04

0000020    00  04  00  00  04  03  00  00  00  01  00  00  10  00  02  03

0000030







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy