Jump to content

10.8.4 Betas Builds


  • This topic is locked This topic is locked
194 replies to this topic

#41
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,879 posts
  • Gender:Male
  • Location:Stuttgart / Germany

@mitch_de

My EP35-DS3P's ALC889a is still working fine. :guitar:

OK, what AppleHDA.kext do you use (and togehter with AppleHDAEnabler? )
I think we all have same DSDT config for 889A = 885 / layout id 12 (x0C)
For tests can you zipp your AppleHDA .kext and upload it here ?
EDIT: Working now with 10.8.3 AppleHDA - i deleted upated 10.8.4 and installed again 10.8.3 (KextWizard).
Perhaps at first install (i didnt removed the overwitten 10.8.3 by 10.8.4 HDA before using Kextwizard with 10.8.3) something went wrong.

#42
VCH888

VCH888

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 585 posts
@ mitch_de

I use AppleHDA 2.3.7fc4 and copy layout12.xml.zlib and Platforms.xml.zlib to their destination before restarting the update.

I am glad that you got it's working.

#43
Kynyo

Kynyo

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 226 posts
  • Gender:Male
  • Location:Not your bisnizz...
  • Interests:
CUDA-Z gives me instant system freeze when i go to the "performance panel."
The rest is oke. Only Rollback AppleHDA.
Using custom DSDT.

#44
RobertX

RobertX

    InSanelyMac Maverick

  • Members
  • PipPipPipPipPipPipPip
  • 531 posts
  • Gender:Not Telling
...are the new nvidia drivers system version dependant?(frameworks and such)...i was considering trying them on 10.8.3... :smoke:

#45
Ekstr

Ekstr

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

...are the new nvidia drivers system version dependant?(frameworks and such)...i was considering trying them on 10.8.3... :smoke:


I was able to install the drivers from 10.8.4 on 10.8.3 and they work perfectly (even got my GTX450TiBoost recognised properly) :)

#46
RobertX

RobertX

    InSanelyMac Maverick

  • Members
  • PipPipPipPipPipPipPip
  • 531 posts
  • Gender:Not Telling

I was able to install the drivers from 10.8.4 on 10.8.3 and they work perfectly (even got my GTX450TiBoost recognised properly) :)

...thanks, i may test them out then... :weight_lift:
edit: just confirming the drivers work fine (same opencl fix required as previous driver for fermi) ran a couple of quick tests and scores about the same...cuda requires an update as well, but none available :smoke:

#47
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,952 posts
  • Gender:Male

CUDA-Z gives me instant system freeze when i go to the "performance panel."


OK, so it not just me. Also all CS6 apps do the same.

#48
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,631 posts
  • Gender:Male
  • Location:Canary Islands
Mountain Lion 10.8.4 Beta (12E30)
Attached File  12E30.png   238.35KB   263 downloads
Sweet...

Fabio
  • XLR likes this

#49
Neo_01

Neo_01

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
Ciao scusa, come fai a gestire due monitor con la scheda Nvidia Quadro?
Grazie
Ciao

Mountain Lion 10.8.4 Beta (12E30)
Attached File  12E30.png   238.35KB   263 downloads
Sweet...

Fabio



#50
tle88

tle88

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts
  • Gender:Male
  • Location:Finland
10.8.4 (12E30) works well.

T -.-

#51
AREOS

AREOS

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 278 posts
  • Gender:Male
  • Location:Mexico City

AGPM mostly didnt help with the wellknown "Nvidia OpenGL Channel timeout". Started in past with fermi gpus, but with an early 10.8.3 dev build even my 9600 GT got that problem - never had that (fermi) problem before.
AGPM was working before and after. And the only solution was one of the later 10.8.3 dev builds.
So it has to do with the Nvidia drivers and the AGPM (settings, working or not) may help to reduce the timeouts but will not avoid them completely.


I have been using build 12E30 for a week and none a single freeze by then. Try it and post back your results.

Good luck

#52
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,631 posts
  • Gender:Male
  • Location:Canary Islands

Mountain Lion 10.8.4 Beta (12E30)
Attached File  12E30.png   238.35KB   263 downloads
Sweet...

Fabio

EDIT:
CUDA Feature gone... waiting until nvidia update it (w8 until Apple release the final 10.8.4).
Fabio

Ciao scusa, come fai a gestire due monitor con la scheda Nvidia Quadro?
Grazie
Ciao

This is related with you bootloader or with your DSDT injection or with your EFI string injection or with some custom kext...
In my case I use the simply GraphicsEnabler=Yes in o.c.B.p (org.chameloen.Boot.plist)

#53
k3nny

k3nny

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 538 posts
  • Gender:Male
New build 12E33a
Attached File  beta.jpg   101.46KB   105 downloads

#54
Ekstr

Ekstr

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

I have been using build 12E30 for a week and none a single freeze by then. Try it and post back your results.

Good luck


Same here :)

#55
xpamamadeus

xpamamadeus

    InsanelyMac Legend

  • Donators
  • 577 posts
  • Gender:Male
  • Location:Croatia
Some inprovments in new nvidia drivers on e33a
Posted Image
Posted Image

#56
maximus

maximus

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
  • Gender:Male
  • Location:Croatia
  • Interests:Everything IT related, Hi-Fi audio, good books
New update works fine. Only AppleHDA needed replacing.

#57
beta992

beta992

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 338 posts
  • Gender:Male
At the moment I'm testing the 10.8.4 nVidia kext + (my) patched AGPM.kext and the robertx openGL patch.
Hopefully this will reduce/remove the openGL timeouts..

One interesting thing, when browsing on the nVidia website I found this page, explaing that 305.53 driver gives OpenGL 4.3 Support for some Fermi/Kepler CPU's. The 'default' OS X 10.8.3 version has: 304.10.65f03. The 10.8.4 driver has 310.40.00.05b03. Could it mean that their simple was no (real) support for Fermi users in 10.8.3 and this has been added (due the new drivers) with 10.8.4?

Will keep you posted. :)

Thanks!

Update: Just got a freeze again! :(

#58
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,879 posts
  • Gender:Male
  • Location:Stuttgart / Germany
I am unsure, or better i think that your page link is an information for Windows OpenGL, which may implement different OpenGL Features than OS X.
At least tessellation OpenGL feature isnt available (even on 10.8.4). Which is normally an feature of 4.x, when gpu has that hw feature.

I dont think that Apple has the focus to implement fast "newer" OpenGL 4.x features into OS X. Less presure from users and devs on mac apps to implement that soon.
Looks different on the workstation (non Apple) market. Some 4.x features, beside tess, can speed up professional OpenGL Apps and / or make opengl dev more easier (less source code steps compared to 3.x for same functions).

#59
AREOS

AREOS

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 278 posts
  • Gender:Male
  • Location:Mexico City

At the moment I'm testing the 10.8.4 nVidia kext + (my) patched AGPM.kext and the robertx openGL patch.
Hopefully this will reduce/remove the openGL timeouts..

One interesting thing, when browsing on the nVidia website I found this page, explaing that 305.53 driver gives OpenGL 4.3 Support for some Fermi/Kepler CPU's. The 'default' OS X 10.8.3 version has: 304.10.65f03. The 10.8.4 driver has 310.40.00.05b03. Could it mean that their simple was no (real) support for Fermi users in 10.8.3 and this has been added (due the new drivers) with 10.8.4?

Will keep you posted. :)

Thanks!

Update: Just got a freeze again! :(


Wich build are you using 12e33a or 12e30?? because I got 2 freeze in 12e33a but none on 12e30. I´ll continue using 12e30 to see if this drivers correct the freeze.

Good Luck

#60
beta992

beta992

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 338 posts
  • Gender:Male

Wich build are you using 12e33a or 12e30?? because I got 2 freeze in 12e33a but none on 12e30. I´ll continue using 12e30 to see if this drivers correct the freeze.

Good Luck

Thanks for reporting. I'm using the newest 12e33a. I'm going to try the 12e30 driver, maybe they work correctly. :)

Just one question: I only replaced the nVidia kexts. Is their need to replace other kexts/frameworks?

Thanks. :)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy