Jump to content

ATI Radeon Xpress 200M with 10.6

radeon 200M Xpress L30-105 toshiba Snow leopard

  • Please log in to reply
4 replies to this topic

#1
zaledar

zaledar

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Male
  • Location:France, Toulouse
Hello,

I have a laptop with an integrated Graphic Card ATI Xpress 200M.

I succeed with the 10.6.8 install. Display is working without kext, with a bad resolution (1024x768) and no QE acceleration.

My native resolution is 1280x800.

My laptop is a Toshiba L30-105(PS33).

1002:5a62 ATI RC410 [Radeon Xpress 200M]

Is there a solution ? A kext ? A work around (force my native resolution) ?

Any ideas ?




Extract from System profiler
------------------------------------------------
Display:


Type: GPU
Bus: PCI
VRAM (Total): 3 MB
Vendor: ATI (0x1002)
Device ID: 0x5a62
Revision ID: 0x0000
Kernel Extension Info: No Kext Loaded
Displays:
SwitchResX4 - toshiba:
Resolution: 1024 x 768
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
-------------------------------------------------------------

#2
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,032 posts
  • Gender:Male
Will never work...

#3
zaledar

zaledar

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Male
  • Location:France, Toulouse
I found a kext Callisto Kext "Callisto_b003fixed" and "koverg-patch9700-v0.2". With It now I can work in native screnn resolution but no hardware acceleration QE / CI.

And I follow the html file tutorial in the zip attached to install Callisto kexts :

- Modify device Id
  • vi CallistoHAL.kext/Contents/Info.plist
  • Replace my own PCI device ID with yours under the IOPCIMatch key (5a62 is mine...)
- Clean up display settings
We might need to clean up some of the display settings files, so proceed with the following inside the terminal window:

  • sudo rm -f /Library/Preferences/com.apple.window*

  • rm -f ~/Library/Preferences/ByHost/com.apple.window*

  • rm -f ~/Library/Preferences/ByHost/com.apple.pref*
- Apply koverg-patch9700-v0.2, run sudo ./patch9700.sh

- Launch Kext utility, and reboot


System Profile extract
-----------------------------------------------------------
Radeon XPRESS 200M (PCIE):

Chipset Model: Radeon XPRESS 200M (PCIE)
Type: GPU
Bus: PCI
VRAM (Total): 16 MB
Vendor: ATI (0x1002)
Device ID: 0x5a62
Revision ID: 0x0000
Displays:
Color LCD:
Resolution: 1280 x 800 @ 60 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes
-----------------------------------------------------------

Attached Files



#4
zaledar

zaledar

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
  • Gender:Male
  • Location:France, Toulouse
Any other ideas to make it working with QE ?

#5
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,032 posts
  • Gender:Male

Will never work...







Also tagged with one or more of these keywords: radeon, 200M, Xpress, L30-105, toshiba, Snow leopard


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy