Jump to content

AppleIntelHDGraphicsFB fixed (SL 10.6.8)


  • Please log in to reply
272 replies to this topic

#241
pentothal

pentothal

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

Hey I got it working with mint live cd (i think the problem was that I was using a 64 bit version ) It appears to be working (outputing EDID info)

get-edid: get-edid version 2.0.0

Performing real mode VBE call
Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
Function supported
Call successful

VBE version 300
VBE string at 0x11100 "Intel®Ironlake Mobile Graphics Chipset Accelerated VGA BIOS"

VBE/DDC service about to be called
Report DDC capabilities

Performing real mode VBE call
Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
Function supported
Call successful

Monitor and video card combination does not support DDC1 transfers
Monitor and video card combination supports DDC2 transfers
0 seconds per 128 byte EDID block transfer
Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
Read EDID

Performing real mode VBE call
Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
Function supported
Call failed

The EDID data should not be trusted as the VBE call failed
parse-edid: EDID checksum passed.

# EDID version 0 revision 0
Section "Monitor"
# Block type: 2:0 3:0
# Block type: 2:0 3:0
# Block type: 2:0 3:0
# Block type: 2:0 3:0
Identifier "@@@:0000"
VendorName "@@@"
ModelName "@@@:0000"
# Block type: 2:0 3:0
# Block type: 2:0 3:0
# Block type: 2:0 3:0
# Block type: 2:0 3:0
# DPMS capabilities: Active off:no Suspend:no Standby:no

# Block type: 2:0 3:0
# Block type: 2:0 3:0
# Block type: 2:0 3:0
# Block type: 2:0 3:0


Ok,
thanks for the info. Unfortunately you have my same problem:

Performing real mode VBE call
Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
Function supported
Call failed

The EDID data should not be trusted as the VBE call failed
parse-edid: EDID checksum passed.

Basically your display is not outputting any EDID. Not being able to read any EDID from the hardware OSX cannot pass the info to the framebuffer during boot process. That means the FB doesn't know you have an internal LCD panel. You'll be able to get the EDID from windows registry but that is not a live EDID. The EDID values in the register may have been generated by the graphics drivers or by windows itself.

You can try EDID override following this post:
http://www.insanelym...splay-problems/

or try using CLOVER Bootloader:
http://www.insanelym...2-instructions/

Good luck
Pentothal

#242
stacyk819

stacyk819

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Thanks for the help. Why would using the different bootloader help?

#243
pentothal

pentothal

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

Thanks for the help. Why would using the different bootloader help?

With CLOVER you can try EDID injection hoping the FB picks it up.

<key>InjectEDID</key>
<string>Yes</string>
<key>CustomEDID</key>
<data>CUSTOM EDID HERE</data>

#244
stacyk819

stacyk819

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Also were you able to have any sucess with EDID override? it seems you cant do it without your edid information

Ooh nevemind I got it thank you ill try it out and report back. were you able to get anything working on your laptop

sorry for asking so many questions but what do I enter for my EDID if I cannot find it

#245
pentothal

pentothal

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

Also were you able to have any sucess with EDID override? it seems you cant do it without your edid information

Ooh nevemind I got it thank you ill try it out and report back. were you able to get anything working on your laptop

sorry for asking so many questions but what do I enter for my EDID if I cannot find it

I had no success with EDID override or EDID injection.
To get you EDID try with windows:
Eldim edid viewer
Phoenix edid something
There are many free programs to get your edid.

#246
stacyk819

stacyk819

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Okay ill try that out but isn't the EDID generated by windows and therefore wont work? do you have any idea why we are having the problem did our monitors, It seems to be a toshiba issue

#247
stacyk819

stacyk819

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts

Hello, Good news.
I confirm now we have correct image and QE/CI enabled in our main monitor.

My Notebook:
Intel HD Graphics 0046:8086 Rev 002 (1366x768)
SMBios: MacBookPro6,2
DSDT Graphics Fix (NO)
Natit.kext (Attached)
AppleIntelHDGraphics.kext and AppleIntelHDGraphicsFB.kext (Attached)
AppleIntelHDGraphicsGA.plugin (10.8.2)
AppleIntelHDGraphicsVADriver.bundle (10.8.2)
AppleIntelHDGraphicsGLDriver.bundle (10.8.2)
Resolution Module (YES)

Thanks verteks!!


I tried both solutions with no luck. THe funny thing is that IF i load natit and the appleintelhdgraphicskext here: but no FB I can get to my desktop and acceleration is partially working

Hello, Good news.
I confirm now we have correct image and QE/CI enabled in our main monitor.

My Notebook:
Intel HD Graphics 0046:8086 Rev 002 (1366x768)
SMBios: MacBookPro6,2
DSDT Graphics Fix (NO)
Natit.kext (Attached)
AppleIntelHDGraphics.kext and AppleIntelHDGraphicsFB.kext (Attached)
AppleIntelHDGraphicsGA.plugin (10.8.2)
AppleIntelHDGraphicsVADriver.bundle (10.8.2)
AppleIntelHDGraphicsGLDriver.bundle (10.8.2)
Resolution Module (YES)

Thanks verteks!!


I tried both solutions with no luck. THe funny thing is that IF i load natit and the appleintelhdgraphicskext here: but no FB I can get to my desktop and acceleration is partially working

#248
stacyk819

stacyk819

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Hey so I found this linux utilityto read and write EDID information. I havent tried it yet as I am afraid of messing up my display, But I believe that it can be used to write a good EDID to our displays, either the one provided by windows or another one that We are able to decode. Does anybody have any experience with this utility/ think this is arealistic solutuion

https://github.com/bulletmark/edid-rw

#249
mengrh

mengrh

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
TOS5091 display panel from TOSHIBA Laptop can not be used in ML/Lion, Which was 1366X768x32 . You can use VNC to view the FB kext load status...

#250
stacyk819

stacyk819

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
The frame buffer is loaded( i can see when I access through VNC) but I would like to use my display. Do you have the same laptop? That is my panel, and apparently all/most toshiba panes have problems with linux/os x because they do not output EDID info. Are you sure it will not work even if rewrite the EDID eg: write the EDID from the windows registry to the display using EDID-rw or do you think that will completely mess up my panel

#251
enjiner

enjiner

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Hi Verteks,

Is there any chance for me to get QE fully enabled?
I've tried using kext from this thread but, below are the condition:
- If I install all AppleIntelHDGraphics*.kext, I got kernel panic with "-v" at boot
- Installing Natit.kext + all AppleIntelHDGraphics*.kext except AppleIntelHDGraphics.kext, my Intel Graphic Card was fully detected + CI (I think) , but no QE.

And could you please inform how to use your patch?
I've tried this workaround:
-Copy the AppleIntelHDGraphicsFB (the binary inside the AppleIntelHDGraphics/Content/MacOS/) to hdgraphics_patcher,
-Use this command "./hdgraphics_patcher -p LVDS+VGA AppleIntelHDGraphicsFB",
-Result is "patch success" and what next? Copy the binary "AppleIntelHDGraphics to /System/Library/Extension/AppleIntelHDGraphics.kext/....?
Thanks in advance.


Update:
Finally, I get QE fully enabled.

-Patching the AppleIntelHDGraphics with Verteks pathcer, as pashoni guide, I copy the binary to AppleIntelHDGraphicsFB.kext/Contents/MacOS/ and installing it with other AppleIntelHDGraphics*.kext + Natit.Kext. Problem appear (wheel stop spinning at booting).

-Tried to edit the AppleIntelHDGraphicsFB.kext/Contents/Info.plist become (edit the bold one):

<key>FBCControl</key>
<dict>
<key>Compression</key>
<integer>0</integer>
</dict>
<key>FeatureControl</key>
<dict>
<key>FBC</key>
<integer>0</integer>
<key>GPUInterruptHandling</key>
<integer>0</integer>
<key>Gamma</key>
<integer>0</integer>
<key>MaximumSelfRefreshLevel</key>
<integer>0</integer>
<key>PowerStates</key>
<integer>0</integer>
<key>RSTimerTest</key>
<integer>0</integer>
<key>RenderStandby</key>
<integer>0</integer>
<key>Watermarks</key>
<integer>0</integer>
</dict>
<key>IOClass</key>
<string>AppleIntelHDGraphicsFB</string>
<key>IOMatchCategory</key>
<string>IOFramebuffer</string>
<key>IOPCIClassMatch</key>
<string>0x03000000</string>
<key>IOPCIPrimaryMatch</key>
<string>0x468086</string>


-Rebuild kext with "kextcache -system-prelinked-kernel" and "kextcache -system-caches", and
-Reboot normally....

Thanks to all.

Edited by enjiner, 01 April 2013 - 06:18 PM.


#252
lance76

lance76

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Thank you @enjiner!! your plist edit FINALLY did the trick for me, too! I used the kexts from http://www.insanelym...i/#entry1885544, including the GraphicsFB one and edited THAT plist according to the stuff that enjiner provided. Installed it all via Kext Wizard, did a cache clean/kext rebuild and voila, it works :) So awesome because my lil' Lenovo is the perfect MacBook size! So thanks to everyone for their darn hard work and experimenting, you guys made my week. Or heck my year, lol!

#253
danild

danild

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

<key>IOPCIClassMatch</key>
<string>0x03000000</string>
<key>IOPCIPrimaryMatch</key>
<string>0x468086</string>


It appears that these two values did it in my particular case. I have Dell Inspiron 17R (N7010) with 1st gen Intel HD Graphics card (Device ID: 0x0046, Revision ID: 0x0018) and I have spent COUNTLESS hours pulling my hair out struggling to understand what I was doing wrong and why solutions published here in this thread worked for other folks but do not work for me. Thanks to enjiner, I was able to get fully working QE/CI on my laptop, and I think I'm half way to getting stuff like brightness control and sleep to work now. I can already see display sleep is working as I'm writing this which had never happened before - it's always been a stupid white screen instead.
Thank you SOOOO much, enjiner! Thanks to verteks and to all folks who contributed to this thread!

#254
ebmesnow

ebmesnow

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Hey so I found this linux utilityto read and write EDID information. I havent tried it yet as I am afraid of messing up my display, But I believe that it can be used to write a good EDID to our displays, either the one provided by windows or another one that We are able to decode. Does anybody have any experience with this utility/ think this is arealistic solutuion

https://github.com/bulletmark/edid-rw


I tried it, unfortunately it does not work, my laptop had 8 devices on the i2c bus, number 2 being listed as the 'Panel', if you try a read or write to this or indeed most of the devices it gives an IO error. Devices 6 & 7 were listed as DDC and they did accept the read/write without the IO Error but timed out, assume these are for external displays. Looks like Toshiba don't put the hardware in the display for the EDID.

#255
stacyk819

stacyk819

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
{censored}. maybe we wont have luck editing the EDID on our panels.

Another solution I thought of that might work for us is to patch the FB usings LVDS+ VGA and using two edid overwrites. some people with toshiba laptops (but without HD 1000) have had luck with this method.

This would require some trouble shooting (eg: you might need to patch the FB a few different ways before finding a working solution)

check out these threads and see if you are able to make any progress.

http://www.insanelym...-hdmi-out-only/
http://www.tonymacx8...35-z835-ok.html

#256
baongoc124

baongoc124

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hi verteks,
I used your patched (LVDS + VGA) and it works wonderful in my internal monitor. But when I switch to VGA monitor, everything looks like {censored}.
Note that System -> Preferences -> Display doesn't detect my second monitor. I switch to it using the key on keyboard.

Do you have know how to solve this problem?
Thank you very much!

#257
2bad0

2bad0

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
Here's kexts from 10.8.4 dev try it out at your own risk or reward has not been patched still vanilla so patch it yourself.
If flash video is black disable graphics acceleration of chrome/chromium.

http://www.insanelym...ttach_id=122764

#258
TheRacerMaster

TheRacerMaster

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male

Hi verteks! GREAT JOB!!!
The kexts work very well on my G62-b13SL: i used, as the other ones, Natit and the framebuffer.
But like mnorthern:

i got same problems.

Anyway, it's a big step forward.

Here are some photos:
Posted Image
As you can see, I've injected the EDID, and I managed to get it similar to a real MacBook (that have Color LCD).

Posted Image
I have the switchable graphics: ATI Radeon HD 5470M and (obviously) Intel HD Graphics. As you can see, there are two Intel HD Graphics and the PCIe was the HD 5470M.
There is also the HDMI audio output from the discrete card.



giofrida, what kexts did you use to make this happen? I am currently using the stock Mountain Lion 10.8.3 kexts, plus a framebuffer patch for DualLink (I have a 17" 1600x900 monitor), default length, and LVDS and VGA ports. No other kexts or DSDT patches. And I get this in System Info:
Posted ImagePosted Image
However, I do have a transparent menu bar, and everything seems to work (it's just a bit laggy sometimes). And in the OpenGL Extensions Viewer, it shows this: Posted Image
Do you know of any way to fix this and make it show like it does in your screenshot?

#259
dictionaryaccount

dictionaryaccount

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
  • Gender:Female
I would appreciate any help on getting the framebuffer working.
My CPU is i3-550, so it obviously has Ironlake graphics.

The system boots with Intel HD graphics kexts (excluding framebuffer) and Natit, but there is no QE/CI and the kexts don't actually get loaded (according to kextstat).

I tried patching vanilla 10.8.3 framebuffer kext with DualLink and LVDS options (my native resolution is 1920x1080 on an external display connected via DVI). Whenever I try booting with it, the kexts get loaded but I either have gray or black screen. I also tried switching length from X1 to X4, there was no positive result. The integers in Info.plist are set to 0.

I use Clover to boot OS X 10.8.3 with no DSDT patches. GraphicsInjector is enabled.

Here is the output of intel_reg_dumper:

user@debian:/live/image/intelt/bin$ sudo ./intel_reg_dumper
PGETBL_CTL: 0x00000008
GEN6_INSTDONE_1: 0xfffffffe
GEN6_INSTDONE_2: 0xffffffff
CPU_VGACNTRL: 0x8020298e (disabled)
DIGITAL_PORT_HOTPLUG_CNTRL: 0x00000000
RR_HW_CTL: 0x00000000 (low 0, high 0)
FDI_PLL_BIOS_0: 0x082b3019
FDI_PLL_BIOS_1: 0x00000000
FDI_PLL_BIOS_2: 0x00000000
DISPLAY_PORT_PLL_BIOS_0: 0x0807012b
DISPLAY_PORT_PLL_BIOS_1: 0x00000000
DISPLAY_PORT_PLL_BIOS_2: 0x00000000
FDI_PLL_FREQ_CTL: 0x00053687
PIPEACONF: 0xc0000000 (enabled, active, pf-pd, rotate 0, 8bpc)
HTOTAL_A: 0x086f063f (1600 active, 2160 total)
HBLANK_A: 0x086f063f (1600 start, 2160 end)
HSYNC_A: 0x073f067f (1664 start, 1856 end)
VTOTAL_A: 0x04e104af (1200 active, 1250 total)
VBLANK_A: 0x04e104af (1200 start, 1250 end)
VSYNC_A: 0x04b304b0 (1201 start, 1204 end)
VSYNCSHIFT_A: 0x00000000
PIPEASRC: 0x063f04af (1600, 1200)
PIPEA_DATA_M1: 0x7e399999 (TU 64, val 0x399999 3774873)
PIPEA_DATA_N1: 0x00800000 (val 0x800000 8388608)
PIPEA_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
PIPEA_DATA_N2: 0x00000000 (val 0x0 0)
PIPEA_LINK_M1: 0x0004cccc (val 0x4cccc 314572)
PIPEA_LINK_N1: 0x00080000 (val 0x80000 524288)
PIPEA_LINK_M2: 0x00000000 (val 0x0 0)
PIPEA_LINK_N2: 0x00000000 (val 0x0 0)
DSPACNTR: 0x98000000 (enabled)
DSPABASE: 0x00000000
DSPASTRIDE: 0x00001900 (100)
DSPASURF: 0x00000000
DSPATILEOFF: 0x00000000 (0, 0)
PIPEBCONF: 0x00000000 (disabled, inactive, pf-pd, rotate 0, 8bpc)
HTOTAL_B: 0x031f027f (640 active, 800 total)
HBLANK_B: 0x03170287 (648 start, 792 end)
HSYNC_B: 0x02ef028f (656 start, 752 end)
VTOTAL_B: 0x020c01df (480 active, 525 total)
VBLANK_B: 0x020401e7 (488 start, 517 end)
VSYNC_B: 0x01eb01e9 (490 start, 492 end)
VSYNCSHIFT_B: 0x00000000
PIPEBSRC: 0x027f01df (640, 480)
PIPEB_DATA_M1: 0x00000000 (TU 1, val 0x0 0)
PIPEB_DATA_N1: 0x00000000 (val 0x0 0)
PIPEB_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
PIPEB_DATA_N2: 0x00000000 (val 0x0 0)
PIPEB_LINK_M1: 0x00000000 (val 0x0 0)
PIPEB_LINK_N1: 0x00000000 (val 0x0 0)
PIPEB_LINK_M2: 0x00000000 (val 0x0 0)
PIPEB_LINK_N2: 0x00000000 (val 0x0 0)
DSPBCNTR: 0x00000000 (disabled)
DSPBBASE: 0x00000000
DSPBSTRIDE: 0x00000000 (0)
DSPBSURF: 0x00000000
DSPBTILEOFF: 0x00000000 (0, 0)
PIPECCONF: 0x00000000 (disabled, inactive, pf-pd, rotate 0, 8bpc)
HTOTAL_C: 0x00000000 (1 active, 1 total)
HBLANK_C: 0x00000000 (1 start, 1 end)
HSYNC_C: 0x00000000 (1 start, 1 end)
VTOTAL_C: 0x00000000 (1 active, 1 total)
VBLANK_C: 0x00000000 (1 start, 1 end)
VSYNC_C: 0x00000000 (1 start, 1 end)
VSYNCSHIFT_C: 0x00000000
PIPECSRC: 0x00000000 (1, 1)
PIPEC_DATA_M1: 0x00000000 (TU 1, val 0x0 0)
PIPEC_DATA_N1: 0x00000000 (val 0x0 0)
PIPEC_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
PIPEC_DATA_N2: 0x00000000 (val 0x0 0)
PIPEC_LINK_M1: 0x00000000 (val 0x0 0)
PIPEC_LINK_N1: 0x00000000 (val 0x0 0)
PIPEC_LINK_M2: 0x00000000 (val 0x0 0)
PIPEC_LINK_N2: 0x00000000 (val 0x0 0)
DSPCCNTR: 0x00000000 (disabled)
DSPCBASE: 0x00000000
DSPCSTRIDE: 0x00000000 (0)
DSPCSURF: 0x00000000
DSPCTILEOFF: 0x00000000 (0, 0)
PFA_CTL_1: 0x80800000 (enable, auto_scale yes, auto_scale_cal no, v_filter enable, vadapt disable, mode least, filter_sel hardcoded,chroma pre-filter disable, vert3tap auto, v_inter_invert field 1)
PFA_CTL_2: 0x00008000 (vscale 1.000000)
PFA_CTL_3: 0x00004000 (vscale initial phase 0.500000)
PFA_CTL_4: 0x00008000 (hscale 1.000000)
PFA_WIN_POS: 0x00000000 (0, 0)
PFA_WIN_SIZE: 0x064004b0 (1600, 1200)
PFB_CTL_1: 0x00000000 (disable, auto_scale yes, auto_scale_cal no, v_filter enable, vadapt disable, mode least, filter_sel programmed,chroma pre-filter disable, vert3tap auto, v_inter_invert field 1)
PFB_CTL_2: 0x00000000 (vscale 0.000000)
PFB_CTL_3: 0x00000000 (vscale initial phase 0.000000)
PFB_CTL_4: 0x00000000 (hscale 0.000000)
PFB_WIN_POS: 0x00000000 (0, 0)
PFB_WIN_SIZE: 0x00000000 (0, 0)
PFC_CTL_1: 0x00000000 (disable, auto_scale yes, auto_scale_cal no, v_filter enable, vadapt disable, mode least, filter_sel programmed,chroma pre-filter disable, vert3tap auto, v_inter_invert field 1)
PFC_CTL_2: 0x00000000 (vscale 0.000000)
PFC_CTL_3: 0x00000000 (vscale initial phase 0.000000)
PFC_CTL_4: 0x00000000 (hscale 0.000000)
PFC_WIN_POS: 0x00000000 (0, 0)
PFC_WIN_SIZE: 0x00000000 (0, 0)
PCH_DREF_CONTROL: 0x00000400 (cpu source disable, ssc_source disable, nonspread_source enable, superspread_source disable, ssc4_mode downspread, ssc1 disable, ssc4 disable)
PCH_RAWCLK_FREQ: 0x0000007d (FDL_TP1 timer 0.5us, FDL_TP2 timer 1.5us, freq 125)
PCH_DPLL_TMR_CFG: 0x0271186a
PCH_SSC4_PARMS: 0x00000000
PCH_SSC4_AUX_PARMS: 0x00000000
PCH_DPLL_SEL: 0x00000000 (FDL_TP1 timer 0.5us, FDL_TP2 timer 1.5us, freq 125)
PCH_DPLL_ANALOG_CTL: 0x00008000
PCH_DPLL_A: 0xc4020002 (enable, sdvo high speed yes, mode (null), p2 (null), FPA0 P1 2, FPA1 P1 2, refclk default 120Mhz, sdvo/hdmi mul 1)
PCH_DPLL_B: 0x04800080 (disable, sdvo high speed no, mode (null), p2 (null), FPA0 P1 8, FPA1 P1 8, refclk default 120Mhz, sdvo/hdmi mul 1)
PCH_FPA0: 0x00010c09 (n = 1, m1 = 12, m2 = 9)
PCH_FPA1: 0x00030d07 (n = 3, m1 = 13, m2 = 7)
PCH_FPB0: 0x00030d07 (n = 3, m1 = 13, m2 = 7)
PCH_FPB1: 0x00030d07 (n = 3, m1 = 13, m2 = 7)
TRANS_HTOTAL_A: 0x086f063f (1600 active, 2160 total)
TRANS_HBLANK_A: 0x086f063f (1600 start, 2160 end)
TRANS_HSYNC_A: 0x073f067f (1664 start, 1856 end)
TRANS_VTOTAL_A: 0x04e104af (1200 active, 1250 total)
TRANS_VBLANK_A: 0x04e104af (1200 start, 1250 end)
TRANS_VSYNC_A: 0x04b304b0 (1201 start, 1204 end)
TRANS_VSYNCSHIFT_A: 0x00000000
TRANSA_DATA_M1: 0x00000000 (TU 1, val 0x0 0)
TRANSA_DATA_N1: 0x00000000 (val 0x0 0)
TRANSA_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
TRANSA_DATA_N2: 0x00000000 (val 0x0 0)
TRANSA_DP_LINK_M1: 0x00000000 (val 0x0 0)
TRANSA_DP_LINK_N1: 0x00000000 (val 0x0 0)
TRANSA_DP_LINK_M2: 0x00000000 (val 0x0 0)
TRANSA_DP_LINK_N2: 0x00000000 (val 0x0 0)
TRANS_HTOTAL_B: 0x031f027f (640 active, 800 total)
TRANS_HBLANK_B: 0x03170287 (648 start, 792 end)
TRANS_HSYNC_B: 0x02ef028f (656 start, 752 end)
TRANS_VTOTAL_B: 0x020c01df (480 active, 525 total)
TRANS_VBLANK_B: 0x020401e7 (488 start, 517 end)
TRANS_VSYNC_B: 0x01eb01e9 (490 start, 492 end)
TRANS_VSYNCSHIFT_B: 0x00000000
TRANSB_DATA_M1: 0x00000000 (TU 1, val 0x0 0)
TRANSB_DATA_N1: 0x00000000 (val 0x0 0)
TRANSB_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
TRANSB_DATA_N2: 0x00000000 (val 0x0 0)
TRANSB_DP_LINK_M1: 0x00000000 (val 0x0 0)
TRANSB_DP_LINK_N1: 0x00000000 (val 0x0 0)
TRANSB_DP_LINK_M2: 0x00000000 (val 0x0 0)
TRANSB_DP_LINK_N2: 0x00000000 (val 0x0 0)
TRANS_HTOTAL_C: 0x00000000 (1 active, 1 total)
TRANS_HBLANK_C: 0x00000000 (1 start, 1 end)
TRANS_HSYNC_C: 0x00000000 (1 start, 1 end)
TRANS_VTOTAL_C: 0x00000000 (1 active, 1 total)
TRANS_VBLANK_C: 0x00000044 (69 start, 1 end)
TRANS_VSYNC_C: 0x00000000 (1 start, 1 end)
TRANS_VSYNCSHIFT_C: 0x00000000
TRANSC_DATA_M1: 0x00000000 (TU 1, val 0x0 0)
TRANSC_DATA_N1: 0x00000000 (val 0x0 0)
TRANSC_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
TRANSC_DATA_N2: 0x00000000 (val 0x0 0)
TRANSC_DP_LINK_M1: 0x00000000 (val 0x0 0)
TRANSC_DP_LINK_N1: 0x00000000 (val 0x0 0)
TRANSC_DP_LINK_M2: 0x00000000 (val 0x0 0)
TRANSC_DP_LINK_N2: 0x00ffffff (val 0xffffff 16777215)
TRANSACONF: 0xc0000000 (enable, active, progressive)
TRANSBCONF: 0x00000000 (disable, inactive, progressive)
TRANSCCONF: 0x00000000 (disable, inactive, progressive)
FDI_TXA_CTL: 0xb01c4000 (enable, train pattern not train, voltage swing 0.4V,pre-emphasis none, port width X4, enhanced framing enable, FDI PLL enable, scrambing enable, master mode disable)
FDI_TXB_CTL: 0x00044000 (disable, train pattern pattern_1, voltage swing 0.4V,pre-emphasis none, port width X1, enhanced framing enable, FDI PLL enable, scrambing enable, master mode disable)
FDI_TXC_CTL: 0x00000000 (disable, train pattern pattern_1, voltage swing 0.4V,pre-emphasis none, port width X1, enhanced framing disable, FDI PLL disable, scrambing enable, master mode disable)
FDI_RXA_CTL: 0xb0182050 (enable, train pattern not train, port width X4, 8bpc,link_reverse_strap_overwrite no, dmi_link_reverse no, FDI PLL enable,FS ecc disable, FE ecc disable, FS err report disable, FE err report disable,scrambing enable, enhanced framing enable, PCDClk)
FDI_RXB_CTL: 0x00000040 (disable, train pattern pattern_1, port width X1, 8bpc,link_reverse_strap_overwrite no, dmi_link_reverse no, FDI PLL disable,FS ecc disable, FE ecc disable, FS err report disable, FE err report disable,scrambing enable, enhanced framing enable, RawClk)
FDI_RXC_CTL: 0x00000000 (disable, train pattern pattern_1, port width X1, 8bpc,link_reverse_strap_overwrite no, dmi_link_reverse no, FDI PLL disable,FS ecc disable, FE ecc disable, FS err report disable, FE err report disable,scrambing enable, enhanced framing disable, RawClk)
FDI_RXA_MISC: 0x00000080 (FDI Delay 128)
FDI_RXB_MISC: 0x00000080 (FDI Delay 128)
FDI_RXC_MISC: 0x00000000 (FDI Delay 0)
FDI_RXA_TUSIZE1: 0x7e000000
FDI_RXA_TUSIZE2: 0x7e000000
FDI_RXB_TUSIZE1: 0x7e000000
FDI_RXB_TUSIZE2: 0x7e000000
FDI_RXC_TUSIZE1: 0x00000000
FDI_RXC_TUSIZE2: 0x00000000
FDI_PLL_CTL_1: 0x33505248
FDI_PLL_CTL_2: 0x00000000
FDI_RXA_IIR: 0x00000600
FDI_RXA_IMR: 0x000000ff
FDI_RXB_IIR: 0x00000000
FDI_RXB_IMR: 0x000000ff
PCH_ADPA: 0x00c00018 (disabled, transcoder A, +hsync, +vsync)
HDMIB: 0x00000018 (disabled pipe A 8bpc SDVO DVI audio disabled +vsync +hsync non-detected)
HDMIC: 0x8000001c (enabled pipe A 8bpc SDVO DVI audio disabled +vsync +hsync detected)
HDMID: 0x0000001c (disabled pipe A 8bpc SDVO DVI audio disabled +vsync +hsync detected)
PCH_LVDS: 0x40000000 (disabled, pipe B, 18 bit, 1 channel)
CPU_eDP_A: 0x00000018
PCH_DP_B: 0x00000018
PCH_DP_C: 0x0000001c
PCH_DP_D: 0x0000001c
TRANS_DP_CTL_A: 0x00000000 (disabled, pipe B, 18 bit, 1 channel)
TRANS_DP_CTL_B: 0x00000000 (disabled, pipe B, 18 bit, 1 channel)
TRANS_DP_CTL_C: 0x00000000 (disabled, pipe B, 18 bit, 1 channel)
BLC_PWM_CPU_CTL2: 0x00000000
BLC_PWM_CPU_CTL: 0x00000000
BLC_PWM_PCH_CTL1: 0x00000000
BLC_PWM_PCH_CTL2: 0x00000000
PCH_PP_STATUS: 0x00000000 (off, not ready, sequencing idle)
PCH_PP_CONTROL: 0x00000000 (blacklight disabled, do not power down on reset, panel off)
PCH_PP_ON_DELAYS: 0x00000000
PCH_PP_OFF_DELAYS: 0x00000000
PCH_PP_DIVISOR: 0x00186904
PORT_DBG: 0x00000000 (HW DRRS off)
RC6_RESIDENCY_TIME: 0xffffffff
RC6p_RESIDENCY_TIME: 0xffffffff
RC6pp_RESIDENCY_TIME: 0xffffffff



#260
2bad0

2bad0

    InsanelyMac Protégé

  • Members
  • PipPip
  • 68 posts
I'm assuming by external monitor you're on a desktop Lvds is for laptops you need to patch for dvi or vga .If that fails there are some other os info's on another forum post .Try to find it.


There you go read though this.
http://www.insanelym...on-lenovo-x201/





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy