Jump to content

AppleIntelHDGraphicsFB fixed (SL 10.6.8)


  • Please log in to reply
272 replies to this topic

#221
GhostRaider

GhostRaider

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 350 posts
  • Gender:Male

Hi Ghostrider,
I connected to my hackintosh using VNC. I noticed the screen is not detected and only intelhdgraphics and intelhdgrapicsFB are loaded. I used the sinle link and dual link FB patch (LVDS) with the same result. Like you I had the forever spinning wheel if I had not natit installed. I was anyway able to connect via VNC. With natit installed the spinning wheel and the apple logo disappeared after a few seconds and the screen was whitish.

I attach a zip file with screenshots and ioregistry. Maybe you can have a look and tell me what you think.

Thanks in advance
Pentothal


From what I've seen, you used natit and both Intel HD Graphics kexts loaded right? However there is a screenshot where it says no display. That is not a good sign...

#222
pentothal

pentothal

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

From what I've seen, you used natit and both Intel HD Graphics kexts loaded right? However there is a screenshot where it says no display. That is not a good sign...


Yes, I used Natit and both Intel HD Graphics loaded. Hmmmm bad news. I've found out something strange in the registry. My panel is identified as AppleDisplay (usually this is the name for external displays) and not as AppleBacklightDisplay as it should be. Any ideas?

Regards
Pentothal

#223
mnorthern

mnorthern

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
  • Gender:Male
  • Location:London, United Kingdom
Does anyone have any of the following problems... Take a picture that's big but not too big (say 1280 x 1024) and open it in Preview app. Try making color adjustments through Adjust Colour. I am suffering terrible lag with simple stuff like Highlights and Shadows. And if I try to adjust Sharpness to make it look softer, the whole picture disappears. Is this normal ?

Also, do I understand correctly.. to enable the shell screen saver, I need to update to 10.8.3 ?

#224
2bad0

2bad0

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts

Yes, I used Natit and both Intel HD Graphics loaded. Hmmmm bad news. I've found out something strange in the registry. My panel is identified as AppleDisplay (usually this is the name for external displays) and not as AppleBacklightDisplay as it should be. Any ideas?

Regards
Pentothal


Hey try going through this, this guy did lots of experimenting with intelhd and display panels.

http://www.insanelym.../232968-hp-g72/

#225
giofrida

giofrida

    InsanelyMac Italy

  • Members
  • PipPipPipPipPipPipPip
  • 658 posts
  • Gender:Male
  • Location:Italy

Does anyone have any of the following problems... Take a picture that's big but not too big (say 1280 x 1024) and open it in Preview app. Try making color adjustments through Adjust Colour. I am suffering terrible lag with simple stuff like Highlights and Shadows. And if I try to adjust Sharpness to make it look softer, the whole picture disappears. Is this normal ?

Also, do I understand correctly.. to enable the shell screen saver, I need to update to 10.8.3 ?


I didn't try that. If you just play with the widgets the lag comes out! The GPU temperature? 70°C

#226
2bad0

2bad0

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts

I didn't try that. If you just play with the widgets the lag comes out! The GPU temperature? 70°C


What do you use to check gpu temps on osx?

#227
giofrida

giofrida

    InsanelyMac Italy

  • Members
  • PipPipPipPipPipPipPip
  • 658 posts
  • Gender:Male
  • Location:Italy

What do you use to check gpu temps on osx?


IntelCPUMonitor for CPU and RadeonX for GPU (maybe because I have an ATi card on my pc, anyway after a reboot I found 'GPU Diode'.. seems Intel HD Graphics). Check the 'FakeSMC 4.2 Download' topic on projectosx.com.

#228
2bad0

2bad0

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts

IntelCPUMonitor for CPU and RadeonX for GPU (maybe because I have an ATi card on my pc, anyway after a reboot I found 'GPU Diode'.. seems Intel HD Graphics). Check the 'FakeSMC 4.2 Download' topic on projectosx.com.


Yup could be the ati, have tried lots of different fakesmc never seemed to detect gpu not that i was to interested anyway :(

Since cpu and gpu are on the same die it would almost make sense for them to be nearly same temp.

#229
giofrida

giofrida

    InsanelyMac Italy

  • Members
  • PipPipPipPipPipPipPip
  • 658 posts
  • Gender:Male
  • Location:Italy

Yup could be the ati, have tried lots of different fakesmc never seemed to detect gpu not that i was to interested anyway :(

Since cpu and gpu are on the same die it would almost make sense for them to be nearly same temp.


Or the name 'GPU Diode' is wrong, or it refers to the Intel HD Graphics, because the ATI card is not integrated. I think the Intel HD Graphics sensor sends info through the ATI card. Anyway i cannot use this dedicated card :( so i don't understand why the temps are so high (if the sensor refers to the ATi card).

Any news about the weird sound from the GPU? And about the low performance?

#230
2bad0

2bad0

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts

Or the name 'GPU Diode' is wrong, or it refers to the Intel HD Graphics, because the ATI card is not integrated. I think the Intel HD Graphics sensor sends info through the ATI card. Anyway i cannot use this dedicated card :( so i don't understand why the temps are so high (if the sensor refers to the ATi card).

Any news about the weird sound from the GPU? And about the low performance?


Not to sure, you think if you remove ati kext it wont get activated?

#231
giofrida

giofrida

    InsanelyMac Italy

  • Members
  • PipPipPipPipPipPipPip
  • 658 posts
  • Gender:Male
  • Location:Italy

Not to sure, you think if you remove ati kext it wont get activated?


If I remove RadeonX i cannot see the GPU Diode temps anymore.. that's it.

#232
2bad0

2bad0

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts

If I remove RadeonX i cannot see the GPU Diode temps anymore.. that's it.


No No i meant the Ati kext responsible for ....radeon acceleration

or some dsdt string to disable activation of the ati gfx....

And while your'e @ it whats the temps of your cpu.

#233
GhostRaider

GhostRaider

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 350 posts
  • Gender:Male

Yes, I used Natit and both Intel HD Graphics loaded. Hmmmm bad news. I've found out something strange in the registry. My panel is identified as AppleDisplay (usually this is the name for external displays) and not as AppleBacklightDisplay as it should be. Any ideas?

Regards
Pentothal


I just find it odd that your internal monitor does not output any EDID information. I understand you even had trouble using the resolution module. Have you tried Clover instead of Chameleon? Maybe you can inject EDID? That way maybe the framebuffer can pick up something.

Does anyone have any of the following problems... Take a picture that's big but not too big (say 1280 x 1024) and open it in Preview app. Try making color adjustments through Adjust Colour. I am suffering terrible lag with simple stuff like Highlights and Shadows. And if I try to adjust Sharpness to make it look softer, the whole picture disappears. Is this normal ?

Also, do I understand correctly.. to enable the shell screen saver, I need to update to 10.8.3 ?


Images don't disappear on mine if I play with Sharpness. And the lag, well its not really noticeable. Everything seems normal on 10.8.3.

#234
red555

red555

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Does anyone have any of the following problems... Take a picture that's big but not too big (say 1280 x 1024) and open it in Preview app. Try making color adjustments through Adjust Colour. I am suffering terrible lag with simple stuff like Highlights and Shadows. And if I try to adjust Sharpness to make it look softer, the whole picture disappears. Is this normal ?


Not normal.

I get it too, extremely poor GPU performance in some apps, like this one and mainstage, along with electrical noise.

Does everyone get this?>

#235
giofrida

giofrida

    InsanelyMac Italy

  • Members
  • PipPipPipPipPipPipPip
  • 658 posts
  • Gender:Male
  • Location:Italy

No No i meant the Ati kext responsible for ....radeon acceleration

or some dsdt string to disable activation of the ati gfx....

And while your'e @ it whats the temps of your cpu.



If I remove the kexts I don't know what it will happen (maybe nothing, changes only something in IOReg) and I don't know how to disable it via DSDT (there are guides only for Nvidia Optimus).
I put '@' after the CPU to add the clock. I've not overclocked it :)

I just find it odd that your internal monitor does not output any EDID information. I understand you even had trouble using the resolution module. Have you tried Clover instead of Chameleon? Maybe you can inject EDID? That way maybe the framebuffer can pick up something.



Images don't disappear on mine if I play with Sharpness. And the lag, well its not really noticeable. Everything seems normal on 10.8.3.


Lag not noticeable?? Sorry but I also have a GMA X3100 with a Core 2 Duo and it works better than the Intel HD Graphics (with an i3)..

#236
stacyk819

stacyk819

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Hi,
First of all thank you for your work, its awesome that you were able to get this working.

I have been trying to get this working for about two weeks on my own and haven't had any luck and i'm going crazy.

I have a toshiba laptop model r700-s1331

One thing different about my laptop is that my processor is an i7-620m which nobody else seems to have (but was used in the macbook pro 6,2)

My reg dump from linux shows that the default settings should work fine (link width x=1, lvds, single link) but I am having so much trouble with the frame buffer.

I am on 10.8.3 but have tried to figure this out on 10.8 and 10.8.2 without any luck

WHen I try to load the frame buffer I get a grey screen and the computer shuts off (with natit, without wheel spins forever). Someone suggested that this might be an issue with cpu power management but I think I figured that out and it still doesn't work.

When I load Natit (alone, no appleintelhd or fb) it shows up as intel graphics with 128 mb but there is no ci/qe and I cannot get custom resolution.

I have tried too many combinations of kexts to list now but basically my issue is when I try to load the frame buffer I can provide more info if needed. please help me Im going crazy

#237
pentothal

pentothal

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

Hi,
First of all thank you for your work, its awesome that you were able to get this working.

I have been trying to get this working for about two weeks on my own and haven't had any luck and i'm going crazy.

I have a toshiba laptop model r700-s1331

One thing different about my laptop is that my processor is an i7-620m which nobody else seems to have (but was used in the macbook pro 6,2)

My reg dump from linux shows that the default settings should work fine (link width x=1, lvds, single link) but I am having so much trouble with the frame buffer.

I am on 10.8.3 but have tried to figure this out on 10.8 and 10.8.2 without any luck

WHen I try to load the frame buffer I get a grey screen and the computer shuts off (with natit, without wheel spins forever). Someone suggested that this might be an issue with cpu power management but I think I figured that out and it still doesn't work.

When I load Natit (alone, no appleintelhd or fb) it shows up as intel graphics with 128 mb but there is no ci/qe and I cannot get custom resolution.

I have tried too many combinations of kexts to list now but basically my issue is when I try to load the frame buffer I can provide more info if needed. please help me Im going crazy


Hi stacyk819,
I've got a Toshiba laptop too (Satellite PRO S500) and I have your same problem. There's no way I can get the FB working on my system. Please run this on Linux (live CD/DVD/USB) and post the output:

$> sudo apt-get update && sudo apt-get install read-edid
$> sudo get-edid | parse-edid

Let's see if your panel is not outputting any EDID info like mine.

Cheers
Pentothal

#238
stacyk819

stacyk819

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Heres my reg dump:
ubuntu@ubuntu:~$ sudo intel_reg_dumper
PGETBL_CTL: 0x00000008
GEN6_INSTDONE_1: 0xfffffffe
GEN6_INSTDONE_2: 0xffffffff
CPU_VGACNTRL: 0x80000000 (disabled)
DIGITAL_PORT_HOTPLUG_CNTRL: 0x00000000
RR_HW_CTL: 0x00000000 (low 0, high 0)
FDI_PLL_BIOS_0: 0x082b3019
FDI_PLL_BIOS_1: 0x00000000
FDI_PLL_BIOS_2: 0x00000000
DISPLAY_PORT_PLL_BIOS_0: 0x0807012b
DISPLAY_PORT_PLL_BIOS_1: 0x00000000
DISPLAY_PORT_PLL_BIOS_2: 0x00000000
FDI_PLL_FREQ_CTL: 0x00053687
PIPEACONF: 0xc0000050 (enabled, active, pf-pd, rotate 0, 6bpc)
HTOTAL_A: 0x06680555 (1366 active, 1641 total)
HBLANK_A: 0x06680555 (1366 start, 1641 end)
HSYNC_A: 0x05e80578 (1401 start, 1513 end)
VTOTAL_A: 0x030b02ff (768 active, 780 total)
VBLANK_A: 0x030b02ff (768 start, 780 end)
VSYNC_A: 0x03020300 (769 start, 771 end)
VSYNCSHIFT_A: 0x00000000
PIPEASRC: 0x055502ff (1366, 768)
PIPEA_DATA_M1: 0x7e152610 (TU 64, val 0x152610 1386000)
PIPEA_DATA_N1: 0x0020f580 (val 0x20f580 2160000)
PIPEA_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
PIPEA_DATA_N2: 0x00000000 (val 0x0 0)
PIPEA_LINK_M1: 0x00012cc8 (val 0x12cc8 77000)
PIPEA_LINK_N1: 0x00041eb0 (val 0x41eb0 270000)
PIPEA_LINK_M2: 0x00000000 (val 0x0 0)
PIPEA_LINK_N2: 0x00000000 (val 0x0 0)
DSPACNTR: 0xd8004400 (enabled)
DSPABASE: 0x00000000
DSPASTRIDE: 0x00001600 (88)
DSPASURF: 0x0044b000
DSPATILEOFF: 0x00000000 (0, 0)
PIPEBCONF: 0x00000000 (disabled, inactive, pf-pd, rotate 0, 8bpc)
HTOTAL_B: 0x00000000 (1 active, 1 total)
HBLANK_B: 0x00000000 (1 start, 1 end)
HSYNC_B: 0x00000000 (1 start, 1 end)
VTOTAL_B: 0x00000000 (1 active, 1 total)
VBLANK_B: 0x00000000 (1 start, 1 end)
VSYNC_B: 0x00000000 (1 start, 1 end)
VSYNCSHIFT_B: 0x00000000
PIPEBSRC: 0x00000000 (1, 1)
PIPEB_DATA_M1: 0x00000000 (TU 1, val 0x0 0)
PIPEB_DATA_N1: 0x00000000 (val 0x0 0)
PIPEB_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
PIPEB_DATA_N2: 0x00000000 (val 0x0 0)
PIPEB_LINK_M1: 0x00000000 (val 0x0 0)
PIPEB_LINK_N1: 0x00000000 (val 0x0 0)
PIPEB_LINK_M2: 0x00000000 (val 0x0 0)
PIPEB_LINK_N2: 0x00000000 (val 0x0 0)
DSPBCNTR: 0x00000000 (disabled)
DSPBBASE: 0x00000000
DSPBSTRIDE: 0x00000000 (0)
DSPBSURF: 0x00000000
DSPBTILEOFF: 0x00000000 (0, 0)
PIPECCONF: 0x00000000 (disabled, inactive, pf-pd, rotate 0, 8bpc)
HTOTAL_C: 0x00000000 (1 active, 1 total)
HBLANK_C: 0x00000000 (1 start, 1 end)
HSYNC_C: 0x00000000 (1 start, 1 end)
VTOTAL_C: 0x00000000 (1 active, 1 total)
VBLANK_C: 0x00000000 (1 start, 1 end)
VSYNC_C: 0x00000000 (1 start, 1 end)
VSYNCSHIFT_C: 0x00000000
PIPECSRC: 0x00000000 (1, 1)
PIPEC_DATA_M1: 0x00000000 (TU 1, val 0x0 0)
PIPEC_DATA_N1: 0x00000000 (val 0x0 0)
PIPEC_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
PIPEC_DATA_N2: 0x00000000 (val 0x0 0)
PIPEC_LINK_M1: 0x00000000 (val 0x0 0)
PIPEC_LINK_N1: 0x00000000 (val 0x0 0)
PIPEC_LINK_M2: 0x00000000 (val 0x0 0)
PIPEC_LINK_N2: 0x00000000 (val 0x0 0)
DSPCCNTR: 0x00000000 (disabled)
DSPCBASE: 0x00000000
DSPCSTRIDE: 0x00000000 (0)
DSPCSURF: 0x00000000
DSPCTILEOFF: 0x00000000 (0, 0)
PFA_CTL_1: 0x00000000 (disable, auto_scale yes, auto_scale_cal no, v_filter enable, vadapt disable, mode least, filter_sel programmed,chroma pre-filter disable, vert3tap auto, v_inter_invert field 1)
PFA_CTL_2: 0x00007e80 (vscale 0.988281)
PFA_CTL_3: 0x00003f40 (vscale initial phase 0.494141)
PFA_CTL_4: 0x00007d54 (hscale 0.979126)
PFA_WIN_POS: 0x00000000 (0, 0)
PFA_WIN_SIZE: 0x00000000 (0, 0)
PFB_CTL_1: 0x00000000 (disable, auto_scale yes, auto_scale_cal no, v_filter enable, vadapt disable, mode least, filter_sel programmed,chroma pre-filter disable, vert3tap auto, v_inter_invert field 1)
PFB_CTL_2: 0x00000000 (vscale 0.000000)
PFB_CTL_3: 0x00000000 (vscale initial phase 0.000000)
PFB_CTL_4: 0x00000000 (hscale 0.000000)
PFB_WIN_POS: 0x00000000 (0, 0)
PFB_WIN_SIZE: 0x00000000 (0, 0)
PFC_CTL_1: 0x00000000 (disable, auto_scale yes, auto_scale_cal no, v_filter enable, vadapt disable, mode least, filter_sel programmed,chroma pre-filter disable, vert3tap auto, v_inter_invert field 1)
PFC_CTL_2: 0x00000000 (vscale 0.000000)
PFC_CTL_3: 0x00000000 (vscale initial phase 0.000000)
PFC_CTL_4: 0x00000000 (hscale 0.000000)
PFC_WIN_POS: 0x00000000 (0, 0)
PFC_WIN_SIZE: 0x00000000 (0, 0)
PCH_DREF_CONTROL: 0x00001400 (cpu source disable, ssc_source enable, nonspread_source enable, superspread_source disable, ssc4_mode downspread, ssc1 disable, ssc4 disable)
PCH_RAWCLK_FREQ: 0x0000007d (FDL_TP1 timer 0.5us, FDL_TP2 timer 1.5us, freq 125)
PCH_DPLL_TMR_CFG: 0x0271186a
PCH_SSC4_PARMS: 0x00000000
PCH_SSC4_AUX_PARMS: 0x00000000
PCH_DPLL_SEL: 0x00000000 (FDL_TP1 timer 0.5us, FDL_TP2 timer 1.5us, freq 125)
PCH_DPLL_ANALOG_CTL: 0x00008000
PCH_DPLL_A: 0x88046004 (enable, sdvo high speed no, mode LVDS, p2 Div 14, FPA0 P1 3, FPA1 P1 3, refclk SSC, sdvo/hdmi mul 1)
PCH_DPLL_B: 0x04800080 (disable, sdvo high speed no, mode (null), p2 (null), FPA0 P1 8, FPA1 P1 8, refclk default 120Mhz, sdvo/hdmi mul 1)
PCH_FPA0: 0x00010c09 (n = 1, m1 = 12, m2 = 9)
PCH_FPA1: 0x00010c09 (n = 1, m1 = 12, m2 = 9)
PCH_FPB0: 0x00030d07 (n = 3, m1 = 13, m2 = 7)
PCH_FPB1: 0x00030d07 (n = 3, m1 = 13, m2 = 7)
TRANS_HTOTAL_A: 0x06680555 (1366 active, 1641 total)
TRANS_HBLANK_A: 0x06680555 (1366 start, 1641 end)
TRANS_HSYNC_A: 0x05e80578 (1401 start, 1513 end)
TRANS_VTOTAL_A: 0x030b02ff (768 active, 780 total)
TRANS_VBLANK_A: 0x030b02ff (768 start, 780 end)
TRANS_VSYNC_A: 0x03020300 (769 start, 771 end)
TRANS_VSYNCSHIFT_A: 0x00000000
TRANSA_DATA_M1: 0x00000000 (TU 1, val 0x0 0)
TRANSA_DATA_N1: 0x00000000 (val 0x0 0)
TRANSA_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
TRANSA_DATA_N2: 0x00000000 (val 0x0 0)
TRANSA_DP_LINK_M1: 0x00000000 (val 0x0 0)
TRANSA_DP_LINK_N1: 0x00000000 (val 0x0 0)
TRANSA_DP_LINK_M2: 0x00000000 (val 0x0 0)
TRANSA_DP_LINK_N2: 0x00000000 (val 0x0 0)
TRANS_HTOTAL_B: 0x00000000 (1 active, 1 total)
TRANS_HBLANK_B: 0x00000000 (1 start, 1 end)
TRANS_HSYNC_B: 0x00000000 (1 start, 1 end)
TRANS_VTOTAL_B: 0x00000000 (1 active, 1 total)
TRANS_VBLANK_B: 0x00000000 (1 start, 1 end)
TRANS_VSYNC_B: 0x00000000 (1 start, 1 end)
TRANS_VSYNCSHIFT_B: 0x00000000
TRANSB_DATA_M1: 0x00000000 (TU 1, val 0x0 0)
TRANSB_DATA_N1: 0x00000000 (val 0x0 0)
TRANSB_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
TRANSB_DATA_N2: 0x00000000 (val 0x0 0)
TRANSB_DP_LINK_M1: 0x00000000 (val 0x0 0)
TRANSB_DP_LINK_N1: 0x00000000 (val 0x0 0)
TRANSB_DP_LINK_M2: 0x00000000 (val 0x0 0)
TRANSB_DP_LINK_N2: 0x00000000 (val 0x0 0)
TRANS_HTOTAL_C: 0x00000000 (1 active, 1 total)
TRANS_HBLANK_C: 0x00000000 (1 start, 1 end)
TRANS_HSYNC_C: 0x00000000 (1 start, 1 end)
TRANS_VTOTAL_C: 0x00000000 (1 active, 1 total)
TRANS_VBLANK_C: 0x00000044 (69 start, 1 end)
TRANS_VSYNC_C: 0x00000000 (1 start, 1 end)
TRANS_VSYNCSHIFT_C: 0x00000000
TRANSC_DATA_M1: 0x00000000 (TU 1, val 0x0 0)
TRANSC_DATA_N1: 0x00000000 (val 0x0 0)
TRANSC_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
TRANSC_DATA_N2: 0x00000000 (val 0x0 0)
TRANSC_DP_LINK_M1: 0x00000000 (val 0x0 0)
TRANSC_DP_LINK_N1: 0x00000000 (val 0x0 0)
TRANSC_DP_LINK_M2: 0x00000000 (val 0x0 0)
TRANSC_DP_LINK_N2: 0x00000000 (val 0x0 0)
TRANSACONF: 0xc0000040 (enable, active, progressive)
TRANSBCONF: 0x00000000 (disable, inactive, progressive)
TRANSCCONF: 0x00000000 (disable, inactive, progressive)
FDI_TXA_CTL: 0xb0044000 (enable, train pattern not train, voltage swing 0.4V,pre-emphasis none, port width X1, enhanced framing enable, FDI PLL enable, scrambing enable, master mode disable)
FDI_TXB_CTL: 0x00044000 (disable, train pattern pattern_1, voltage swing 0.4V,pre-emphasis none, port width X1, enhanced framing enable, FDI PLL enable, scrambing enable, master mode disable)
FDI_TXC_CTL: 0x00000000 (disable, train pattern pattern_1, voltage swing 0.4V,pre-emphasis none, port width X1, enhanced framing disable, FDI PLL disable, scrambing enable, master mode disable)
FDI_RXA_CTL: 0xb0022050 (enable, train pattern not train, port width X1, 6bpc,link_reverse_strap_overwrite no, dmi_link_reverse no, FDI PLL enable,FS ecc disable, FE ecc disable, FS err report disable, FE err report disable,scrambing enable, enhanced framing enable, PCDClk)
FDI_RXB_CTL: 0x00000040 (disable, train pattern pattern_1, port width X1, 8bpc,link_reverse_strap_overwrite no, dmi_link_reverse no, FDI PLL disable,FS ecc disable, FE ecc disable, FS err report disable, FE err report disable,scrambing enable, enhanced framing enable, RawClk)
FDI_RXC_CTL: 0x00000000 (disable, train pattern pattern_1, port width X1, 8bpc,link_reverse_strap_overwrite no, dmi_link_reverse no, FDI PLL disable,FS ecc disable, FE ecc disable, FS err report disable, FE err report disable,scrambing enable, enhanced framing disable, RawClk)
FDI_RXA_MISC: 0x00000080 (FDI Delay 128)
FDI_RXB_MISC: 0x00000080 (FDI Delay 128)
FDI_RXC_MISC: 0x00000000 (FDI Delay 0)
FDI_RXA_TUSIZE1: 0x7e000000
FDI_RXA_TUSIZE2: 0x7e000000
FDI_RXB_TUSIZE1: 0x7e000000
FDI_RXB_TUSIZE2: 0x7e000000
FDI_RXC_TUSIZE1: 0x00000000
FDI_RXC_TUSIZE2: 0x00000000
FDI_PLL_CTL_1: 0x33505248
FDI_PLL_CTL_2: 0x00000000
FDI_RXA_IIR: 0x00000000
FDI_RXA_IMR: 0x000000ff
FDI_RXB_IIR: 0x00000000
FDI_RXB_IMR: 0x000000ff
PCH_ADPA: 0x00f40000 (disabled, transcoder A, -hsync, -vsync)
HDMIB: 0x0000089c (disabled pipe A 8bpc TMDS DVI audio disabled +vsync +hsync detected)
HDMIC: 0x0000001c (disabled pipe A 8bpc SDVO DVI audio disabled +vsync +hsync detected)
HDMID: 0x00000018 (disabled pipe A 8bpc SDVO DVI audio disabled +vsync +hsync non-detected)
PCH_LVDS: 0x80308302 (enabled, pipe A, 18 bit, 1 channel)
CPU_eDP_A: 0x00000018
PCH_DP_B: 0x0000001c
PCH_DP_C: 0x0000001c
PCH_DP_D: 0x00000018
TRANS_DP_CTL_A: 0x00000000 (enabled, pipe A, 18 bit, 1 channel)
TRANS_DP_CTL_B: 0x00000000 (enabled, pipe A, 18 bit, 1 channel)
TRANS_DP_CTL_C: 0x00000000 (enabled, pipe A, 18 bit, 1 channel)
BLC_PWM_CPU_CTL2: 0x80000000
BLC_PWM_CPU_CTL: 0x000011bb
BLC_PWM_PCH_CTL1: 0x80000000
BLC_PWM_PCH_CTL2: 0x11bb11bb
PCH_PP_STATUS: 0xc0000008 (on, ready, sequencing idle)
PCH_PP_CONTROL: 0xabcd0003 (blacklight disabled, power down on reset, panel on)
PCH_PP_ON_DELAYS: 0x01f40834
PCH_PP_OFF_DELAYS: 0x00010032
PCH_PP_DIVISOR: 0x00186904
PORT_DBG: 0x00000000 (HW DRRS off)
RC6_RESIDENCY_TIME: 0xffffffff
RC6p_RESIDENCY_TIME: 0xffffffff
RC6pp_RESIDENCY_TIME: 0xffffffff

Im not really sure what to look for I just followed the instructions on verteks' patcher to patch the frame buffer

oh sorry i just saw what you said hold on let me check now

Hey im on linux right now and it said that it could find the package for read-edid, this is possibly because I have booted from a live cd. did you have the same problem? Im going to install on a spare hard drive and see if it works

#239
pentothal

pentothal

    InsanelyMac Protégé

  • Members
  • PipPip
  • 75 posts

Heres my reg dump:
ubuntu@ubuntu:~$ sudo intel_reg_dumper
PGETBL_CTL: 0x00000008
GEN6_INSTDONE_1: 0xfffffffe
GEN6_INSTDONE_2: 0xffffffff
CPU_VGACNTRL: 0x80000000 (disabled)
DIGITAL_PORT_HOTPLUG_CNTRL: 0x00000000
RR_HW_CTL: 0x00000000 (low 0, high 0)
FDI_PLL_BIOS_0: 0x082b3019
FDI_PLL_BIOS_1: 0x00000000
FDI_PLL_BIOS_2: 0x00000000
DISPLAY_PORT_PLL_BIOS_0: 0x0807012b
DISPLAY_PORT_PLL_BIOS_1: 0x00000000
DISPLAY_PORT_PLL_BIOS_2: 0x00000000
FDI_PLL_FREQ_CTL: 0x00053687
PIPEACONF: 0xc0000050 (enabled, active, pf-pd, rotate 0, 6bpc)
HTOTAL_A: 0x06680555 (1366 active, 1641 total)
HBLANK_A: 0x06680555 (1366 start, 1641 end)
HSYNC_A: 0x05e80578 (1401 start, 1513 end)
VTOTAL_A: 0x030b02ff (768 active, 780 total)
VBLANK_A: 0x030b02ff (768 start, 780 end)
VSYNC_A: 0x03020300 (769 start, 771 end)
VSYNCSHIFT_A: 0x00000000
PIPEASRC: 0x055502ff (1366, 768)
PIPEA_DATA_M1: 0x7e152610 (TU 64, val 0x152610 1386000)
PIPEA_DATA_N1: 0x0020f580 (val 0x20f580 2160000)
PIPEA_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
PIPEA_DATA_N2: 0x00000000 (val 0x0 0)
PIPEA_LINK_M1: 0x00012cc8 (val 0x12cc8 77000)
PIPEA_LINK_N1: 0x00041eb0 (val 0x41eb0 270000)
PIPEA_LINK_M2: 0x00000000 (val 0x0 0)
PIPEA_LINK_N2: 0x00000000 (val 0x0 0)
DSPACNTR: 0xd8004400 (enabled)
DSPABASE: 0x00000000
DSPASTRIDE: 0x00001600 (88)
DSPASURF: 0x0044b000
DSPATILEOFF: 0x00000000 (0, 0)
PIPEBCONF: 0x00000000 (disabled, inactive, pf-pd, rotate 0, 8bpc)
HTOTAL_B: 0x00000000 (1 active, 1 total)
HBLANK_B: 0x00000000 (1 start, 1 end)
HSYNC_B: 0x00000000 (1 start, 1 end)
VTOTAL_B: 0x00000000 (1 active, 1 total)
VBLANK_B: 0x00000000 (1 start, 1 end)
VSYNC_B: 0x00000000 (1 start, 1 end)
VSYNCSHIFT_B: 0x00000000
PIPEBSRC: 0x00000000 (1, 1)
PIPEB_DATA_M1: 0x00000000 (TU 1, val 0x0 0)
PIPEB_DATA_N1: 0x00000000 (val 0x0 0)
PIPEB_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
PIPEB_DATA_N2: 0x00000000 (val 0x0 0)
PIPEB_LINK_M1: 0x00000000 (val 0x0 0)
PIPEB_LINK_N1: 0x00000000 (val 0x0 0)
PIPEB_LINK_M2: 0x00000000 (val 0x0 0)
PIPEB_LINK_N2: 0x00000000 (val 0x0 0)
DSPBCNTR: 0x00000000 (disabled)
DSPBBASE: 0x00000000
DSPBSTRIDE: 0x00000000 (0)
DSPBSURF: 0x00000000
DSPBTILEOFF: 0x00000000 (0, 0)
PIPECCONF: 0x00000000 (disabled, inactive, pf-pd, rotate 0, 8bpc)
HTOTAL_C: 0x00000000 (1 active, 1 total)
HBLANK_C: 0x00000000 (1 start, 1 end)
HSYNC_C: 0x00000000 (1 start, 1 end)
VTOTAL_C: 0x00000000 (1 active, 1 total)
VBLANK_C: 0x00000000 (1 start, 1 end)
VSYNC_C: 0x00000000 (1 start, 1 end)
VSYNCSHIFT_C: 0x00000000
PIPECSRC: 0x00000000 (1, 1)
PIPEC_DATA_M1: 0x00000000 (TU 1, val 0x0 0)
PIPEC_DATA_N1: 0x00000000 (val 0x0 0)
PIPEC_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
PIPEC_DATA_N2: 0x00000000 (val 0x0 0)
PIPEC_LINK_M1: 0x00000000 (val 0x0 0)
PIPEC_LINK_N1: 0x00000000 (val 0x0 0)
PIPEC_LINK_M2: 0x00000000 (val 0x0 0)
PIPEC_LINK_N2: 0x00000000 (val 0x0 0)
DSPCCNTR: 0x00000000 (disabled)
DSPCBASE: 0x00000000
DSPCSTRIDE: 0x00000000 (0)
DSPCSURF: 0x00000000
DSPCTILEOFF: 0x00000000 (0, 0)
PFA_CTL_1: 0x00000000 (disable, auto_scale yes, auto_scale_cal no, v_filter enable, vadapt disable, mode least, filter_sel programmed,chroma pre-filter disable, vert3tap auto, v_inter_invert field 1)
PFA_CTL_2: 0x00007e80 (vscale 0.988281)
PFA_CTL_3: 0x00003f40 (vscale initial phase 0.494141)
PFA_CTL_4: 0x00007d54 (hscale 0.979126)
PFA_WIN_POS: 0x00000000 (0, 0)
PFA_WIN_SIZE: 0x00000000 (0, 0)
PFB_CTL_1: 0x00000000 (disable, auto_scale yes, auto_scale_cal no, v_filter enable, vadapt disable, mode least, filter_sel programmed,chroma pre-filter disable, vert3tap auto, v_inter_invert field 1)
PFB_CTL_2: 0x00000000 (vscale 0.000000)
PFB_CTL_3: 0x00000000 (vscale initial phase 0.000000)
PFB_CTL_4: 0x00000000 (hscale 0.000000)
PFB_WIN_POS: 0x00000000 (0, 0)
PFB_WIN_SIZE: 0x00000000 (0, 0)
PFC_CTL_1: 0x00000000 (disable, auto_scale yes, auto_scale_cal no, v_filter enable, vadapt disable, mode least, filter_sel programmed,chroma pre-filter disable, vert3tap auto, v_inter_invert field 1)
PFC_CTL_2: 0x00000000 (vscale 0.000000)
PFC_CTL_3: 0x00000000 (vscale initial phase 0.000000)
PFC_CTL_4: 0x00000000 (hscale 0.000000)
PFC_WIN_POS: 0x00000000 (0, 0)
PFC_WIN_SIZE: 0x00000000 (0, 0)
PCH_DREF_CONTROL: 0x00001400 (cpu source disable, ssc_source enable, nonspread_source enable, superspread_source disable, ssc4_mode downspread, ssc1 disable, ssc4 disable)
PCH_RAWCLK_FREQ: 0x0000007d (FDL_TP1 timer 0.5us, FDL_TP2 timer 1.5us, freq 125)
PCH_DPLL_TMR_CFG: 0x0271186a
PCH_SSC4_PARMS: 0x00000000
PCH_SSC4_AUX_PARMS: 0x00000000
PCH_DPLL_SEL: 0x00000000 (FDL_TP1 timer 0.5us, FDL_TP2 timer 1.5us, freq 125)
PCH_DPLL_ANALOG_CTL: 0x00008000
PCH_DPLL_A: 0x88046004 (enable, sdvo high speed no, mode LVDS, p2 Div 14, FPA0 P1 3, FPA1 P1 3, refclk SSC, sdvo/hdmi mul 1)
PCH_DPLL_B: 0x04800080 (disable, sdvo high speed no, mode (null), p2 (null), FPA0 P1 8, FPA1 P1 8, refclk default 120Mhz, sdvo/hdmi mul 1)
PCH_FPA0: 0x00010c09 (n = 1, m1 = 12, m2 = 9)
PCH_FPA1: 0x00010c09 (n = 1, m1 = 12, m2 = 9)
PCH_FPB0: 0x00030d07 (n = 3, m1 = 13, m2 = 7)
PCH_FPB1: 0x00030d07 (n = 3, m1 = 13, m2 = 7)
TRANS_HTOTAL_A: 0x06680555 (1366 active, 1641 total)
TRANS_HBLANK_A: 0x06680555 (1366 start, 1641 end)
TRANS_HSYNC_A: 0x05e80578 (1401 start, 1513 end)
TRANS_VTOTAL_A: 0x030b02ff (768 active, 780 total)
TRANS_VBLANK_A: 0x030b02ff (768 start, 780 end)
TRANS_VSYNC_A: 0x03020300 (769 start, 771 end)
TRANS_VSYNCSHIFT_A: 0x00000000
TRANSA_DATA_M1: 0x00000000 (TU 1, val 0x0 0)
TRANSA_DATA_N1: 0x00000000 (val 0x0 0)
TRANSA_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
TRANSA_DATA_N2: 0x00000000 (val 0x0 0)
TRANSA_DP_LINK_M1: 0x00000000 (val 0x0 0)
TRANSA_DP_LINK_N1: 0x00000000 (val 0x0 0)
TRANSA_DP_LINK_M2: 0x00000000 (val 0x0 0)
TRANSA_DP_LINK_N2: 0x00000000 (val 0x0 0)
TRANS_HTOTAL_B: 0x00000000 (1 active, 1 total)
TRANS_HBLANK_B: 0x00000000 (1 start, 1 end)
TRANS_HSYNC_B: 0x00000000 (1 start, 1 end)
TRANS_VTOTAL_B: 0x00000000 (1 active, 1 total)
TRANS_VBLANK_B: 0x00000000 (1 start, 1 end)
TRANS_VSYNC_B: 0x00000000 (1 start, 1 end)
TRANS_VSYNCSHIFT_B: 0x00000000
TRANSB_DATA_M1: 0x00000000 (TU 1, val 0x0 0)
TRANSB_DATA_N1: 0x00000000 (val 0x0 0)
TRANSB_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
TRANSB_DATA_N2: 0x00000000 (val 0x0 0)
TRANSB_DP_LINK_M1: 0x00000000 (val 0x0 0)
TRANSB_DP_LINK_N1: 0x00000000 (val 0x0 0)
TRANSB_DP_LINK_M2: 0x00000000 (val 0x0 0)
TRANSB_DP_LINK_N2: 0x00000000 (val 0x0 0)
TRANS_HTOTAL_C: 0x00000000 (1 active, 1 total)
TRANS_HBLANK_C: 0x00000000 (1 start, 1 end)
TRANS_HSYNC_C: 0x00000000 (1 start, 1 end)
TRANS_VTOTAL_C: 0x00000000 (1 active, 1 total)
TRANS_VBLANK_C: 0x00000044 (69 start, 1 end)
TRANS_VSYNC_C: 0x00000000 (1 start, 1 end)
TRANS_VSYNCSHIFT_C: 0x00000000
TRANSC_DATA_M1: 0x00000000 (TU 1, val 0x0 0)
TRANSC_DATA_N1: 0x00000000 (val 0x0 0)
TRANSC_DATA_M2: 0x00000000 (TU 1, val 0x0 0)
TRANSC_DATA_N2: 0x00000000 (val 0x0 0)
TRANSC_DP_LINK_M1: 0x00000000 (val 0x0 0)
TRANSC_DP_LINK_N1: 0x00000000 (val 0x0 0)
TRANSC_DP_LINK_M2: 0x00000000 (val 0x0 0)
TRANSC_DP_LINK_N2: 0x00000000 (val 0x0 0)
TRANSACONF: 0xc0000040 (enable, active, progressive)
TRANSBCONF: 0x00000000 (disable, inactive, progressive)
TRANSCCONF: 0x00000000 (disable, inactive, progressive)
FDI_TXA_CTL: 0xb0044000 (enable, train pattern not train, voltage swing 0.4V,pre-emphasis none, port width X1, enhanced framing enable, FDI PLL enable, scrambing enable, master mode disable)
FDI_TXB_CTL: 0x00044000 (disable, train pattern pattern_1, voltage swing 0.4V,pre-emphasis none, port width X1, enhanced framing enable, FDI PLL enable, scrambing enable, master mode disable)
FDI_TXC_CTL: 0x00000000 (disable, train pattern pattern_1, voltage swing 0.4V,pre-emphasis none, port width X1, enhanced framing disable, FDI PLL disable, scrambing enable, master mode disable)
FDI_RXA_CTL: 0xb0022050 (enable, train pattern not train, port width X1, 6bpc,link_reverse_strap_overwrite no, dmi_link_reverse no, FDI PLL enable,FS ecc disable, FE ecc disable, FS err report disable, FE err report disable,scrambing enable, enhanced framing enable, PCDClk)
FDI_RXB_CTL: 0x00000040 (disable, train pattern pattern_1, port width X1, 8bpc,link_reverse_strap_overwrite no, dmi_link_reverse no, FDI PLL disable,FS ecc disable, FE ecc disable, FS err report disable, FE err report disable,scrambing enable, enhanced framing enable, RawClk)
FDI_RXC_CTL: 0x00000000 (disable, train pattern pattern_1, port width X1, 8bpc,link_reverse_strap_overwrite no, dmi_link_reverse no, FDI PLL disable,FS ecc disable, FE ecc disable, FS err report disable, FE err report disable,scrambing enable, enhanced framing disable, RawClk)
FDI_RXA_MISC: 0x00000080 (FDI Delay 128)
FDI_RXB_MISC: 0x00000080 (FDI Delay 128)
FDI_RXC_MISC: 0x00000000 (FDI Delay 0)
FDI_RXA_TUSIZE1: 0x7e000000
FDI_RXA_TUSIZE2: 0x7e000000
FDI_RXB_TUSIZE1: 0x7e000000
FDI_RXB_TUSIZE2: 0x7e000000
FDI_RXC_TUSIZE1: 0x00000000
FDI_RXC_TUSIZE2: 0x00000000
FDI_PLL_CTL_1: 0x33505248
FDI_PLL_CTL_2: 0x00000000
FDI_RXA_IIR: 0x00000000
FDI_RXA_IMR: 0x000000ff
FDI_RXB_IIR: 0x00000000
FDI_RXB_IMR: 0x000000ff
PCH_ADPA: 0x00f40000 (disabled, transcoder A, -hsync, -vsync)
HDMIB: 0x0000089c (disabled pipe A 8bpc TMDS DVI audio disabled +vsync +hsync detected)
HDMIC: 0x0000001c (disabled pipe A 8bpc SDVO DVI audio disabled +vsync +hsync detected)
HDMID: 0x00000018 (disabled pipe A 8bpc SDVO DVI audio disabled +vsync +hsync non-detected)
PCH_LVDS: 0x80308302 (enabled, pipe A, 18 bit, 1 channel)
CPU_eDP_A: 0x00000018
PCH_DP_B: 0x0000001c
PCH_DP_C: 0x0000001c
PCH_DP_D: 0x00000018
TRANS_DP_CTL_A: 0x00000000 (enabled, pipe A, 18 bit, 1 channel)
TRANS_DP_CTL_B: 0x00000000 (enabled, pipe A, 18 bit, 1 channel)
TRANS_DP_CTL_C: 0x00000000 (enabled, pipe A, 18 bit, 1 channel)
BLC_PWM_CPU_CTL2: 0x80000000
BLC_PWM_CPU_CTL: 0x000011bb
BLC_PWM_PCH_CTL1: 0x80000000
BLC_PWM_PCH_CTL2: 0x11bb11bb
PCH_PP_STATUS: 0xc0000008 (on, ready, sequencing idle)
PCH_PP_CONTROL: 0xabcd0003 (blacklight disabled, power down on reset, panel on)
PCH_PP_ON_DELAYS: 0x01f40834
PCH_PP_OFF_DELAYS: 0x00010032
PCH_PP_DIVISOR: 0x00186904
PORT_DBG: 0x00000000 (HW DRRS off)
RC6_RESIDENCY_TIME: 0xffffffff
RC6p_RESIDENCY_TIME: 0xffffffff
RC6pp_RESIDENCY_TIME: 0xffffffff

Im not really sure what to look for I just followed the instructions on verteks' patcher to patch the frame buffer

oh sorry i just saw what you said hold on let me check now

Hey im on linux right now and it said that it could find the package for read-edid, this is possibly because I have booted from a live cd. did you have the same problem? Im going to install on a spare hard drive and see if it works


I was able to install the package in Linux Mint Live. You should be able to do the same.

Cheers

#240
stacyk819

stacyk819

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Hey I got it working with mint live cd (i think the problem was that I was using a 64 bit version ) It appears to be working (outputing EDID info)

get-edid: get-edid version 2.0.0

Performing real mode VBE call
Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
Function supported
Call successful

VBE version 300
VBE string at 0x11100 "Intel®Ironlake Mobile Graphics Chipset Accelerated VGA BIOS"

VBE/DDC service about to be called
Report DDC capabilities

Performing real mode VBE call
Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
Function supported
Call successful

Monitor and video card combination does not support DDC1 transfers
Monitor and video card combination supports DDC2 transfers
0 seconds per 128 byte EDID block transfer
Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
Read EDID

Performing real mode VBE call
Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
Function supported
Call failed

The EDID data should not be trusted as the VBE call failed
parse-edid: EDID checksum passed.

# EDID version 0 revision 0
Section "Monitor"
# Block type: 2:0 3:0
# Block type: 2:0 3:0
# Block type: 2:0 3:0
# Block type: 2:0 3:0
Identifier "@@@:0000"
VendorName "@@@"
ModelName "@@@:0000"
# Block type: 2:0 3:0
# Block type: 2:0 3:0
# Block type: 2:0 3:0
# Block type: 2:0 3:0
# DPMS capabilities: Active off:no Suspend:no Standby:no

# Block type: 2:0 3:0
# Block type: 2:0 3:0
# Block type: 2:0 3:0
# Block type: 2:0 3:0





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy