Jump to content

Need help with MSI Z77A-G45


  • Please log in to reply
2 replies to this topic

#1
mathq

mathq

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 208 posts
  • Gender:Male
  • Location:Quebec
I just bought myself this motherboard and I would be really happy if anyone can help me fixing my DSDT to get my ALC892 sound card to work. I currently have it working using HDAEnabler, but I'd like to have something as clean as possible so it would be nice to get rid of that kext.

I also have problems to get rid of NullCPUPowerManagement that still gets loaded even though I removed it from /E/E. I tried booting with UseKernelCache=No -f, but it still gets loaded. I looked if it was in /S/L/E and it isn't, so I'm really out of ideas right now!

Thanks a lot
MQ

I've attached my DSDT to the post

Attached Files



#2
WhatTheTech

WhatTheTech

    Macmodder Addict

  • Retired
  • 454 posts
  • Gender:Male
I'm also interested in figuring this out - my Z77MA-G45 also uses the ALC892 and I have had no luck so far. What have you tried so far?

#3
mathq

mathq

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 208 posts
  • Gender:Male
  • Location:Quebec
Yea audio is now working with HDAEnabler + modified AppleHDA





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy