Jump to content

[Guide] ML on Acer Aspire TimelineX 4830TG (3830TG or 5830TG)

* * * * * 2 votes Mountain lion acer aspire timelineX 4830TG 3830TG 5830TG

  • Please log in to reply
108 replies to this topic

#1
superb921

superb921

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

Attached File  Screen Shot 2013-02-16 at 5.09.29 PM.png   209.87KB   196 downloadsAttached File  GB.png   93.17KB   243 downloadsAttached File  LOW VOLT.png   321.83KB   228 downloadsAttached File  High VOLT.png   387.58KB   208 downloadsAttached File  TP.png   132.56KB   248 downloads
Spec:

  • Intel Core i5-2410M @ 2.30 GHz + TurboBoost Up to 2.90GHz
  • 8.00 GB DDR3 1333 MHz RAM
  • 750 GB HDD
  • Atheros 9287 Wifi/ Gigabyte Ethernet
  • HD 3000 GPU / nVidia Optimus GeForce GT540M 2GB
  • Elantech Multitouch TrackPad

Works:

  • CPU with turboboost (Speedstep)
  • Wifi
  • Ethernet
  • HD 3000 GPU (full)
  • 2 USB 2.0 Ports + USB 3.0 Port (See UPDATE 4 for USB 3.0 kext)
  • Audio (Speaker/Headphone) + volume control
  • Shutdown, Restart, Sleep (Lid and button)
  • Brightness control
  • Battery
  • Keyboard/Mouse
  • Multitouch Enable Trackpad
  • Dual Boot with Windows 8
  • WebCam
  • iMessage (FIXED)
  • Bluetooth (See update 5 for download link)

Does't Work:

  • nVidia Optimus GeForce GT540M

Preparation:

Installation:

  • Boot from iATKOS ML2 USB
  • Disk Utilities > Format your OSX Partition to Mac OS Extended (Journaled)
  • Customize, Select, Install and Restart:

Bootloader
Graphics
EnablerBuilt-in
Ethernet
1366*768*32
Original Apple Boot Logo
FakeSMC
Disabler
EvOreBootRTC
PatchMac Model> 8,1 MacBook Pro
SATA/IDE (leave the default select)
PS/2

Battery*****(select this to get native battery working, without voodoo)
nVidia>Disable nVidia
HD3000
Network
-----
Deselect:
Sound
Kernel Cache

Post-Installation:

  • Unzip 4830TG kext.zip
  • Patch all kext Inside Folder [PATCH 1] using Kext Utilities Attached File  P1.png   347.27KB   354 downloads
  • Patch all kext Inside Folder [PATCH 2] using Kext Utilities Attached File  P2.png   251.47KB   363 downloads
  • Drag all Files inside Extra (in PATCH 2) to ~/Extra and replace all Attached File  EXT.png   286.08KB   423 downloads
  • Delete NullCPUPowerManagement.kext inside Extension
  • Rebuild Cache/Repair Permission Attached File  Screen Shot 2013-02-16 at 5.21.30 PM.png   154.84KB   461 downloads
  • Install Pleaseslpeep.dmg
  • Reboot with -f
  • After Reboot, Open up Champlist (in your application folder) and select F-boot Attached File  FBoot.png   252.23KB   366 downloads
  • For iMessage Fix (Patch 3: http://tekwik.com/20...-fix-chameleon/)

EVERYTHING SHOULD BE WORKING AT THIS POINT

Side Notes:

  • Set Graphics to Integrated instead of Switchable if you want to increase battery life (5 - 7 hr Integrated/2-3 hr Switchable)

Attached File  BATT.png   794.58KB   260 downloadsAttached File  BATT 2.png   123.82KB   165 downloads

  • Screen Brightness Control: Fn + F12 (down) AND Fn + Pause (Up)

Attached File  BT C.png   115.81KB   128 downloadsAttached File  BRG CNT.png   802.95KB   134 downloads

  • Headphone sound may be unstable at times (Open up Settings > sound > Mic and just leave the window open)

Attached File  HEADPHONE FIX.png   94.84KB   149 downloadsTwitter: @rwu921

[UPDATE 1*] New ElanTech TouchPad kext is out V2.1.3: https://mega.co.nz/#...ACz66THGRdDLniAYou can add/remove different features in the plist!!(or visit official forum: http://forum.osxlati...driver-mac-osx/)

[UPDATE 2*] Turns out after a couple boots, -f (flag boot) is no longer necessary!!

[UPDATE 3*] Feel free to update to 10.8.3 and 10.8.4 via Apps Store. It might show unexpected error, but everything will be fine after restart. Attached File  Screen Shot 2013-03-16 at 4.07.38 PM.png   178.73KB   128 downloadsAttached File  Screen Shot 2013-06-06 at 1.47.35 PM.png   608.84KB   38 downloads

[UPDATE 4*] NO SLEEP FUNCTION IF YOU APPLY THIS KEXT (for now). USB 3.0 kext tested working!!! Here ya go fellows: https://mega.co.nz/#...ScGbwYryLNqYxVI
Attached File  Screen Shot 2013-03-29 at 1.55.51 AM.png   113.46KB   130 downloads

 

[UPDATE 5*] Bluetooth AR3011 tested working...finally! press Fn+F3 to cycle through wireless settings.

***Some of you might need to edit your VID and PID. I have it on VID0489/PIDE02C

Here ya go: https://mega.co.nz/#...WAS3EimLMvO16d0

Attached File  Screen Shot 2013-06-16 at 3.58.26 PM.png   1003.35KB   19 downloadsAttached File  Screen Shot 2013-06-16 at 4.01.13 PM.png   239.66KB   12 downloads

 

[UPDATE 6*] HDMI Audio kext found!

Link: https://mega.co.nz/#...oGJxOsKGD0mGN6I

Attached File  Screen Shot 2013-06-17 at 12.04.43 PM.png   110.51KB   18 downloads

 

 

For risk takers (USE IT AT YOUR OWN RISKS):

------------------------------------------------------------------------------------------------------------

DSDT Tutorial (Step 1): http://www.youtube.c...h?v=WseMI07G6_A

 

For Acer 5830TG Mountain Lion Users (Kext Package):

*Fresh install required

Link: https://mega.co.nz/#...ujmEyDzZKtzhxtY

 

Bluetooth kext (not tested/not fully functional): SOLUTION FOUND, SEE UPDATE 5

*Test it on any version beyond 10.8.2

*More files coming soon

*Try to make it recognize by OSX first!

*It goes Wifi + No BT --> Wifi + BT --> No Wifi + BT --> No Wifi + No BT --> Wifi + No BT

Link: https://mega.co.nz/#...hAOSaP8573pLNHQ

 

 

HDMI audio (not tested):   SOLUTION FOUND, SEE UPDATE 6

*Test it on 10.8.0 or 10.8.2 first before moving onto higher version

link: https://mega.co.nz/#...zUf4GecWhI9Ua5Q

 

SSDT Collection:

*use only when the given files (above) doesnt work

*all files are not tested, read readme file first

*Includes:

i3 2310M/2330M/2350M/2370M
i5 2410M/2430M/2450M/2520M/2540M/
i7 2620M/2630QM/2640M/2670QM/2720QM/2760QM/2820QM/2860QM/2920QM/2960QM

Link: https://mega.co.nz/#...5p32VQQUhCLcMU0

 

TrackPad (for 3830TG user) [some report failure, update coming soon]

*Not tested

*Make sure you dont have VoodooPS2 when using this

Link: https://mega.co.nz/#...hOVwOA8LaSC4PHc

 

Wifi Card (5830TG 3830TG users)

*Atheros AR81(31/32/51/52/61/62/71/72)

Link: http://www.insanelym...ver-for-107108/

 

DSDT for 3830TG - WORK IN PROGRESS - By Yuvin

http://www.insanelym...30tg/?p=1934214



#2
Alien1959

Alien1959

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
thank you so much! helps alot!

#3
tytbro

tytbro

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Great guide but i have problems. I have Acer 5830TG.
After installation OSX works only if i use "-x".
Before boot loading with Apple logo i have :
"ERROR: dcbtable_version is 0x10
ERROR: nVidia ROM Patching Failed!"
And it freeze at boot loading if i dont use "-x".

And i have WIndows 8 on the other partition and when i run notebook without USBstick with iAtkos i see boot0: error.

Sorry about my english, I wasn't talking and writing in that language about a year and a half.

Thanks for any help!

#4
superb921

superb921

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

Great guide but i have problems. I have Acer 5830TG.
After installation OSX works only if i use "-x".
Before boot loading with Apple logo i have :
"ERROR: dcbtable_version is 0x10
ERROR: nVidia ROM Patching Failed!"
And it freeze at boot loading if i dont use "-x".

And i have WIndows 8 on the other partition and when i run notebook without USBstick with iAtkos i see boot0: error.

Sorry about my english, I wasn't talking and writing in that language about a year and a half.

Thanks for any help!


Did you select nVidia>Disable nVidia when installing iATKOS ML2?
Which version are you on? (10.8.2 or 10.8.3)

1. Try setting your your graphic to "INTEGRATED" instead of "SWITCHABLE" in the BIOS.
2. If the previous step doesnt work, try booting with -f
3. If you can't boot with -f, use -v and post the screenshot.

---
boot0 error is an easy fix, put in a windows 8 DVD or USB
in the menu click more option>command prompt
type bootrec /Scan <---------this step is optional
bootrec /rebuildbcd
There are also many solutions out there on the internet regarding this issue, a quick google search will do.

#5
tytbro

tytbro

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Thanks for the reply!
I've changed grpahic mode to integrated. Now i don't have this error but i still have freeze at boot with Apple logo... with -f too...
I've did -v and here's my photo.

https://dl.dropbox.c...51/DSC04981.JPG

It's 10.8.2

#6
superb921

superb921

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

Thanks for the reply!
I've changed grpahic mode to integrated. Now i don't have this error but i still have freeze at boot with Apple logo... with -f too...
I've did -v and here's my photo.

https://dl.dropbox.c...51/DSC04981.JPG

It's 10.8.2


Hmm this is new. Here, try patching it. And make sure rebuild cache and repair permission
https://mega.co.nz/#!l5gyXLIQ!AyZj_w1PV5E1GwyUDt6nhFEJlccNVBqWd8MElGnQCQo

#7
tytbro

tytbro

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Ok, i've installed this fix and everything works good! Except WiFi. Ethernet works. Any ideas how to repair wifi? I'm writing form ML 1.8.2 :) Thanks for help!

#8
superb921

superb921

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

Ok, i've installed this fix and everything works good! Except WiFi. Ethernet works. Any ideas how to repair wifi? I'm writing form ML 1.8.2 :) Thanks for help!


Good. Does your wifi work before the fix (when in safe mode)?
Normally wifi should work after iATKOS ML2 installation if you selected "Network" during setup.

Here is my kext, BACKUP YOURS FIRST: https://mega.co.nz/#...ZTQx8rrqt2-v2Bc

Also try hitting Fn + F3 a few times, see if you accidentally turn wifi off (wait 30 sec before press again)
It goes Wifi + No BT --> Wifi + BT --> No Wifi + BT --> No Wifi + No BT --> Wifi + No BT .....(similar to Windows)

#9
tytbro

tytbro

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
This don't help and i see that my osx dont see my battery (it was before try that kext). And in safe mode wifi wasn't working too.

#10
superb921

superb921

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

This don't help and i see that my osx dont see my battery (it was before try that kext). And in safe mode wifi wasn't working too.


Then restore your back up. What kind of wifi card do you have?

#11
Negative

Negative

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
I was gonna say, I had to replace my wifi card to a Atheros AR9285 ($7 on eBay) and now it works without any kexts. This was on a 5830TG
Just wondering, Before I install the Elan touchpad drivers, the os allows flawless tap-to-drag and works all with taps etc (no multi-touch) Then when I install the kext, I get multi-touch but cant tap-to-drag and any taps dont register, and clicks take about 3 secs to register :/ Any ideas?

#12
superb921

superb921

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

I was gonna say, I had to replace my wifi card to a Atheros AR9285 ($7 on eBay) and now it works without any kexts. This was on a 5830TG
Just wondering, Before I install the Elan touchpad drivers, the os allows flawless tap-to-drag and works all with taps etc (no multi-touch) Then when I install the kext, I get multi-touch but cant tap-to-drag and any taps dont register, and clicks take about 3 secs to register :/ Any ideas?


Yes, it is a trade off really. Personally, I would go for multi touch since it is more useful.
(The developer for this kext set it this way, there might be a value you could change in the plist)

Select everything except "zoom while holding" in the Trackpad under settings.

Suggestions:
Install Mouse acceleration: http://triq.net/arti...ration-download
OR
Smooth Mouse(RECOMMEND): http://smoothmouse.com

Drag and Drop:
- Hold the physical left mouse button for a few sec to enable
- Tap on the trackpad for a few sec with one finger while applying a constant amount of pressure to enable

Troubleshoot:
If the curser is non-responsive, click and hold the RIGHT physical trackpad button for a few sec to reset. (might need to do this twice)

*Keep an eye on the official thread for ElanTech TrackPad Kext for future updates.

#13
Negative

Negative

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Alright, I managed to find a fix somewhere in between, The multi-touch works now, And I installed SmootMouse and it helped a lot with the delay, not perfectly but still much better. Thanks for all your help on the guide though! :)
The smoothmouse also gives windows style acceleration and removes all the lag-feel! :D

-For you guys who are having problems with the Wifi, I presume Atheros AR8151 because thats what I had, I spent hours on end trying to fix it and nothing worked. It saves so much time to just change the card (plus its easy as!)
-For the boot problems, 1st I had boot0 error and reinstall fixed that, 2nd time round I had all the graphics errors, again a reinstall fixed that... and about the 5th time now everything works like a charm! :)
+1 Cheers for the kext pack, woulda been lost without it :)

#14
superb921

superb921

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

Alright, I managed to find a fix somewhere in between, The multi-touch works now, And I installed SmootMouse and it helped a lot with the delay, not perfectly but still much better. Thanks for all your help on the guide though! :)
The smoothmouse also gives windows style acceleration and removes all the lag-feel! :D

-For you guys who are having problems with the Wifi, I presume Atheros AR8151 because thats what I had, I spent hours on end trying to fix it and nothing worked. It saves so much time to just change the card (plus its easy as!)
-For the boot problems, 1st I had boot0 error and reinstall fixed that, 2nd time round I had all the graphics errors, again a reinstall fixed that... and about the 5th time now everything works like a charm! :)
+1 Cheers for the kext pack, woulda been lost without it :)


Glad I can help. Is there any difference between "like in Windows" and "Like in OSX"? I couldnt tell the difference.

For all 5830TG USERS
Yes, it turns out 4830TG and 5830TG have different wifi cards. There might be fixes out there, but purchase a wifi card would be less of a hassle as Negative suggested.

#15
tytbro

tytbro

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
So i must just buy another wifi card - thats better solution than no solution ;)
About battery issue, i've downloaded this kext ( http://www.osx86.net...ile&#38;id=3169) and works nice.
When i was using skype i noticed that my microphone don't works. Any solutions?
And i still have problem with booting without USBstick... I was trying with Win8 CD and by gparted in Ubuntu... and difference is that now i have "boot0: done"...

Except that everything works well and thanks for help.

#16
superb921

superb921

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

So i must just buy another wifi card - thats better solution than no solution ;)
About battery issue, i've downloaded this kext ( http://www.osx86.net...ile&#38;id=3169) and works nice.
When i was using skype i noticed that my microphone don't works. Any solutions?
And i still have problem with booting without USBstick... I was trying with Win8 CD and by gparted in Ubuntu... and difference is that now i have "boot0: done"...

Except that everything works well and thanks for help.


I have never experienced mic issue on mine.
  • Open up skype>Preference>Audio/Video, you should see microphone settings. There should be only one choice (Built-in Microphone Internal mic).
  • Opening up Settings>Sounds>Input, and just leave the windows open (this fix is mainly for speaker not mic)
  • If still nothing, you need a new kext
Boot Error:
  • Download/Install EasyBCD on Windows: http://neosmart.net/EasyBCD/
  • Click on "Add New Entry" on the sidebar
  • Select "Mac" and change model to "MBR". then click "Add Entry"
  • Click on "Edit Boot Menu" on the sidebar
  • Make sure Windows is selected as default!! Feel free to change the wait time. REBOOT


#17
tytbro

tytbro

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Funny story: I've changed in my router wireless mode in "only b" and wifi works! So at this moment everything works good on 5830TG except microphone.

Thanks for help and i'll write if i'll find solution for mic.

#18
tytbro

tytbro

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Sorry about double post but i have new issue...

Yesterday i've installed fix for iMessage and this kext for USB 3.0. And after that i have problems with wake up after sleep... I've trying to wake up notebook after sleep twice and every time i hear that disk and fan is working but notebook isn't wake...and i must reboot. And when i booting i see "Incorrect image signature". Except that osx run and works good.

#19
mgmft

mgmft

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
hi,

my osx don't see battery too. how did you fix your problem? the link given above seems like down.

#20
superb921

superb921

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

hi,

my osx don't see battery too. how did you fix your problem? the link given above seems like down.


Go to Settings>Energy Saver. Make sure "Show battery status in menu bar" is checked.
Tell me more about your computer and detail of your problems so i can troubleshoot.
All links have been tested working.

Sorry about double post but i have new issue...

Yesterday i've installed fix for iMessage and this kext for USB 3.0. And after that i have problems with wake up after sleep... I've trying to wake up notebook after sleep twice and every time i hear that disk and fan is working but notebook isn't wake...and i must reboot. And when i booting i see "Incorrect image signature". Except that osx run and works good.


Yes, I was able to reproduce the issue. iMessage fix has nothing to do with it, it's all USB 3.0 kext's fault.
I am proactively looking for a fix, but in the mean time:
- Keep the kext, if you choose USB 3.0 function over sleep
- delete the kext, if you choose sleep over USB 3.0 (still able to charge devices)





Also tagged with one or more of these keywords: Mountain, lion, acer, aspire, timelineX, 4830TG, 3830TG, 5830TG


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy