Jump to content

AsRock Z77E-ITX - UEFI How-to?

- - - - - Aiuto - Installare ML in UEFI

  • Please log in to reply
16 replies to this topic

#1
fatez

fatez

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Italy - Bolzano
Salve ragazzi,


sto impazzendo da giorni, sto cercando su google e su tutti i forum possibili ma alla fine mi arrendo e vi chiedo aiuto.

Possiedo una AsRock Z77E-Itx e vorrei installare ML in UEFI mode ma non capisco come fare... qualcuno potrebbe aiutarmi?

Giuro che se ci riesco farò una guida ultra dettagliata



grazie

#2
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,742 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Ciao,
per fare questo ti serve un bootloader diverso da chameleon; si chiama Clover e se capisci l'inglese (ma comunque Google aiuta) ti giro 2 link:
http://www.insanelym...2-instructions/
http://www.insanelym...ral-discussion/
Ci sono le istruzioni per creare la chiavetta di installazione e per installare il bootloader nella partizione EFI del disco rigido.
Buon Hack

#3
fatez

fatez

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Italy - Bolzano
Ciao ti ringrazio per i link ma avevo gia provato clover ma in uefi non parte, fa schermata nera e torna al menu :(

#4
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,742 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Hai messo la flag slide=0 nelle opzioni di avvio?
Poi ci sono diverse combinazioni di drivers da provare (quelli nella cartella Drivers64UEFI), e serve il file HFSPlus.efi
Nel mio caso parte con HFSPlus.efi + FSInject-64.efi + OsxAptioFixDrv-64.efi
Ciao

#5
fatez

fatez

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Italy - Bolzano
Questa notte riprovo, studio un pò e ti faccio sapere.

Intanto grazie per il supporto

#6
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,742 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Intanto grazie per il supporto

Ma ti pare...

#7
fatez

fatez

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Italy - Bolzano
Niente da fare... ci ho provato in tutte le maniere ma non va...

Non è che potresti dirmi esattamente come fare? sto diventando pazzo!

#8
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,742 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Hai il file HFSPlus.efi?

#9
Mhackintosh96

Mhackintosh96

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
Vorrei sapere perché non è possibile utilizzare Chameleon. Non è compatibile?

#10
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,742 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Vorrei sapere perché non è possibile utilizzare Chameleon. Non è compatibile?

Da che ne so io dovrebbe essere solo Clover a consentire il boot in modalità UEFI

#11
fatez

fatez

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Italy - Bolzano
Guarda questa mattina ho deciso di radere al suolo tutto il pc, ho appena installato Windows8 in UEFI e appena finisco di fare il backup reinstallo ML con U.N.I.B.E.A.S.T
Bisogna fare qualche accorgimento particolare con U.N.I.B.E.A.S.T 1.7 per andare in UEFI ?

#12
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,742 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Guarda questa mattina ho deciso di radere al suolo tutto il pc, ho appena installato Windows8 in UEFI e appena finisco di fare il backup reinstallo ML con U.N.I.B.E.A.S.T
Bisogna fare qualche accorgimento particolare con U.N.I.B.E.A.S.T 1.7 per andare in UEFI ?

Vorrei farti presente le REGOLE riguardo i tools di tony, se installi con questi tools poi non pretendere aiuto da questo forum...

#13
fatez

fatez

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Italy - Bolzano
Lo so hai perfettamente ragione ma sto cercando di ricavare informazioni utili con qualsiasi tools.

#14
fatez

fatez

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Italy - Bolzano
Niente da fare... non capisco cosa sbaglio.

Ho windows8 che boota in UEFI quindi so per certo che la cosa funziona.
Con clover, quando seleziono UEFI, torna sempre sul menù di selezione...

Ecco l'esploso della mia EFI

Spoiler


#15
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 6,742 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Nei drivers prova ad aggiungere OsxFatBinaryDrv-64.efi
Non scordare di entrare nelle opzioni e alla voce boot-args mettere -v slide=0

#16
fatez

fatez

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Italy - Bolzano
Niente da fare

#17
friscos

friscos

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 517 posts
  • Gender:Male
  • Location:Roma
Scusate se mi intrometto, ma l'utilità di installare osx in Uefi mode quale sarebbe? Capisco che win8 in questo modo si possa installare in una partizione GPT ma viceversa osx lo consente già nativamente e allora..
..mi sfugge qualcosa?

Inoltre l'installazione del bootloader nella piccola partizione EFI a che serve?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy