Jump to content

[GUIDE] ML on HP Envy 17-3200 CTO

* * * * * 2 votes

  • Please log in to reply
173 replies to this topic

#161
chengbo

chengbo

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Yeah it is very interesting

It is not very likely that internal hd3000 died because it is in the cpu right?

And there is not swichable graphics option on the bios and it is very simple

And it is not an external monitor but running teamviewer on 3077nr and see it on my windows desktop it is sort of vnc program in this way you can work on windows and osx with alt+tap conveniently

I have used it in this way for couple of hours and there seems to be no problem with overheating of graphics card

When clover couldn’t load hd3000 when I boot windows on the other hdd driver it couldn’t load up hd3000 and ati6470 and fail to show right resolution

Maybe I should bios reset and I won’t be able to load ati graphics foever?

Oh I did not recognize top speaker issue but I will replace the voodoohda kext thanks so much

I think I will have some time at weekends working on the issue…

Have a good day

Attached Files



#162
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 836 posts
  • Gender:Male
  • Location:Southern California

So Clover does not recognize your HD3000 GPU.  In the photo you posted, it should recognize 2 video cards.  Do you use a custom DSDT?  If so, it appears that it does not have GFX0 and only has IGPU.  The only way I can think that Clover wouldn't recognize a working GPU is if it was removed from your DSDT.  Let me know.



#163
chengbo

chengbo

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

I don't use custom dsdt I only did hd3000 patch to original dsdt

because I don't know how to do it myself

 

i'd like to upload my EFI folder but it is over 10MB

 

i'll just upload my original and hd3000 patched dsdt

 

Attached Files



#164
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 836 posts
  • Gender:Male
  • Location:Southern California

I'm not sure I fixed anything.  I cleaned up your TNOT compilation error, got rid of the 4 warnings and relocated your HD3000 patch to the top of IGPU using RehabMan's syntax.  If this doesn't help, we can take a look at your config.plist for Clover.  The problem may be hiding there.

 

Attached File  DSDT.patched.aml.zip   30.46KB   2 downloads



#165
chengbo

chengbo

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

I pulled out my msata sdd in which  installed osx and I reinstalled windows10 to check if hd3000 works

It looks like I failed my hd3000 even on windows I only have ati 6470m and it works okay

it seems like I somehow overheated hd3000 or something so I now have no option but to stick to externel graphics card

my hd3000 is gone

 

 

now then with ati  6470m it works fine only with color gradiation problem  so I tried custom edid injection but it didn't solve

the problem. clover bootloader seems to  grab correct edid information but incorrect framebuffer

looks like I need to work on custom framebuffer 

 



#166
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 836 posts
  • Gender:Male
  • Location:Southern California

Things aren't looking good for your internal screen to work properly.  See here:  http://www.insanelym...notebook/page-1

 

But take a look at this too:  http://www.insanelym...adeon-hd-6470m/

 

Good luck.



#167
cicetto

cicetto

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
I need kext for el capitan, who can upload it?
Thanks in advance

#168
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 836 posts
  • Gender:Male
  • Location:Southern California

Which kext do you need?



#169
cicetto

cicetto

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

All the kext you use with el capitan.

Which version of clover you use with el capitan? with which settings?

Finally I have clover working with latest bios f.0b but not from usb.

can you give me the patches you apply in dsdt?

How can I remap my keys for brightness in dsdt?



#170
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 836 posts
  • Gender:Male
  • Location:Southern California

Here's my current config.plist for El Capitan:

 

Attached File  config.plist.zip   1.91KB   1 downloads

 

Here's my current DSDT.aml:

 

Attached File  DSDT.aml.zip   29.6KB   1 downloads

 

I use the most current version of Clover and also the most current version of RehabMan's kexts for PS2, Battery, BrcmPatchRam.  I do not need his kext for USB but my DSDT is patched for that.



#171
cicetto

cicetto

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Subwoofer and tweeter did not work together?



#172
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 836 posts
  • Gender:Male
  • Location:Southern California

Subwoofer and tweeter did not work together?

 

You need to create a multi-output device using Audio Midi Setup.



#173
cicetto

cicetto

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Why don't you disable ati gpu to save energy in ssdt, I've seen you have enabled in clover config.



#174
mnfesq

mnfesq

    Emenef, Esquire

  • Members
  • PipPipPipPipPipPipPip
  • 836 posts
  • Gender:Male
  • Location:Southern California

There's no need to disable the AMD Radeon 7850M.  It's disabled in the BIOS.  I just have the entries in my DSDT and config.plist for cosmetic purposes.  It allows the OS to detect the hardware even though it's not enabled.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy