Jump to content

How can i make this HD 7770 work ?

inject kext ati 7000 7770

  • Please log in to reply
5 replies to this topic

#1
Scellow

Scellow

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:France
  • Interests:while{true||false}
    {
    dream();
    }
Hi everyone,


I searched around but i can't find an tuto on how inject an kext to an custom usb restoration system (iATKOS ML2)


I want to to choose to install my ATI HD 7770 during the installation of OSX


I appreciate any help =)



(Sorry for my english ..)


EDIT :

I installed OSX and i booted on Windows; How can i make this HD 7770 work ? i tried putting kext from beta 10.8.3 on the usb restoration but it won't work

#2
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 7,521 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Hi, if you created a bootable usb you could try to put the kext in the Extra/Extensions folder of the USB and reboot with -v -f
But i don't know if this is the right solution
Good Luck (and good night)

P.S. Sorry for my english

#3
Scellow

Scellow

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:France
  • Interests:while{true||false}
    {
    dream();
    }
Thanks i'll try that :)



EDIT :

That solution won't work :/

When i want to boot the usb the screen goes black


EDIT 2:

Now i installed OSX and i booted on Windows , How can i make this HD 7770 work with OSX ? what i need to add with transmac ?

#4
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 7,521 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Hi, the installation is successful when you try with original iatkos USB?
If yes you could try to boot disabling hd2000 from bios and reboot with -v GraphicsEnabler=No after installation, if work, change the string Graphics Enabler in org.chameleon.boot.plist from Yes to No

#5
Scellow

Scellow

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:France
  • Interests:while{true||false}
    {
    dream();
    }

Hi, the installation is successful when you try with original iatkos USB?
If yes you could try to boot disabling hd2000 from bios and reboot with -v GraphicsEnabler=No after installation, if work, change the string Graphics Enabler in org.chameleon.boot.plist from Yes to No

Yes the installation worked, but i unticked every VGA option so i didn't selected ATI too, i disabled the HD 2000 from the bios, but when it boot it won't let me choose option, i got an Blackscreen, and my monitor said "Resolution is too high" (My monitor not the computer) so i can't use those boot flags

Should i need to tick the ATI driver from installation ?


Thanks for your help :)

EDIT :

I tried to tick ATi driver and tick Remove Intel driver but same result .. i can't boot the screen say "Resolution is too high" , i tried to tick an custom resolution but same won't work .. :/

EDIT 2:

I finnaly found how to boot with HD 2000
Tuto here : http://www.macbreaker.com/2012/05/enable-intel-hd-2000-graphics-on-your.html

Summary:
Boot with Windows open Transmac then open your OSX partition, go to System/Library/Extantions then put everything with this file : http://www.mediafire...8gbb8kkzma5z737
Then boot OSX with this boot flag :
GraphicsEnabler=No


I think i'll wait for the 10.8.3 release to try to install driver for HD 7770, but if there is someone who can help me it will be fine :) for me and for other noob like me :P
Thanks !

#6
xmaniak100

xmaniak100

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
  • Gender:Male
  • Location:Prešov
  • Interests:OSX86

Yes the installation worked, but i unticked every VGA option so i didn't selected ATI too, i disabled the HD 2000 from the bios, but when it boot it won't let me choose option, i got an Blackscreen, and my monitor said "Resolution is too high" (My monitor not the computer) so i can't use those boot flags

Should i need to tick the ATI driver from installation ?


Thanks for your help :)

EDIT :

I tried to tick ATi driver and tick Remove Intel driver but same result .. i can't boot the screen say "Resolution is too high" , i tried to tick an custom resolution but same won't work .. :/

EDIT 2:

I finnaly found how to boot with HD 2000
Tuto here : http://www.macbreake...cs-on-your.html

Summary:
Boot with Windows open Transmac then open your OSX partition, go to System/Library/Extantions then put everything with this file : http://www.mediafire...8gbb8kkzma5z737
Then boot OSX with this boot flag :

GraphicsEnabler=No


I think i'll wait for the 10.8.3 release to try to install driver for HD 7770, but if there is someone who can help me it will be fine :) for me and for other noob like me :P
Thanks !


There is a DSDT Edit for it to make it work, which WILL BE required even after the full version of 10.8.3 is out... its not a hard edit... here you go: http://rampagedev.wo...g-with-full-qe/





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy