Jump to content

Dell Inspiron 14z 5423 (only in secure mode)


  • Please log in to reply
64 replies to this topic

#41
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
pueba com 10.2, estos son las smbios para ivy bridge use conforme tu cpu, y en la sabios cambia esto

Mac-6F01561E16C75D06




MacOS:
X86PlatformPlugin
Resources:
Mac-00BE6ED71E35EB86.plist //IM13,1 i5-3470S
Mac-2E6FAB96566FE58C.plist //MBA5,2 i5-3427U
Mac-4B7AC7E43945597E.plist //MacBookPro9,1 i7-3720QM @ 2.60 GHz
Mac-6F01561E16C75D06.plist //MBP9,2 i5-3210M
Mac-7DF2A3B5E5D671ED.plist //MacBookPro9,2
Mac-031AEE4D24BFF0B1.plist //MacMini6.1 i5-3210M @ 2.49 GHz
Mac-66F35F19FE2A0D05.plist //MacBookAir5,1 i5-3317U @ 1.70 GHz
Mac-AFD8A9D944EA4843.plist //MBP10,2 i5-3210M
Mac-C3EC7CD22292981F.plist //MBP10,1 i7-3615QM
Mac-F65AE981FFA204ED.plist //Macmini6,2 i7-3615QM
Mac-FC02E91DDD3FA6A4.plist //iMac13,2 i7-3770 @ 3.40 GHz

#42
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Chile
iFIRE, no tenido suerte con lo del mensaje sobre el cpu. Aún el SO no detecta los pendrives USB. Algún consejo?

#43
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
lo que hace falta es identificar tu chipset de los usb 3.0, si es Asmedia,Caldigit o algún otro, si quieres prueba estos caldigit, instalas com KextWizard /Repair/Perm./reboot haver si hay suerte, ya has mirado si en tu bios esta enable el USB3.0?



Attached File  CalDigit.rar   147.25KB   4 downloads

#44
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Chile
Existe alguna manera para identificar el chipset en linux o os x?
iFIRE, conoces algún kext para mostrar el estado de la bateria?

#45
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
Este es tu chipset
Intel Panther Point Usb 3.0

no lo se, pero seguro que hay, prueba los caldigit primero

At the End on my pc Fujitsu c710 if i DISABLING xHCI mode for USB in BIOS all my port work like 2.0

:weight_lift:

(THX


slayer2333)


and i don't see anyone usb3.0 in system profiler between if enable xHCI mode in BIOS i can see 2 hub 3.0 but it don't work



#46
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Chile
No funciono, el sistema se pega, tuve que desinstalar el kext. La verdad es que prefiero tener solo puertos usb 2.0 si es que se puede...
Vi los comentarios de slayer2333, pero lamentablemente no puedo modificar la bios para deshabilitar el xHCI (no esta esa opción)

Update: El problema del USB ya esta solucionado, sólo tuve que parchar el archivo "IOUSBFamily.kext", no hay necesidad de instalar ningún otro kext. Funciona muy bien, incluso después del "sleep" :)
Ahora creo que sólo falta configurar el "SpeedStep" para el procesador junto con la correcta definición del sistema

#47
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
como los has parchado? me lo puede explicar!!

#48
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Chile
Claro que si:)

Sólo se debe modificar el archivo "IOUSBFamily.kext" insertando el valor (0x1e31) obtenido con el comando lspci -n (linux).

Tengo un pequeño problema si, sólo me funciona un puerto usb; quizá sea por la modificación del DSDT para el sleep. Sería posible que lo revises para descartar si el problema está ahi o no?. Ya que antes de modificar este archivo, tampoco funcionaba el otro puerto.

En cuanto a la definición del sistema; el perfil que mas se ajusta al mio es el "MacBook Air 5,1" ya que este posee el mismo procesador (i5-3317U). Pero aun así, aunque modique el SMBIOS para este modelo, el OS sigue sin reconocer el procesador y tampoco el "SpeedStep". Para completar el perfil he usado los valores que obtuve de la siguiente pagina: http://tdev.me/2010/...hardware-dumps/

Attached Files



#49
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain

<key>AppleUSBEHCI</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleUSBEHCI</string>

<key>IOClass</key>

<string>AppleUSBEHCI</string>

<key>IOPCIClassMatch</key>

<string>0x1e2d8086 0x1e268086</string>

<key>IOPCITunnelCompatible</key>

<true/>

<key>IOProviderClass</key>

<string>IOPCIDevice</string>

<key>IOUserClientClass</key>

<string>IOUSBControllerUserClient</string>

</dict>



edita este kext com el device id que he puesto en esta ruta: /System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBEHCI.kext/Contents/Info.plist

Luego repara/Perm/reboot

#50
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Chile
No funciona iFIRE, al insertar los valores que sugieres; el OS deja de detectar todos los puertos USB
Es extraño, si te fijas en las fotos; aparecen los id del HUB (1e2d y 1e26) pero dice que los dispositivos están conectados al XHCI. Ademas, antes aparecía un tercero (Superspeed) que ahora no aparece. Quizá ese sea el problema. O tal vez la edicion del DSDT hizo desaparecer ese tercer SuperSpeed.

Podrías mostrarme como se hace la edición del DSDT para el sleep con el XHCI?

Attached Files



#51
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
el device id de los EHCI esta correcto nel kext y nel dsdt, talves sea porque tu has modificado el device del XHCI, vuelve dejar como estaba, para hacer una prueba quitas el dsdt de Extra y reboot para ver lo que pasa.

nel DSDT hai dos portos EHCI1 Y EHC2 and dos HUBS y varios devices, y 1 porto XHCI 1 HUB y varios devices, si miras nel DSDT veras que todos tienen el device id inject correcto, este es problema
com device en los kexts.

HUB EHCI Attached File  Captura de pantalla 2013-02-08 a la(s) 18.47.25.png   6.9KB   3 downloads Attached File  Captura de pantalla 2013-02-08 a la(s) 18.49.28.png   16.74KB   3 downloads XHCI + HUB USB 3.0



EHCI1 EHCI 2Attached File  Captura de pantalla 2013-02-08 a la(s) 18.51.12.png   17.65KB   3 downloads

#52
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
http://www.insanelym...i-from-os-1082/
I have Panther USB host controller for USB 3 by tried either adding AllowAnyXhci or your patched filed without success. With the unpatched kext my USB 3.0 are detected as Superspeed USB 3.0 in system profiler, but as soon as i plug anything, the system freezes.
My lappy is an Asus G75VW-BH71-CB. Any ideas ?

Thank you very much for your help. In fact the USB 3.0 worked nativelly without any modifications when i disabled Legacy USB at Bios and Enabled Pre-Boot XHCI. Good speeds and no freezes. Many thanks for your help.

#53
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain

AICPMPatch, edit your post, DON`T post link tonycrap here please!!!


#54
b04r

b04r

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Mexico
  • Interests:Linux,HTML5,CSS3,WebGL,Music,Poetry,CS Geek.
Hi all :D

I'm watching this thread since i have a very similar configuration. What i need to make work Os X on my laptop, apart of the Extra, DSDT mods, and Fixes to USB3 and HDA? There are subtle changes between the configuration on this post and my configuration (a PCI bridge for PCI-Ex and the AMD Radeon 7570 [that is a Muxless one]). Do you think it could work? I really don't care if the AMD one doesn't works. With the integrated one from Intel is fine.

Thanks :3

-----

Hola a todos :D

Desde hace un tiempo que ando mirando este post, porque tengo una Laptop similar. ¿Qué necesitaría para hacerla funcionar acá? Las diferencias que veo son el Puente PCI para el PCI-Express y la Gráfica Discreta AMD HD 7570M (que viene con mi modelo, y hasta donde se, es Muxless, no accede a la pantalla, solo renderiza.) ¿Creen que pueda hacer funcionar la Lap con ML? En realidad no me importa si la AMD funciona o no. Con la integrada tengo suficiente :P

Saludos ^^

--

#55
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Chile
I think; YES
Try it and post screenshots if you can't enter to the installation screen. That is the begin...
Can you disable your dedicated graphics in BIOS?

#56
b04r

b04r

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Mexico
  • Interests:Linux,HTML5,CSS3,WebGL,Music,Poetry,CS Geek.

I think; YES
Try it and post screenshots if you can't enter to the installation screen. That is the begin...
Can you disable your dedicated graphics in BIOS?


It isn't possible to disable the dedicated graphics on BIOS, but i'll try using GraphicsEnabler=No and post the results.

#57
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Chile
Hola iFIRE, por fin pude hacer que el OS reconociera el cpu y con esto el speedstep. Todo anda muy bien.
Tengo una pregunta; como puedo habilitar el audio por HDMI, he leido que se necesita hacer una modificación en el DSDT. Podrías por favor ayudarme con esto. Muchas gracias.

#58
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
que codec de AUDIO TIENES? usas voodoo o AppleHDA?

#59
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
  • Gender:Male
  • Location:Chile
Hola iFIRE, uso AppleHDA...

#60
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
Post Ioreg + DSDT + codec AUDIO ALC....





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy