Jump to content

Dell Inspiron 14z 5423 (only in secure mode)


  • Please log in to reply
64 replies to this topic

#1
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
Hi all,

Am trying to install ML 10.8.2 on this machine, this is what i've done:
1) make a uni### (1.7.0) USB with ML 10.8.2
2) Set Sata option to ACHI in bios
3) boot in verbose mode, but i get "Still waiting for root device". i tried all flags kernel
4) I think this issue is due to USB 3.0, so i've put the PXHCD extension in Extra folder of ##### (1.7.0) USB
5) With that extension, i can boot and reach the installation screen BUT ONLY IN SECURE MODE.

Finished installation, and there is no way to boot without secure mode and neither make to work the HD 4000 after install multi### (5.2.1) (No DSDT)

Specs:

Intel® Core™ i5-3317U CPU @ 1.70GHz
Intel HM77 Chipset
Intel HD 4000 Video
6.00 GB RAM
500GB HDD
32GB SSD
Atheros 9285
Qualcomm Atheros AR8162 PCI-E Fast Ethernet Controller (NDIS 6.30)
IDT High Definition Audio
Only 2 USB port and both are 3.0

Please guys help me, i tried all the things that i know and readed all the posts here and there

Attached Files

  • Attached File  1.jpg   194.42KB   51 downloads
  • Attached File  2.jpg   195.89KB   57 downloads


#2
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
Update: i've remake a uni### USB with Legacy USB support and now is not necessary to put the PXHCD extension on it. But am still can't boot without -x flag :(

#3
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
ok, use esta carpeta Extra que he hecho para ti, mire si te funciona ahora, use para dar o boot com el Installer un porto usb 2.0, reset tu bios F9 para default, ponga en AHCI MODE, Suspend type= S3, HEPT=64Bits, lo demas todo en auto o en dissable, disable usb 3.0.

Suerte!!!!


http://cl.ly/MfUv

#4
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
Wow, muchas gracias iFIRE.
En cuanto a los puertos USB, este laptop sólo tiene 2 puertos y ambos son USB 3.0
De las opciones que dices, en la BIOS de este equipo sólo se puede modificar el modo AHCI (adjunto foto)
He re-creado el USB, usando la herramienta mencionada, pero esta vez he eliminado la carpeta Extra y puesto en su lugar la que has creado para mi
Pregunta: Si el problema son los puertos USB 3.0; no sería bueno probar con un DVD?
iFIRE, también adjunto el archivo DSDT sin compilar aún (.dsl) extraído desde Linux.
Estos son los resultados:

Attached Files

  • Attached File  3.jpg   79.63KB   16 downloads
  • Attached File  4.jpg   219.37KB   14 downloads
  • Attached File  dsdt.zip   33.17KB   6 downloads


#5
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
me puedes mandar lspci -nn de tu hardware, voy a editar algunos kexts para ver si suluciona tu problema


Prueba dar el boot com esta flag, UseKernelCache=No busratio=17 -v GraphicsEnabler=No npci=0x2000


Attached File  DSDTpatched.zip   19.03KB   8 downloads

#6
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
Aqui está el lspci, voy a probar esos flags. Gracias

Acá esta el screenshot con los flags sugeridos

Attached Files



#7
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
cambia tu Extra por esta, ya he incluido el DSDT, dime como te fue, pero tengo una duda, ya tienes el sistema instalado y no puedes arrancar o quieres instalar? copias esta extra para tu usbinstaller, y si ya tienes instalado copia también para raiz de tu disco



Attached File  Extra.zip   467.01KB   15 downloads

#8
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
Logré instalar una vez, pero sólo podía bootear en modo seguro y tampoco pude hacer funcionar la grafica (HD 4000). Ya no tengo el sistema instalado. Recomiendas que instale el sistema de nuevo y trabajar así?
Voy a poner la carpeta Extra nueva al USB, vuelvo en un instante... Gracias

Sigo sin suerte amigo...

Attached Files

  • Attached File  6.jpg   194.75KB   9 downloads


#9
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
lo de la grafica funciona no hay problema, instalas y intenta arrancar y llegar al escritorio, lo importante es que arranque la instalación ni que sea com - x luego esto lo arreglamos

#10
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
Bien, instalaré entonces. Una vez que el OS esté instalado, recomiendas instalar multi#### con el bootloader chimera?

#11
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
Listo iFIRE, sistema instalado, también he habilitado el wifi, what's next?
Es una instalación limpia, no he instalado el bootloader aún, así que no exíste la carpeta Extra
Adjunto LOG

Attached Files



#12
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
Primero usa la app KextWizard repara permissos/rebuild caches/reboot

segundo . copie la ultima Extra para raiz de tu disco, usa la app Chameleon Wizard para probar los EfiStrings, usa uno cada vez, empieza por el primero, pones nel boot.plist y reboto, puede ser que alguno te deje la pantalla en negro, tienes que probar uno por uno hasta que encontré el que te va activar la aceleracion gráfica,



Put one (only one, you can't use multiple device-property keys!) of the following lines into your org.chameleon.Boot.plist:


ig-platform-id: 01660000, Stolen RAM for FB: 96MB, Pipes: 3, Ports: 4, FBMem: 3

Code:

<key>device-properties</key>

<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000000006601140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>

ig-platform-id: 01660001, Stolen RAM for FB: 96MB, Pipes: 3, Ports: 4, FBMem: 3

Code:

<key>device-properties</key>

<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000001006601140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>

ig-platform-id: 01660002, Stolen RAM for FB: 64MB, Pipes: 3, Ports: 1, FBMem: 1

Code:

<key>device-properties</key>

<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000002006601140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>

ig-platform-id: 01660003, Stolen RAM for FB: 64MB, Pipes: 2, Ports: 2, FBMem: 2

Code:

<key>device-properties</key>

<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000003006601140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>

ig-platform-id: 01660004, Stolen RAM for FB: 32MB, Pipes: 3, Ports: 1, FBMem: 1

Code:

<key>device-properties</key>

<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000004006601140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>

ig-platform-id: 01660008, Stolen RAM for FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3

Code:

<key>device-properties</key>

<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000008006601140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>

ig-platform-id: 01660009, Stolen RAM for FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3

Code:

<key>device-properties</key>

<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000009006601140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>

ig-platform-id: 0166000A, Stolen RAM for FB: 32MB, Pipes: 2, Ports: 3, FBMem: 2

Code:

<key>device-properties</key>

<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d00690064000000080000000a006601140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>

ig-platform-id: 0166000B, Stolen RAM for FB: 32MB, Pipes: 2, Ports: 3, FBMem: 2

Code:

<key>device-properties</key>

<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d00690064000000080000000b006601140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>

ig-platform-id: 01620005, Stolen RAM for FB: 32MB, Pipes: 2, Ports: 3, FBMem: 2

Code:

<key>device-properties</key>

<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000005006201140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>


#13
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
Gracias iFIRE, tengo algunas dudas con tu ultimo post:
Realicé el primer paso: pero no tenia nada instalado, aun así era necesario reparar los permisos, etc?. Como no tenia la carpeta Extra ejecute la herramienta sobre S/L/E.
Copie la carpeta Extra a / y repare los permisos para esa carpeta
Instale el bootloader con Chameleon wizard, reinicie y aun no es posible bootear el OS en modo normal
Mi duda, es que si no soy capaz de bootear en modo normal; tiene caso intentar hacer funcionar la grafica? Entiendo que el modo seguro no se activa la grafica por defecto.
Gracias, quedo atento

#14
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
IFIRE, probando uno de los strings, obtengo pantalla negra y no puedo volver al escritorio. Hay alguna forma de iniciar el sistema en mode consola para editar el archivo org.chameleon.Boot.plist?

#15
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
boot com tu USBInstaller y selecione tu disco e escrive cada linea y enter
-s
mount /
cd Extra
rm -rf org.chameleon.boot.plist
diskutil repairPermissions /
reboot -r lnk

pues si en modo -x no te lee los kexts, es como en win modo seguro, -f ignora las caches de los kexts, instala los kexts FakeSMC.kext y NULLCPUPOWERManegemente.kext para S/L/E com KextWizard, luego reparapermissos y reboot com -v


Edit: los passos a sguir es:
1. hacer que tu sistema arranque desde el disco sin el usb, si tienes problemas boot 0 error usa este methodo, instala el ultimo chameleon Chameleon 2.1svn Official PKG Installer & Binaries


ok, this is the second option for install it, download binarios chameleon folder i386
1. open the folder i386 and copy boot1h for your USBInstaller.
2. boot from USBinstaller and go for utilities and open app Terminal
3. type diskutil list for identified your disk and partition were you installed of system ML = "(i.e: disk0s2)"
4. type diskutil unmount disk0s2
5. type cd /
6. type dd if=boot1h of=/dev/disk0s2 bs=4096
7. reboot
in steep 6 put your disk and partition "(i.e disk0s2 "), see your

2. para que te lea los kexts de la graphica tienes que arrancar solo com -v

#16
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
Gracias iFIRE por la info. Probé todos los strings pero ninguno funcionó. Hay alguna otra cosa que se pueda hacer?

#17
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
Buenas noticias iFIRE, por fin pude hacer que el OS detectara la grafica, pero aun solo puedo bootear en modo seguro, y al parecer no tengo aceleración grafica. Alguna idea?

#18
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
Por fin pude solucionar el problema de iniciar en modo seguro; lo hice reemplazando el siguiente archivo:
AppleACPIPlatform.kext
El proximo paso es configurar el audio...

#19
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
update your system para 10.8.2, que codec de audio tienes?

#20
jl4c

jl4c

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 248 posts
  • Gender:Male
  • Location:Chile
Hola iFIRE. Ya estoy en la 10.8.2.
Estoy siguiendo esta guia:http://www.insanelymac.com/forum/topic/283754-patched-applehdakext-for-codecs-idt-92hd81b1x5-idt-92hd91bxx/
Pero no esta la version de graphviz para mountain lion...

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy