Jump to content

Problems trying ti install iatkos ml2 usb onto dell 15r

iatkos ml2

  • Please log in to reply
19 replies to this topic

#1
Robbie1524

Robbie1524

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Been trying to install iatkos ml2 onto a dell 15r second gen i5 but most of the time it stalls patching 64bit xnu kernel with 3 groups of numbers and restarts or it will get past that stage and the screen will stay gray and flicker every few seconds.


Used mac to create usb drive and used usb2 port.

#2
Shaneee

Shaneee

    AMD Dev Tester

  • Local Moderators
  • 1,002 posts
  • Gender:Male
  • Location:Scotland
  • Interests:Web Design. OS X. Music.
Hello. Try removing the KernelPatcher.dylib from the Extra folder on your USB and try boot again.

#3
Robbie1524

Robbie1524

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Removing that file mate sorted out the boot problem with the kernel. The extra foler must have been hidden as i couldn't find the file so had to do a search.
My next problem is that it doesn't show up my drive so i can chose the destination to install as i want to dual boot.

As the mouse is not working at this stage what keys will get me to the top of the screen for the menu bar on the install screen to chose utilities.

#4
Shaneee

Shaneee

    AMD Dev Tester

  • Local Moderators
  • 1,002 posts
  • Gender:Male
  • Location:Scotland
  • Interests:Web Design. OS X. Music.
What kind of mouse are you using? PS2 or USB?

#5
Robbie1524

Robbie1524

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
I am using a usb mouse as i am trying to install onto a dell 15rwhich has no ps2 ports.

If i can't get a mouse to work is there a ctrl + tab type of key combo that will work on my hackintosh so i can select utilities at the top of the page so i can partition this drive that will let me install onto.

If i manged to get past this stage will i leave the setting to default to install the basics that is selected or customize

#6
Shaneee

Shaneee

    AMD Dev Tester

  • Local Moderators
  • 1,002 posts
  • Gender:Male
  • Location:Scotland
  • Interests:Web Design. OS X. Music.
Try booting using USBLegacyOff=Yes to get the mouse to work.

#7
Robbie1524

Robbie1524

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
That setting would work mate but it's not in the dell bios

#8
Shaneee

Shaneee

    AMD Dev Tester

  • Local Moderators
  • 1,002 posts
  • Gender:Male
  • Location:Scotland
  • Interests:Web Design. OS X. Music.
No not in the BIOS. When you boot the USB press F8 and type USBLegacyOff=Yes -v

#9
Robbie1524

Robbie1524

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
The first time i tryed USBLegacyOff=Yes -v it loaded to the installation screen but the mouse still never worked and tryed again this time stopping at

system uptime in nanoseconds

Is this like a lockout before i can try again.

#10
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,375 posts
  • Gender:Male
  • Location:Belgium
  • Interests:OSx86, Cooking, Gadgets.
Include the following kexts on the usb installer, copy them to the extra folder. The appleps2controller should fix the touchpad. The usb kexts well, speaks for itself.

Attached Files



#11
Robbie1524

Robbie1524

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Copied the two files above into the extra folder but made no difference

#12
Shaneee

Shaneee

    AMD Dev Tester

  • Local Moderators
  • 1,002 posts
  • Gender:Male
  • Location:Scotland
  • Interests:Web Design. OS X. Music.
Add these two files to the Extra folder. I used them to get working trackpad and keyboard on my laptop during and after setup.

http://www.mediafire...76zrzud4qg6h58o

#13
Robbie1524

Robbie1524

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Coypied those two files Shane but still no mouse pad or usb mouse action

#14
Shaneee

Shaneee

    AMD Dev Tester

  • Local Moderators
  • 1,002 posts
  • Gender:Male
  • Location:Scotland
  • Interests:Web Design. OS X. Music.
Ok, boot USB, press F8 and type, -x -f -v and try it.

#15
Robbie1524

Robbie1524

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
I think am out of options so how can i use the keyboard to enable me to move up at the toolbar and choose utiltities to partition the drive and install

Used the command -x -f -v

Controller::setConfigstate calling registerservice

still waiting ir root device
still waiting ir root device

#16
Shaneee

Shaneee

    AMD Dev Tester

  • Local Moderators
  • 1,002 posts
  • Gender:Male
  • Location:Scotland
  • Interests:Web Design. OS X. Music.
I'm not sure how you would do that with the keyboard. Try adding this file to System/Library/Extensions on the USB and replace the one thats there and boot using, USBLegacyOff=Yes -f -v

Attached File  IOUSBFamily.kext.zip   1.33MB   67 downloads

#17
Robbie1524

Robbie1524

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
Just tryed the above kext by adding it to System/Library/Extensions and at the loading process it goes through pages and pages of reading all the Extensions but the end is still the same.

#18
plsh2me

plsh2me

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Location:Bangladesh
@Robbie1524: Actually I havn't faced such difficulties on my system,its also a Dell 15R (See on signature).
Just made a USB using myhack. Booted normally !!! & Installed many times...........
Once or twice faced "still waiting root device", in this case reinstalled chameleon (right now using v2069) on USB and successfully booted.
iATKOS ml2 yet not tried, but also successfully installed iATKOS L2 !!!!!!!!

If you yet not tried Myhack - http://myhack.sojuga...yHack-3.1.2.dmg , try with it.

Thank you
Palash

#19
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,375 posts
  • Gender:Male
  • Location:Belgium
  • Interests:OSx86, Cooking, Gadgets.

@Robbie1524: Actually I havn't faced such difficulties on my system,its also a Dell 15R (See on signature).
Just made a USB using myhack. Booted normally !!! & Installed many times...........
Once or twice faced "still waiting root device", in this case reinstalled chameleon (right now using v2069) on USB and successfully booted.
iATKOS ml2 yet not tried, but also successfully installed iATKOS L2 !!!!!!!!

If you yet not tried Myhack - http://myhack.sojuga...yHack-3.1.2.dmg , try with it.

Thank you
Palash


Can you upload your extra folder? For use with myhack.

#20
plsh2me

plsh2me

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Location:Bangladesh
MyHack is already included a generic Extra folder. If you have interest on mine, here it is - Attached File  Extra for both Lion & ML.zip   1.65MB   133 downloads

Thank you
Palash





Also tagged with one or more of these keywords: iatkos ml2


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy