Jump to content

HP630 iATKOS ML2 OK tranne SD Card reader

- - - - -

  • Please log in to reply
3 replies to this topic

#1
cicciopoeta

cicciopoeta

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
  • Gender:Male
Salve a tutti, questo è il mio primo post in questo forum, spero di non essere noioso raccontando di come sono riuscito ad effettuare il mio primo hackintosh e di chiedervi qualche aiutino per le parti mancanti e/o effettuate non al meglio, con le vostre correzioni e consigli. Avevo questo portatile HP630 fermo da rientro aziendale, essendo che tutto sommato non è troppo scarso ho deciso di provare ad installarvi OSX. Questo è stato il primo forum in cui mi sono imbattuto, e tra leggere questo e tanti altri ho raccolto le giuste informazioni e successi insuccessi di installazione su questo portatile. Comunque, in breve, ho utilizzato la distro iAtkos ML2 (non da dvd che non funziona), ma installando da usb tutto andava ok, meno che il boot chameleon si installava sulla usb, e quando provavo ad installarlo sul disco corretto di osx non riuscivo in alcun modo a farlo avviare, per mancanza di esperienza in materia o versione/settaggi non fatti bene, e non volendo tenere la usb sempre collegata non mi sono arreso ed ho fatto così come vi racconterò. Disco in MBR e prima partizione "riservato per il sistema" per il boot del Windows 7, seconda con Windows 7 sopra e ridotta con gestione disco per far spazio per le atre. Quindi la terza e quarta partizione (sempre primarie e non logiche!) create prima da Windows stesso con FAT32 con l'utility gratuita MiniTool partition wizard h.e., con la terza partizione di 9~10Gb riformattata in hfs+ collegando ad un altro pc in usb l'hd del portatile ad una virtual machine con osx con utility disco, e la stessa cosa per la quarta partizione su cui installerò osx. Bene, quindi sempre con utility disco ho ripristinato il dmg di iatkos sulla partizione di 10gb, e li vi ho installato sempre da virtual machine il chameleon che si trova sulla pagina del download ufficiale iatkos. La cosa buona è che ho l'installer sempre pronto, soprattutto in questa fase di TEST del mio primo hackintosh. Poi effettuata l'installazione seguendo i consigli per i portatili HP (pach del kernel da flaggare nelle opzioni) ho installato il tutto. In breve per fare partire sicuro al 100% il pc l'opzione -f di chameleon deve essere sempre attiva, e fin ora l'unica versione che mi funziona è quella della distro di installazione. Gli unici hext che ho installato e modificato sono per il Bluetooth, e funzionano al 100%, compreso test di accoppiamento e funzionalità. Mentre non trovo gli hext per il lettore sd card. Ho provato con le VoodoSDHC e le IOSDHCIBlockDevice ma senza successo. Stessa cosa vale per le Applestoragedrivers, che funzionano solo con con i lettori usb modificando il pid e vid nel file info. Questo perché il lettore è di tipo pciex, e il suo pid è 0x5209 e vid 0x10ec (realtek). Se qualcuno può darmi una mano...io non ho trovato proprio niente oltre quanto descritto se non degli insuccessi, e considerando che oggi sono appena 5 giorni dal mio primo hackintosh, confido in voi. Grazie :help:

#2
Marchrius

Marchrius

    Lo scippatore di emozioni

  • Pandora Team
  • 271 posts
  • Gender:Male
  • Location:Ferrara, Italia
  • Interests:Studente di Informatica.
    Passione/Hobby: Informatica in generale, hackintosh, musica Rock...
Premetto che non ho mai avuto un lettore sd collegato tramite pcie ad un computer ma dando un' occhiata al sito ufficiale realtek ho trovato questo link, provalo...

http://www.realtek.c...3&GetDown=false

#3
raimdal

raimdal

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 153 posts
ciao, un mio amico ha lo stesso notebook, dopo qualche incacchiatura flag del kernel x hp e -f e anche nel suo caso abbiamo iniziato a vedere la luce. Però non trovo un bluetooth funzionante, mi sembra strano perché ho trovato dei link dove wifi e bluetooth erano abbinati nel download . Mi invieresti i tuoi kext? se possibile proprio tutti in un bel zip....Poi non so a te ma sul suo ogni tanto sullo schermo compaiono delle strane distorsioni tipo un quadratino di un centimetro, ho usato una patch per non vedere le linee dovute al tardato refresh tipico delle hd3000 con osx ma ogni tanto compare un quadratino adesso. Cmq è molto poco frequente e solo a certi avvii, se non ci sono da subito si vede perfettamente. Mi invieresti i kext che usi per il tuo ? Il suo ha i3, hd3000, atheros wifi e bluetooth. Grazie mille. per la sd card non ho provato proprio ancora. Sul fatto del flag -f anche nel suo caso non ho potuto evitarlo. Aiutiamoci che su sto notebook si trova ben poco in giro.

#4
raimdal

raimdal

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 153 posts
come non detto al successivo riavvio funziona anche il bluetooth col kext che si trova sul noto sito per scaricare tutti i kext





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy