Jump to content

Error: Nvidia ROM Patching Failed

- - - - -

  • Please log in to reply
38 replies to this topic

#1
4l3xis

4l3xis

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Bueno que tal, soy nuevo en esta comunidad, mi experiencia en hackintosh antes era algo buena pero la abandone un tiempo. Hoy que quiero regresar pues estoy algo oxidado.
Compre una nueva laptop la cual tiene las siguientes especificaciones.

Intel core i7 3630
Intel HD 4000 con nvidia optimus ge force gt 635m 1gb ddr3
Killer ultimate wireless-n 1103

Bueno pensé que la instalacion de mac ps x Mountain Lion seria fácil, pero me encuentro con varios errores.
Tengo un disco duro Sata de 500 gb. En el tengo windows 8, debian 6, fedora 18 e instale mac os por medio de una version Retail de ML llamada OS X 10.8 Install DVD, la restaure en un pendrive de 8 gb e instale chameleon en la USB y pude instalarlo pero no inicia, se queda trabado en una parte que dice algo sobre ntfs, no se si sea el chameleon o el smbios.plist o algun kext que me haga falta, porque mac no me ha iniciado ni una sola vez, solo lo pude instalar. Este metodo es el que mas confio siempre he confiado en chameleon pero no se porque no me inicie mac os x ML.
Después intente usar el método de myhack, esta vez con Lion, descargue La app de Lion y con el myhack cree el pendrive poniendo esta en formato MBR y mas os con registro. Pero esta nisiquira carga el instalador se queda parada en
Error: Nvidia ROM Patching failed
Error: dcbtable_version is 0x4
No se a que se deba o como pueda solucionarlo. Espero haber sido explicito y puedan ayudarme, he leído que ese error es común en el nvidia optimus pero no he encontrado solución de ante mano gracias

#2
4l3xis

4l3xis

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Bueno, quite todos lo NVDA y Geforce Kexts del pendrive.
Instale en el /S/L/E el FakeMC.kext y el NullCPUPO....kext
y ahora ya no me manda ningun error, simplemente carga el verbose y despues de ello la pantalla se queda negra y no sale nada mas, me parcece que es porque no me esta detectando ninguna salida de video o no se a que se deba, en la carpeta Extra no tengo nada ni tampoco poseo un DSDT

#3
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
use esta Extra, ponga en / de tu disco, si tienes problemas par dar el boot deleite all kexts INTEL HD, backup primero, luego deleta de S/L/E, boot com -f -v GraphicsEnabler=No npci=0x2000


Attached File  Extra .zip   53.12KB   46 downloads

#4
4l3xis

4l3xis

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Bueno primero muchas gracias por contestar, mira he avanzado un poco. Antes de colocar el extra que me has dado, descargue la ultima version de chameleon la 2.2sun r2117
Y me ha corrido el ML PERO!!
Solo corre si lo cargo con los flags -v -x
Ningun otro flag corre, inclusive he probado con el PCIRootUID=1 GraphicsEnabler=YES
Ahora el dsdt.aml lo saque de aida64, pero este me dice que mi motherboard era Desconocida no se si eso afecte en algo. Saque el archivo .bin y lo renombre a .aml y con el dsdt autopatcher puse el parche IRQs, RTC y el new HPET.

Aclaro no siempre corre ni con los flags -v -x ya que a veces manda kernel panic hasta con esos flags, utilizo kernel vanilla. Cuando cargo ML recopile esta informacion

Informacion hardware: Imac 12.1
Detecta Resolucion: 1024 x 768 (la resolucion deberia ser de 1968)
Audio: Sonido Intel de alta definicion (no se ha encontrado ni entrada ni salida de audio)
Graficos: GeForce 635m
Unknown 64 mb integrado
Tarjeta Ethernet: Parece que no hay ninguna tareta PCI instalada
Tarjeta PCI: GeForce 635m drivers instalados: SI
wifi: atheros chipset 9380 (pero no detecta nada)

La motherboard es una clevo series W251EFQ/W270EFQ Probare el extra a ver si mejora esto un poco :)

Este es el archivo bin que renombre a .aml con los parches que mencione anteriormente, no se i puedieras decirme si algo le falta o que parches me sugieres. No se si el new HPET es correcto, ya que si ponia solo el parche HPET me marcaba un error y con ese ninguno.

Gracias y espero tu ayuda ;)

Este es el .aml solo lo comprimi

Attached Files



#5
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
boot com -v y saca una foto de donde se para, postea aquí la foto, el DSDT manda sin ningun patch, supongo que es un Laptop no? la Nvidia no funciona en OS X deleta todos kexts NV, repara permisos with KextWizard y reboot, usa esta app para identificar tu Hardware, y postea un screenshot


Attached File  Systeminfo-Mac.zip   389.84KB   13 downloads

#6
4l3xis

4l3xis

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Bueno al poner la carpeta Extra que me pasaste y el archivo dsdt.aml en la misma ya no me manda kernel panic. Pero solo sigue arrancando con los flags -v -x

Antes de poner la carpeta extra me detectada el teclado de la laptop, ahora ya no me lo detecta, por tanto no pude usar el system info

Al hacer un -v tome 3 pantallasos, en estos 3 puntos se para un buen rato

y del ultimo ya no se mueve hasta dar kernel panic, del dsdt no se que parches serian buenos aplicarle ;)

Este es el archivo .bin que me arrojo el Aida64

Attached Files



#7
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
parece que no has leído my anterior post, la respuesta a tu problema esta ahi, por ahora no nescessitas el DSDT, DSDT no hace milagros,

Attached File  Patched.zip   15.74KB   16 downloads

#8
4l3xis

4l3xis

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Ok provare quitando los kext NVDA de la particion de ML, y ya te posteo
Gracias

#9
4l3xis

4l3xis

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Borre los kexts
NVDA y el NVSMU y el ML ya me corre sin kernel Panic. Ahora mis observaciones son las siguientes :P

El ML aun no me detecta los Intel HD 4000
Me gustaria saber si la killer wireless-n 1103 con chip atheros 9300 la detecta ML

#10
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
usa la app systemInfo y postea tu hardware, para saber el device id de tu graphica y wifi

#11
4l3xis

4l3xis

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Bueno aquí esta el screen perdón por la demora :P

Por cierto el teclado ni el touchpad ambos PS/2 me andaban (normal) se supone debía conectar tanto el teclado como el mouse por usb, pero como no tengo teclado instale los sig kexts

AppleACPIPS2Nub.kext
ApplePS2Mouse.kext
ApplePS2Controller.kext
ApplePS2Keyboard.kext

Pero a veces me manda kernel panic, no se si exista alguna manera de ahorrar kexts o bien de configurar los PS/2 por dsdt

Attached Files



#12
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
deleta todos estos kexts que has instalado para el teclado y LA CARPETA Extensions de Extra/Extensions, "supongo que ya tienes instalados en S/L/E FakeSMC.kext y el NULLCPUPM"
instalas estos que estan en la carpeta QUE TE ENVIO en S/L/E com la app KextWizard/ReparaPermissions/rebuidCaches/reboot, TAMBIEN CAMBIA EL ORG.BOOT.PLIST por este que te envio que ya tiene los graphicos injectd, ahora mandame esta kext IO80211Family.kext que es para la wifi y tengo que editar el kext, busca en el report de AIDA64 informacion de la Tarjeta Ethernet y que codec de Audio tienes com su devine id y postea aquí.



Attached File  Kexts org.boot.plist.zip   2.52MB   15 downloads


edit: deleta estos kexts también, son los de NVIDIA.

Attached File  Captura de pantalla 2013-01-24 a la(s) 11.01.13.png   18.73KB   12 downloads

#13
4l3xis

4l3xis

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Te mando el IO80211Faily.kext ahorita recopilo la información del ethernet y del codec de audio del AIDA64

Bueno el Aida me mando un informe del sistema, te lo anexo. Ahora hice lo de borrar los kexts Geforce, y cambiar el org.boot.plist de la carpeta extra y ahora cuando intento arrancar )que ya es mas rapido) sale el
Error: Nvidia ROM Patching Failed y despues de que carga ya sea boot normal o con -v
la pantalla se queda negra, intentare dejando el org.boot.plist al anterior haber si ese es el fallo :P

Gracias iFIRE :)

No se si con este informe baste o falta mas

Attached Files



#14
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
abres el boot plist com chameleon wizard e quita la flag Graphics Enabler y guarda el cambio, prueba otra vez dar el boot, mandame el report de kextwizard donde kexts leidos, quiero ver si lee el kext de la wifi


Attached File  Ethernet kext.zip   98.28KB   3 downloads instala com KextWizard/ReparaPermissos/reboot


Attached File  VoodooHDA-v2.7.4.pkg.zip   216.31KB   10 downloads sonido, dos click en el archivo para instalar, luego com KextWizard/ReparaPermissos/reboot


Attached File  DarwinDumper.app.zip   2.41MB   5 downloads luego mandame un report completo de esta app

#15
4l3xis

4l3xis

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Este es el reporte del kext wizard con los kexts que carga

Por cierto con los kexts PS/2 que me habias mandado anteriormente solo me detecta el teclado, esta bien ? o tambien tendria que detectar el touchpad

Attached Files

  • Attached File  red.tiff   273.8KB   4 downloads


#16
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
mandame el report de DarwinDumper, esto que me enviaste no aparece nila mitad de los kexts



Attached File  VoodooKexts.zip   62.38KB   4 downloads desinstala los dos y instala estos

instala com KextWizard/ReparaPermissos/reboot



#17
4l3xis

4l3xis

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Lo siento pense que solo querias el del wifi :P

En seguida te mando los 2 reportes, el org,chameleon le quite el flag de graphicsEnables con chameleon wizard y ya no manda el
Error: Nvidia ROM Patching Failded pero queda cargando la manzanita con un simbolo de prohibido

El audio anda bien, en seguida te mando los reportes :)

Por cierto Ifire si no es mucha molestia podrías decirme que parches aplicaste al dsdt para llevar nota de lo que tengo y me hará falta investigar. Siempre sobra que investigar y hacer en hackintosh :D
Gracias Ifire

#18
4l3xis

4l3xis

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Este es el reporte de Kext Wizard, el reporte de la otra aplicacion no la pude sacar ya que al llegar al 70% a las tablas ACPI no avanza se queda ahi pensando

El touchpad sigue sin andar, la pila marca una X y algo raro que pasa es que al abir el kext wizard e intentar reparar permisos ya no me aparece disco de destino, solo dice item 2 o item 3

Attached Files



#19
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain
Attached File  Kext Utility.app.zip   267.43KB   2 downloads use esta app para reparrar permissos

#20
4l3xis

4l3xis

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
Listo ya quedaron reparados, creo que hay que ir por partes creo que lo primordial es la wifi, la aceleracion de los intel HD 4000 y el que no se trabe al apagar o reiniciar.
Estuve leyendo este tutorial y por ejemplo decia que para la aceleracion grafica tenias que agregamor el parche de DTGP (del directorio patches que incluye) y el que habilita la Intel 4000:
into method label _DSM parent_adr 0x00020000 remove_entry;
into device name_adr 0x00020000 insert
begin
Method(_DSM,4,NotSerialized)\n
{\n
Store(Package(0x02)\n
{\n
"AAPL,ig-platform-id",\n
Buffer(0x04)\n
{\n
0x04,0x00,0x66,0x01\n
},\n
},Local0)\n
DTGP (Arg0,Arg1,Arg2,Arg3,RefOf(Local0))\n
Return(Local0)\n
}\n
end


Para hacer funcionar mi Atheros fui a windows y vi el Vendor ID + Product ID de mi wifi y edité:
/System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros40.kext/Contents/Info.plist
para agregar un <string>pci168c,2b</string> en la lista de PID + VID que sale en este info.plist

No se que tan cierto cres que sea, al menos intente probarlo y no me funciono no se si hice algo mal

Fuente
http://bakingcode.co...8-2-hackintosh/





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy