Jump to content

Installing 10.6 or newer from a Leopard installation


  • Please log in to reply
No replies to this topic

#1
naquaada

naquaada

    Gates crusher

  • Donators
  • 267 posts
  • Gender:Male
  • Location:Germany
  • Interests:Audio editing, Commodore computers
Hi!

I've got new hardware, after five years:

- Gigabyte GA-Z77-DS3H
- Intel i7 3770K (Ivy Brigde, 4x 3.5 GHz)
- 32 GB RAM
- Sapphire ATI Radeon HD6970 2 GB RAM
- 1 TB WD10EADS-00L5B1 Advanced Format harddrive with GUID table as boot drive
- LG SATA DVD burner

There are some instructions for the Gigabyte board, but they don't care about the OS you are preparing the installation from. I have OS X 10.5.8 AMD, and the most important programs aren't working. I never had a really working Chameleon 2 installer, the one I have (2.1-svn-r2060) doesn't finish the installation. ChameleonWizard needs 10.6 as minimum OS, and System Info needs Java 1.6 which is not available for Leopard.

That's what I did: I formatted a 32 GB USB stick as GUID with 2 partitions, the first for Mountain Lion image and the second for a bootable system. This configuration worked with an 10.5 install DVD, bootable system and Chameleon 1 on MBR. Then I restored the Mountain Lion image to the first USB stick partition and copied the kexts. After this I installed Chameleon 2, but the installation failed, a log file with the mounted volumes was created. As replacement I wrote the package contents to the USB stick using Pacifist. My system is not built up yet, so I tested the stick in my Thinkpad x61 tablet. Like to expect, it didn't boot at all. Then I repartitioned the stick in MBR, copied the Mountain Lion image again and installed Chameleon 1. This worked, but it didn't boot either. But at least there was the bootloader visible, Press any key for options blah blah and the rotating bar. But it didn't react on keys.

The first thing would be to get the correct files to create an bootable USB stick for the installation, but it must work from Leopard. If the Gigabyte board is still capable to run 10.6, it would be great because it's PowerPC compatible. I have an original retail 10.6.3 installation DVD here. I also need 10.6 and 10.7 installers for my Thinkpad x61 tablet. The Gigabyte board should run 10.8 then.

I hope someone can help me without wiki links, I never used Chameleon 2 because it always caused problems on my systems.

Greets, naquaada.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy