Jump to content

HELP TOPIC - further help in chat.osx86.hu/#legacykernel (IRC)

SL ML AMD APU FX Bulldozer

  • Please log in to reply
2281 replies to this topic

#401
Maverick

Maverick

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 249 posts
  • Gender:Male
  • Location:india
  • Interests:Caffeine,Hackintosh,
    AMD hackintosh,
    Technology,

I don't mean to be harsh, but as i already told you, there's not and there will never ever be. Sorry, man, but it's impossible to modify proprietary kexts more than a very limited extent, and to write one from scratch is a task that even software companies with much more resources and qualified personnel than any hackintosh community failed to accomplish. Again, and will be the third time i'll say that (meaning next time i'll remorseless delete the post :P) buy a cheap ATI 4xxx card and be happy.

About iCloud, there's a workaround for it: search for the correspondent topic here in the AMD development section. But it's no easy feat, and you'll need to use a friend's Mac or Intel vanilla hack to do it.

Glad to read things are going well with your hack! Enjoy!

All the best!

@ mac_carol and theconnactic
Hey lit off topic but i have ATI 6770 M 2GB laptop no kext for now :( :( :wallbash:
do you know anything about then tell me

#402
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
I think it might as well be supported. Since it's not AMD hardware, open a topic here: http://www.insanelym.../forum/174-ati/

All the best!

#403
zebaszp

zebaszp

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts

buy a cheap ATI 4xxx card and be happy.

This whole hackintosh + Linux + Windows gaming thing I had going has put me between a rock and a hard place...I think Nvidia drivers lately are a lot better than AMD ones for Linux. For one thing, I can only use open source drivers with my chip because of that "legacy" {censored}. But I digress. I do know, from what I've read, that Nvidia is really bugged on AMD hackintoshes right now. I'll think about it.
Sorry for being so annoying. If there's any way I can help in the AMD development or testing, do let me know. I'm not a programmer (yet), but I'm used to bash, and I'm a fast learner. I don't use OS X as my main OS, so losing it wouldn't be that much of a pain in the ass right now, and I'd love to see this move forward. Go team! :D

#404
Divin3

Divin3

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Buy Mountain Lion, Lion or Snow Leopard, use the VM you have with Leopard to make the installer, then ask help here when and if you get stuck.

All the best!


Well I would if they would work. But I couldn't even got to installation with other distros yet (black screen or stuck at apple logo).
OS X doesen't realy like my FM2 chipset and yet I could only find solutions for am chipsets :worried_anim:

#405
iskorini

iskorini

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts

Well I would if they would work. But I couldn't even got to installation with other distros yet (black screen or stuck at apple logo).
OS X doesen't realy like my FM2 chipset and yet I could only find solutions for am chipsets :worried_anim:

My 3870k boot with fx_kernel for ML, test it.
However I've installed OSX ML (i've used a my friend's mac with this guide http://www.insanelym...-for-beginners/ ) in a USB Drive (HFS+ Journaled Guid Partition Table), but i forgot to put the kernel's file.

Yesterday nigth I succeed to mount in write the usb drive in ubuntu and i put the kernel's file, but the problem is that when i select the key for boot, it switch directly to ssd ignoring it... :(

#406
Bitcore

Bitcore

    AMD Fanboy

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Producing Music
Guys i have a problem.
I am installing Lion right now. I want to install OSX to the second partition of my HDD (First partition is windows 7)
The partition is formatted in NTFS. And AHCI is enabled, but i cant find it in disk utility!
How can i make it visible? Thanks!

Bitcore

#407
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male

Yesterday nigth I succeed to mount in write the usb drive in ubuntu and i put the kernel's file, but the problem is that when i select the key for boot, it switch directly to ssd ignoring it... :(


Did you remember to install Chameleon on the USB stick?


The partition is formatted in NTFS. And AHCI is enabled, but i cant find it in disk utility!


The problem here is your disk is formatted as Master Boot Record. You have to add some files to make your installer see it and effectively write to it, See this guide, there's a link to the files and instructions about how to proceed ("Note 2D"): http://www.insanelym...-for-beginners/

Best regards!

#408
iskorini

iskorini

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts

Did you remember to install Chameleon on the USB stick?

Yep, i've installed this chameleon http://www.insanelym...aller-binaries/ ( Latest Trunk [PKG r2187] iMessage fixed ==> Posted Image Chameleon-2.2svn-r2187.pkg.zip 3.15MB )

#409
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
So it should be able to boot from it. Did you try to set the USB as primary boot device on the BIOS?

#410
iskorini

iskorini

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts

So it should be able to boot from it. Did you try to set the USB as primary boot device on the BIOS?

When appears the splash screen I press on F11 button on the keyboard and i choose USB.
However i test a old nawcom cd and it doesn't recognize the usb drive...
But i have an idea, maybe a bit 'stupid, can I burn Chameleon on a CD?
EDIT: I found Chameleon 2.1svn and i burn it but it doesn't recognize the usb drive o_o

#411
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male

Just for my curiosity,
could you tell me the output of ioreg | grep ATY
and also send me the rom bios file of your vga ?


Of course, Carol. Here:

Attached File  Cedar.rom.zip   38.37KB   4 downloads

Attached File  Screen Shot 2013-03-22 at 11.45.52 AM.png   47.9KB   7 downloads

All the best!

#412
iskorini

iskorini

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
I'm the man of strange cases... ROTFL!
If i use posterior USB 3.0 i can boot my usb drive but... https://dl.dropbox.c...22 16.05.13.jpg

#413
mac_carol

mac_carol

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 148 posts
  • Gender:Not Telling
@theconnactic

thanks for the file :)

a friend of mine has xfx 5450 and maybe I can borrow her card for running some tests under osx
and I will let you know if I can manage to enable the hdmi audio

#414
YaPaY

YaPaY

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Gender:Male
  • Location:Zurich
  • Interests:xbox one
Dear All,

boot.cheamelon.plist:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Graphics Mode</key>
<string>1440x900x32</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>npci=0x2000</string>
<key>device-properties</key>
<string>6a02000001000000010000005e0200000d00000002010c00d041030a000000000101060000020101060000007fff04001e00000072006f006d002d007200650076006900730069006f006e0000002d0000006e5669646961204765466f72636520393830304754204f70656e474c20456e67696e65205b4546495d22000000400030002c006400650076006900630065005f00740079007000650000000b000000646973706c6179100000004e00560043004100500000001800000004000000000003000400000000000007000000000e0000006e0061006d00650000000b000000646973706c617914000000400030002c006e0061006d0065000000120000004e5644412c446973706c61792d41100000006d006f00640065006c000000190000006e5669646961204765466f726365203938303047540e0000004e00560050004d000000200000000100000000000000000000000000000000000000000000000000000014000000400031002c006e0061006d0065000000120000004e5644412c446973706c61792d4220000000400031002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4e564d6163220000005600520041004d002c0074006f00740061006c00730069007a0065000000080000000000002020000000400030002c0063006f006d00700061007400690062006c00650000000e0000004e5644412c4e564d616322000000400031002c006400650076006900630065005f00740079007000650000000b000000646973706c61791c0000006400650076006900630065005f00740079007000650000000f0000004e5644412c506172656e74</string>
</dict>
</plist>


Macos X 10.7.5

Symptoms:

When I enter:

-v -x arch=x86_64 ---> System can boot and my Nvidia card + Monitor recognising from OS correctly
-v arch=x86_64 ---> White screen no mouse cursor
-v arch=i386 ---------> KP Please see the screenshot

http://i.imgur.com/3zDH3R2.jpg

I can boot only safe mode. any help would be apprecited

#415
Bitcore

Bitcore

    AMD Fanboy

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Producing Music

The problem here is your disk is formatted as Master Boot Record. You have to add some files to make your installer see it and effectively write to it, See this guide, there's a link to the files and instructions about how to proceed ("Note 2D"): http://www.insanelym...-for-beginners/

Best regards!

Thanks mate!
It worked, see my post at lion development

#416
iskorini

iskorini

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts

I'm the man of strange cases... ROTFL!
If i use posterior USB 3.0 i can boot my usb drive but... https://dl.dropbox.c...22 16.05.13.jpg

I'm boring, I know :D
What is the problem on the image?

#417
unci

unci

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:indonesia

you could try this kext

VoodooTSCSyncAMD.kext.zip

Thanks but it doesn't work for me but the kext is loaded.. i'm using ML 10.8.2 processor AMD phenom n830 Triple core processor in my laptop.. i also use busratio=105

#418
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male

Dear All,

boot.cheamelon.plist:



Macos X 10.7.5

Symptoms:

When I enter:

-v -x arch=x86_64 ---> System can boot and my Nvidia card + Monitor recognising from OS correctly
-v arch=x86_64 ---> White screen no mouse cursor
-v arch=i386 ---------> KP Please see the screenshot

http://i.imgur.com/3zDH3R2.jpg

I can boot only safe mode. any help would be apprecited


Out of curiosity, 1) do you have the NullCPUPowerManagement.kext in /S/L/Extensions? and 2) (more important) do you have Xcode, including the iPhone SDK?

All the best!

#419
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male

a friend of mine has xfx 5450 and maybe I can borrow her card for running some tests under osx
and I will let you know if I can manage to enable the hdmi audio


Carol, thank you very much, but i already solved the HDMI audio issue with a kext provided by Mirone, plus the fixes i applied myself to solve another HD5450 annoyance, the black screen upon wake issue: PCIRootUID=0 and GraphicsEnabler=No.

http://www.insanelym...a/#entry1899978 see post #17. :D

#420
YaPaY

YaPaY

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 114 posts
  • Gender:Male
  • Location:Zurich
  • Interests:xbox one

Out of curiosity, 1) do you have the NullCPUPowerManagement.kext in /S/L/Extensions? and 2) (more important) do you have Xcode, including the iPhone SDK?

All the best!


1.Yes
2. Xcode I didn't install it.





Also tagged with one or more of these keywords: SL, ML, AMD, APU, FX, Bulldozer


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy